Subject: [Anima] Ben Campbell's No Objection on draft-ietf-anima-stable-connectivity-07: (with COMMENT)

From: Ben Campbell <[email-masked]>
Date: Wed, 10 Jan 2018 16:03:16 -0800

Ben Campbell has entered the following ballot position for
draft-ietf-anima-stable-connectivity-07: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-anima-stable-connectivity/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I am skeptical that there are no normative references at all. Is it reasonable
that a reader could skip all the references and still fully understand this
document?

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 11 Jan 2018 01:36:33 +0100

Thanks, Ben

Pls. check the reply i sent to Alvaro i just sent. It tackles the
issue of whether ACP should be a normative reference.

Your comment makes me more confused about the exact rules for what makes
a reference normative. Initially (when i wrote the stable connectivity draft)
i thought an informational doc should not have normative references because
it did itself not have MUST/SHOULD requirements that could have dependencies.

Later Brian Carpenter i think explained to me this i was wrong, but since then
my understanding is "Reference must be normative if you must support/implement
it to implement/support the current document".

Your comment makes it sound more like "if you must read/understand a reference
then it must be normative". Is that true ? Which RFC/section says so ?

Cheers
    Toerless

On Wed, Jan 10, 2018 at 04:03:16PM -0800, Ben Campbell wrote:
> _______________________________________________
> Anima mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/anima

-- 
---
[email-masked]

---

From: Adam Roach <[email-masked]>
Date: Wed, 10 Jan 2018 18:49:45 -0600

> then it must be normative". Is that true ? Which RFC/section says so ?

That's true. You're looking for 
https://tools.ietf.org/html/rfc7322#section-4.8.6

    Reference lists must indicate whether each reference is normative or
    informative, where normative references are essential to implementing
    or understanding the content of the RFC and informative references
    provide additional information.

The IESG's guidance on this topic is posted here, and it provides some 
additional rationale for these criteria: 
https://www.ietf.org/iesg/statement/normative-informative.html

/a

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 11 Jan 2018 02:51:55 +0100

Thanks, Adam, i had overlooked the "or understandding the content" first
time i've been round the block!

In any case, see reply to Alvaros original DISCUS why i think ACP does not
need to be normative reference, and that IMHO also applies to the "understanding"
part.

Cheers
    Toerless

On Wed, Jan 10, 2018 at 06:49:45PM -0600, Adam Roach wrote:
> The IESG's guidance on this topic is posted here, and it provides
> some additional rationale for these criteria:

---

From: Ben Campbell <[email-masked]>
Date: Wed, 10 Jan 2018 20:42:24 -0600

> time i've been round the block!

Thanks also to Adam for explaining my point before I got to it :-)

A sometimes useful thought experiment is whether you think a normal reader would fully understand the points you are making if they didn’t read the cited reference.

> need to be normative reference, and that IMHO also applies to the "understanding"

I wasn’t picking on that (or any other) reference in particular; just the fact there were no normative references. It’s certainly possible that none of them should be normative, but that would be an unusual case.

Thanks!

Ben.

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 17 Jan 2018 03:33:11 +0100

Thanks, Ben

I just posted -08: https://tools.ietf.org/id/draft-ietf-anima-stable-connectivity-08.txt

Wrt. your comment.

I did create for -08 a section of normative references. IN reply
to Alvaros DISCUSS i wrote:

> I went through the references and made those normative where i thought
> rfc7322#section-4.8.6 "are essential to ... understanding the content"
> applies. 
> 
> This set is of course somewhat subjective. Eg.: there is nothing special
> to know about RFC6434, so its kept informational. On the other hand, if
> you're a poor enterprise requiring to use any of the nasty NAT options
> mentioned, you really want to read up on SIIT (RFC7915), so i made that
> normative. Most customers i talked to did not know ULA (rfc4193), so i made it
> normative. For fairness so then did the same for rfc1918.

I hope this addresses your comment.

Cheers
    toerless

-- 
---
[email-masked]