Subject: [Anima] Comments from Alex G. on draft-carpenter-anima-asa-guidelines

From: "Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Tue, 20 Mar 2018 10:39:58 +0000

Hi Alex,

Thanks for your comments on draft-carpenter-anima-asa-guidelines.

If I get it correctly you raised the following points:

  1.  -better describe what ASA are: rather application or network service, and better describe the border between the two and implications for ASA designers/developers in the draft.

I think it is an important (and not so simple) topic and worth being discussed.

Would welcome views from the group.

  1.  -NFV is an important area for future networks, and more focus for ANIMA and ASA should be devoted.

Agreed; However, I'm not aware that NFV community is following ANIMA work and guidelines on autonomic VNF design/development. Although there are several autonomic/self-* behavior/functionality being developed in NFV.

There is clearly a gap here, and a difference in approach.

  1.  -You mentioned something about the decoupling of self-* functionality (self-configuration, self-healing...)

Not sure I get fully what was your comment on this aspect. Could you clarify / develop?

Thank you.
Best regards, Laurent.

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 21 Mar 2018 09:00:52 +1300

> Would welcome views from the group.

Yes, these are aspects that we discussed in NMRG and also in the UCAN BOF and early
days of the WG. Probably we have most of the points scattered around in various
documents and meeting minutes, but we need to collect them in one place.

> There is clearly a gap here, and a difference in approach.

I couldn't find an adequate reference for NFV, which is why the drafts says
[reference needed]. I didn't find a clear definition of "microservices" either,
which is why I didn't use the term.

I think autonomic networking is a new form of network management. Is there
anything wrong with the current statement?
  "For example, the services envisaged for
   network function virtualisation [reference needed] or for service
   function chaining [RFC7665] might be managed by an ASA rather than by
   traditional configuration tools."

An ASA to manage SFC might be an interesting use case to develop.
 
> Not sure I get fully what was your comment on this aspect. Could you clarify / develop?

Again, I think this is a use case issue. The way these self- properties
interact is surely not the same in all cases?

    Brian