Subject: [Anima] Ben Campbell's No Objection on draft-ietf-anima-reference-model-08: (with COMMENT)

From: Ben Campbell <[email-masked]>
Date: Wed, 24 Oct 2018 16:08:41 -0700

Ben Campbell has entered the following ballot position for
draft-ietf-anima-reference-model-08: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-anima-reference-model/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Thanks for the work on this. I just have one editorial comment:

- Several sections describe themselves as being for "informational purposes".
Given that this is an informational document, isn't that true of all sections?

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 25 Oct 2018 14:10:10 +1300

Hi Ben,

On 2018-10-25 12:08, Ben Campbell wrote:
...

Those sections are among the ones tagged (*) as per:

>>    Some topics are considered architecturally
>>    in this document, but are not yet reflected in the implementation
>>    specifications.  They are marked with an (*).

Possibly the (*) is sufficient and the phrase you mention can be removed.

   Brian

---

From: Ben Campbell <[email-masked]>
Date: Wed, 24 Oct 2018 21:33:04 -0500

> On Oct 24, 2018, at 8:10 PM, Brian E Carpenter <[email-masked]> wrote:
> 
> Hi Ben,
> 
> ....

I think that could help. Or alternatively, put a few extra words in the (*) sections to remind people what it means :-)

Thanks!

Ben.

---

From: "Michael H. Behringer" <[email-masked]>
Date: Thu, 25 Oct 2018 10:43:13 +0200

Hi Ben, thanks for your review!

Yes, we're a bit "verbose" with those topics. There was a consistent 
worry all through our work to distinguish phase 1 and phase 2 work, and 
to not let phase 2 work creep into phase 1. So we probably erred on the 
more "explicit" wording, trying to make REALLY sure everybody 
understands what's in scope for phase 1 or not.

Unless you have a real concern at some specific points, I would prefer 
to not open those debates again. Yes, from a language point of view 
there is redundancy, but at least we're being very clear.

Michael

---

From: Ben Campbell <[email-masked]>
Date: Thu, 25 Oct 2018 10:18:18 -0500

Hi Michael,

My real concern is that “informational” is a term of art in the IETF, and the use of it to label “later phase” sections is a different use than that.

I will leave it to the authors to decide if that would be confusing to the target audience.

Thanks!

Ben.

> On Oct 25, 2018, at 3:43 AM, Michael H. Behringer <[email-masked]> wrote:
> 
> Yes, we're a bit "verbose" with those topics. There was a consistent worry all through our work to distinguish phase 1 and phase 2 work, and to not let phase 2 work creep into phase 1. So we probably erred on the more "explicit" wording, trying to make REALLY sure everybody understands what's in scope for phase 1 or not.
> 
> Unless you have a real concern at some specific points, I would prefer to not open those debates again. Yes, from a language point of view there is redundancy, but at least we're being very clear.
> 
> Michael
> 
>

---

From: "Michael H. Behringer" <[email-masked]>
Date: Thu, 25 Oct 2018 21:47:16 +0200

Ah, now I understand. Thanks for clarifying. Yes, we really used it as 
sort of a "boiler plate" for topics that are not part of this phase of 
ANIMA work. I guess we just introduced (informational)^2.

I'm happy to change that "boiler plate" text.  What about "This section 
discusses a topic for further research".

I guess we can edit that when we get to the RFC Editor queue.

Michael

---

From: Ben Campbell <[email-masked]>
Date: Thu, 25 Oct 2018 15:35:00 -0500

""This section discusses a topic for further research” sounds good to me.

Thanks!

Ben.

> On Oct 25, 2018, at 2:47 PM, Michael H. Behringer <[email-masked]> wrote:
> 
> Ah, now I understand. Thanks for clarifying. Yes, we really used it as sort of a "boiler plate" for topics that are not part of this phase of ANIMA work. I guess we just introduced (informational)^2.
> 
> I'm happy to change that "boiler plate" text.  What about "This section discusses a topic for further research".
>