Subject: [Anima] $transport-proto in BRSKI

From: Michael Richardson <[email-masked]>
Date: Fri, 01 Mar 2019 16:34:27 -0500

Brian, we have CDDL in BRSKI:

ipv6-address      = the v6 LL of the Proxy
$transport-proto /= IPPROTO_TCP   ; note this can be any value from the
                                 ; IANA protocol registry, as per
                                 ; [GRASP] section 2.9.5.1, note 3.

and we don't know why we have a $ on transport-proto.
Maybe it's a typo.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 2 Mar 2019 11:43:03 +1300

> and we don't know why we have a $ on transport-proto.

I think it's a typo. As additional evidence, the comment is one space
too far to the right. Editorial fix!

    Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 8 Mar 2019 10:13:15 +1300

Sigh. I was wrong. The $ sign is legal CDDL:

> Per convention, CDDL extension points are marked with a leading
> dollar sign (types) or two leading dollar signs (groups).
[draft-ietf-cbor-cddl-07]

It isn't *required* but it shows that the item in question is expected
to be extended in future.

So either include it or don't, but at the moment there's a nit in
your text: the syntax says
> transport-proto /= IPPROTO_TCP
but the following paragraph says:
> The $transport-proto above indicates the method...

Otherwise, fwiw I'm happy with bootstrapping-keyinfra-19.

   Brian

---

From: Michael Richardson <[email-masked]>
Date: Fri, 08 Mar 2019 13:03:06 -0500

> Otherwise, fwiw I'm happy with bootstrapping-keyinfra-19.

I noticed that extra $ when reading the diff, and removed it.
I will put them all it back: I found another location where it belongs.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-