Subject: [Anima] Potential Milestones for ANIMA new charter

From: Sheng Jiang <[email-masked]>
Date: Fri, 15 Mar 2019 06:51:27 +0000

Hi, Toerless,

I am working on the charter text. It is not difficult to categetied the work items into 4 classes: ANI+, ASA, BRSKI, Use cases. I am intending to put NOCs into ANI+. I will send you a reword version on next Monday.

For milestones, giving that we have a long document waiting list as long as 20. It would not sufficient to satisfy everyone for just 5 milestones by saying everyone should have no more than one document through. We would face more than 10 individuals asking for adoption. Anyway, here are my choice for the first 5:

ASA Lifecycle (Lucent)
ASA guideline (Brian C)
GRASP Distribution (Bing Liu)
Constrained Join Proxy for Bootstrapping Protocols (Michael R.)
+ One BRSKI document

This would looks good when we face IESG. Then, we may able to adopt 2 or 3 more document out of written milestones, I guess. But it would looks bad if we have more than 10 WG document parallel. PS: we still have 7 WG documents showing now, though 3 of them passed IESG review and waiting by MISREF - ACP!

Cheers,

Sheng

---

From: Eliot Lear <[email-masked]>
Date: Fri, 15 Mar 2019 16:17:58 +0100

Hi Sheng,

Forgive me, but I believe that the charter text above the milestones needs a touch up.  I also see somewhere around six drafts worth of BRSKI work coming down the pike on their own.  They are:

draft-ietf-anima-constrained-voucher
draft-ietf-anima-contrained-voucher
draft-fries-anima-brski-async-enroll
draft-lear-eap-teap-brski
draft-vanderstok-anima-constrained-join-proxy
draft-richardson-anima-smarkarklink

And I expect that draft-lear-brski-pop will live to see another day.

Now it may be the right thing to split off this work into a separate WG, or it may be the right thing to continue in ANIMA.  I expect that some of the above can also consolidate, but there’s still a lot of work to be done, and cramming all of that into one draft would be inadvisable ;-)

Eliot

> On 15 Mar 2019, at 07:51, Sheng Jiang <[email-masked]> wrote:
> 
> Hi, Toerless,
> 
> This would looks good when we face IESG. Then, we may able to adopt 2 or 3 more document out of written milestones, I guess. But it would looks bad if we have more than 10 WG document parallel. PS: we still have 7 WG documents showing now, though 3 of them passed IESG review and waiting by MISREF – ACP!
> 
> Cheers,
> 
> Sheng
> _______________________________________________
> Anima mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/anima <https://www.ietf.org/mailman/listinfo/anima>

---

From: Sheng Jiang <[email-masked]>
Date: Sat, 16 Mar 2019 00:56:26 +0000

Hi, Eliot,

As you know, the charter text is different from the milestones. In charter text, we will have a paragraph to describe the BRSKI relevant works. In principle, all BRSKI works, even those have not been mentioned, would be covered. So, BRSKI works, no matter they are listed as milestones or not, are in WG scope.

Milestones are these work items that WG MUST deliver in a limited time, say a year or one and half years. So, as WG chairs, we would like to have a shorter list for each period, for which every work item has enough energy to complete in time. This is also IESG would like to see. We could easily add milestones later when the WG had shown enough interests and energy for new in-scope works.

“+ One BRSKI document” means newly adopt one more BRSKI document. The reason that we do not want too many new BRSKI document immediately is that the WG need energy to guarantee the current adopted BRSKI works, including the main BRSKI document and constrained voucher, to be completed as soon as possible with high quality.

Regards,

Sheng

From: Eliot Lear [mailto:[email-masked]]
Sent: Friday, March 15, 2019 11:18 PM
To: Sheng Jiang <[email-masked]>
Cc: Toerless Eckert <[email-masked]>; Toerless Eckert <[email-masked]>; [email-masked]
Subject: Re: [Anima] Potential Milestones for ANIMA new charter

Hi Sheng,

  *   draft-ietf-anima-constrained-voucher
  *   draft-ietf-anima-contrained-voucher
  *   draft-fries-anima-brski-async-enroll
  *   draft-lear-eap-teap-brski
  *   draft-vanderstok-anima-constrained-join-proxy
  *   draft-richardson-anima-smarkarklink

Eliot

On 15 Mar 2019, at 07:51, Sheng Jiang <[email-masked]<mailto:[email-masked]>> wrote:

Hi, Toerless,

ASA Lifecycle (Lucent)
ASA guideline (Brian C)

Cheers,

Sheng
_______________________________________________
Anima mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/anima

---

From: Eliot Lear <[email-masked]>
Date: Sat, 16 Mar 2019 08:34:00 +0100

Hi Sheng,

> On 16 Mar 2019, at 01:56, Sheng Jiang <[email-masked]> wrote:
> 
> Hi, Eliot,
> 

Thanks.  That’s what I was aiming at.  Are you looking for some proposed text?

> “+ One BRSKI document” means newly adopt one more BRSKI document. The reason that we do not want too many new BRSKI document immediately is that the WG need energy to guarantee the current adopted…

I think we’re coming close to needing a bit of a work plan for just the BRSKI documents alone.  That is- it’s not just how many documents but which ones, in order to accomplish which functions.  At this point, I am presuming that the base document is just about done.  The constrained-voucher doc looks like it needs to get pushed over the finish line.  And then, it seems to me our chartering discussion might do well to focus down a bit on what is needed for different operating environments, so as to help sort overlap in drafts with an understanding of who wants to commit what code.

Eliot

---

From: Michael Richardson <[email-masked]>
Date: Sat, 16 Mar 2019 17:04:06 -0400

Eliot Lear <[email-masked]> wrote:
    > I think we’re coming close to needing a bit of a work plan for just the BRSKI
    > documents alone. That is- it’s not just how many documents but which ones, in
    > order to accomplish which functions. At this point, I am presuming that the
    > base document is just about done.

Yes, In theory it's back in the ADs' hands to put in the IESG queue.
I hope that the three reviews will be enough; but I suspect that there will
be a bunch of mis-understandings from some quarters that will need to get
resolved.

    > The constrained-voucher doc looks like it
    > needs to get pushed over the finish line.

Yes.  The EST-COAPS part is done, the voucher part is done.
There are some hangups with references in CORE (SID stuff) that is going to
MISSREF badly once we get into the RFC editor queue.

    > And then, it seems to me our
    > chartering discussion might do well to focus down a bit on what is needed for
    > different operating environments, so as to help sort overlap in drafts with
    > an understanding of who wants to commit what code.

1) I think we will need to write some contrasting use case documents.
2) We will need some additional real-world experience.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-