Subject: [Anima] Call for agenda ANIMA @ IETF 104， Prague

From: Sheng Jiang <[email-masked]>
Date: Fri, 8 Mar 2019 06:59:16 +0000

Hi, all anima,

We have been allocated a session of 2-hour for the ANIMA WG meeting for IETF-104 (Prague) - Tuesday afternoon session I. We are now starting to collect agenda items for the session. Please send your request for agenda by March 14th, Thursday.

For this coming meeting, we would like to discuss potential future ANIMA works. As normal, the priority among these non-charter work items would be: these that have active discussion in mail list, then these have submitted drafts, and topics without drafts.

Please send us (anima-chairs at ietf.org<https://ietf.org/>) requests for time slot by March 14th, Thursday and include:

Name of time slot:

Name of draft(s):

Time requested:

Presenter name(s):

More details about the IETF 104, Prague can be found at:

https://www.ietf.org/how/meetings/104/

Again, presenters and draft authors please invoke active discussions in the ANIMA list. Mail list is a very good place to discuss and reach consensus on technical issues.

Best regards,

Toerless & Sheng

---

From: Xun Xiao <[email-masked]>
Date: Fri, 8 Mar 2019 11:39:21 +0000

Hi Sheng,

We would like to have a time slot to report the update we made for the information-distribution draft (including updates. Thanks.

Name of time slot: Updates on Information Distribution in Autonomic Networking

Name of draft(s): draft-liu-anima-grasp-distribution-10

Time requested: 10 mins

Presenter name(s): Xun Xiao and Artur Hecker

Best Regards,

Xun Xiao (肖迅)
Advanced Wireless Technology Lab
Munich Research Center

From: Anima [mailto:[email-masked]] On Behalf Of Sheng Jiang
Sent: Friday, 8 March 2019 07:59
To: [email-masked]
Cc: [email-masked]
Subject: [Anima] Call for agenda ANIMA @ IETF 104， Prague

Hi, all anima,

Name of time slot:

Name of draft(s):

Time requested:

Presenter name(s):

Best regards,

Toerless & Sheng

---

From: Sheng Jiang <[email-masked]>
Date: Mon, 11 Mar 2019 11:31:10 +0000

Hi, Xiao,

I can confirm your request. The chairs would allocate time according to the application situation and priority policy.

Regards,

Sheng

From: Xun Xiao
Sent: Friday, March 08, 2019 7:39 PM
To: Sheng Jiang <[email-masked]>; [email-masked]
Cc: [email-masked]; Artur Hecker <[email-masked]>
Subject: RE: Call for agenda ANIMA @ IETF 104， Prague

Hi Sheng,

Time requested: 10 mins

Best Regards,

Xun Xiao (肖迅)

From: Anima [mailto:[email-masked]] On Behalf Of Sheng Jiang
Sent: Friday, 8 March 2019 07:59
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [Anima] Call for agenda ANIMA @ IETF 104， Prague

Hi, all anima,

Name of time slot:

Name of draft(s):

Time requested:

Presenter name(s):

Best regards,

Toerless & Sheng

---

From: Toerless Eckert <[email-masked]>
Date: Mon, 11 Mar 2019 16:33:56 +0100

ACP update slot pls.

On Mon, Mar 11, 2019 at 11:31:10AM +0000, Sheng Jiang wrote:
> Subject: RE: Call for agenda ANIMA @ IETF 104?? Prague
> 
> Hi Sheng,
> 
> Xun Xiao (????)
> Subject: [Anima] Call for agenda ANIMA @ IETF 104?? Prague
> 
> 
> Hi, all anima,
> 
> 
> 

> _______________________________________________
> Anima mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/anima

---

From: Eliot Lear <[email-masked]>
Date: Mon, 11 Mar 2019 18:44:02 +0100

Hi Sheng Jiang,

I think we had a lengthy conversation about BRSKI next steps, and that we should expect to spend some time on this in ANIMA.  I think I count at least four drafts that are worth considering, and Michael might have more in mind:

Draft-vanderstock-anima-constrained-join-proxy
Draft-lear-eap-teap-brski
Draft-ietf-6tisch-{…}
Draft-fries-anima-brski-async-enroll

How would you like to organise that conversation?

Eliot

> On 8 Mar 2019, at 07:59, Sheng Jiang <[email-masked]> wrote:
> 
> Hi, all anima,
> 
> Please send us (anima-chairs at ietf.org <https://ietf.org/>) requests for time slot by March 14th, Thursday and include:
> 
> Name of time slot:
> Name of draft(s):
> Time requested:
> Presenter name(s):
>

---

From: Michael Richardson <[email-masked]>
Date: Mon, 11 Mar 2019 15:34:45 -0400

Eliot Lear <[email-masked]> wrote:
    > I think we had a lengthy conversation about BRSKI next steps, and that we
    > should expect to spend some time on this in ANIMA. I think I count at least
    > four drafts that are worth considering, and Michael might have more in mind:

    > * Draft-vanderstock-anima-constrained-join-proxy
    > * Draft-lear-eap-teap-brski
    > * Draft-ietf-6tisch-{…}

    > * Draft-fries-anima-brski-async-enroll
{Eliot: Does this document include Oskar's requirements?}

Additional documents that call on BRSKI:

* draft-richardson-anima-smarkaklink (formerly draft-richardson-anima-smartpledge)
   -> I have revised slides, and I walk to talka bout them.
      I believe that it solves draft-fries-anima-brski-async-enroll as well,
      but I haven't read the entire document yet.

* draft-reddy-dprive-bootstrap-dns-server
* draft-boucadair-dots-server-discovery
  --> some details are still TBD.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Sheng Jiang <[email-masked]>
Date: Tue, 12 Mar 2019 01:54:37 +0000

Hi, Eliot & Michael R.

Thanks for your email. I confirm your request and also the priority of BRSKI relevant discussion. It would follow just after the WG documents update and WG re-chartering unscrambling. Actually, I agree the discussion of BRSKI next steps is part of WG recharter. We could skip the BRSKI part in the re-chartering unscrambling.

Regards,

Sheng

> -----Original Message-----
> From: Michael Richardson [mailto:[email-masked]]
> Sent: Tuesday, March 12, 2019 3:35 AM
> To: Eliot Lear <[email-masked]>
> Cc: Sheng Jiang <[email-masked]>; [email-masked];
> [email-masked]
> Subject: Re: [Anima] Call for agenda ANIMA @ IETF 104， Prague
> 
> 
> Michael Richardson <[email-masked]>, Sandelman Software Works  -=
> IPv6 IoT consulting =-

---

From: Sheng Jiang <[email-masked]>
Date: Tue, 12 Mar 2019 04:00:04 +0000

Hi, Toerless,

Your request is noted.

Regards,

Sheng

> From: Toerless Eckert [mailto:[email-masked]]
> Sent: Monday, March 11, 2019 11:34 PM
> To: Sheng Jiang <[email-masked]>
> Cc: Xun Xiao <[email-masked]>; [email-masked]; [email-masked];
> Artur Hecker <[email-masked]>
> Subject: Re: [Anima] Call for agenda ANIMA @ IETF 104?? Prague
> 
> ACP update slot pls.
> 
> > I can confirm your request. The chairs would allocate time according to the
> application situation and priority policy.
> >
> > Regards,
> >
> > Sheng
> >
> > From: Xun Xiao
> > We would like to have a time slot to report the update we made for the
> information-distribution draft (including updates. Thanks.
> >
> >
> > We have been allocated a session of 2-hour for the ANIMA WG meeting for
> IETF-104 (Prague) - Tuesday afternoon session I. We are now starting to collect
> agenda items for the session. Please send your request for agenda by March
> 14th, Thursday.
> >
> >
> >
> > For this coming meeting, we would like to discuss potential future ANIMA
> works. As normal, the priority among these non-charter work items would be:
> these that have active discussion in mail list, then these have submitted drafts,
> and topics without drafts.
> >
> >
> >
> > Please send us (anima-chairs at ietf.org<https://ietf.org/>) requests for time
> slot by March 14th, Thursday and include:
> >
> >
> >
> > Name of time slot:
> >
> > Name of draft(s):
> >
> > Time requested:
> >
> > Presenter name(s):
> >
> >
> >
> > Again, presenters and draft authors please invoke active discussions in the
> ANIMA list. Mail list is a very good place to discuss and reach consensus on
> technical issues.
> >
> >
> >
> > Best regards,
> >
> >
> >
> > Toerless & Sheng
>

---

From: Eliot Lear <[email-masked]>
Date: Tue, 12 Mar 2019 06:40:59 +0100

Hi Sheng,

> On 12 Mar 2019, at 02:54, Sheng Jiang <[email-masked]> wrote:
> 
> Hi, Eliot & Michael R.
> 

Thank you.  I think this is an important aspect of the recharter.

Eliot

---

From: "Fries, Steffen" <[email-masked]>
Date: Tue, 12 Mar 2019 08:23:03 +0000

Hi Michael, hi Eliot,

>       but I haven't read the entire document yet.
I just read across draft-richardson-anima-smarkaklink and to my understanding it focuses on the voucher exchange in situations where the domain registrar is only temporary available. The voucher exchange is currently only touched  in draft-fries-anima-brski-async-enroll for the voucher exchange, while the main focus is on the certification request/response exchange. It is based on a self-contained object binding the initial pledge authentication to the certification request allowing to perform the authorization of the certification request in a different component than a local domain registrar. In that aspect it has a different scope than draft-richardson-anima-smarkaklink. 

Best regards
Steffen

> Michael Richardson <[email-masked]>, Sandelman Software Works  -= IPv6 IoT consulting =-

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 13 Mar 2019 14:36:55 +1300

Confirming this request on the list:

15 minutes for draft-carpenter-anima-l2acp-scenarios-00

Scenarios and requirements for Autonomic Control Planes
(ACPs) constructed and secured at Layer 2.

Speaker: Bing Liu (remote)

Regards
   Brian Carpenter

---

From: Sheng Jiang <[email-masked]>
Date: Wed, 13 Mar 2019 01:45:51 +0000

Thanks, Brian & Bing.

Your request is noted.

Sheng

> From: Brian E Carpenter [mailto:[email-masked]]
> Sent: Wednesday, March 13, 2019 9:37 AM

---

From: Michael Richardson <[email-masked]>
Date: Tue, 12 Mar 2019 23:20:42 -0400

> I just read across draft-richardson-anima-smarkaklink and to my
    > understanding it focuses on the voucher exchange in situations where
    > the domain registrar is only temporary available. The voucher exchange

My focus on writing it is bootstrapping a registrar.
As such, the protocol flow does not include direct access to a registrar.
Oskar shared your requirements with me, and I think that we accomodate it in
the same protocol.

    > different component than a local domain registrar. In that aspect it
    > has a different scope than draft-richardson-anima-smarkaklink.

I think this discussion should be interesting!

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 13 Mar 2019 16:49:13 +1300

> I think this discussion should be interesting!

Having read both, I believe they address different scenarios at the
moment. Explain to me how you'd add a new batch of a few hundred widgets
to a building services network at 3 a.m. Sunday morning using smarkalink.
I thought that was pretty clear using brski-async-enroll. On the other
hand I don't see Joe Average Citizen using brski-async-enroll to set
up a new CE and small office network.

Maybe we can get the goals and scenarios clear.

   Brian