Subject: Re: [Anima] I-D Action: draft-richardson-anima-registrar-considerations-00.txt

From: Brian E Carpenter <[email-masked]>
Date: Tue, 3 Dec 2019 12:56:31 +1300

Hi,

This looks like all good stuff to me and I don't have much to say.

> The domain is embodied by the Registrar component.

I think that's a step too far, because the Registrar doesn't
do anything to establish the domain boundary and which nodes
are at the edges of the domain. So I think it's better to say

"The Registrar component embodies the identity, membership and
trust anchor of the domain."

[The identity being the DomainID, and the membership being the
set of currently enrolled pledges. The registrar is the trust
anchor because it either contains or interfaces with the CA.]

>    This document, while a Best Current Practices, makes use of BCP14
>    language to indicate which practices are mandatory, and which ones
>    are just recommendations.

Did you mean to write "while *not* a BCP"? In any case you've
tagged the draft for the standards track, which seems wrong.

Regards
   Brian

On 03-Dec-19 04:16, [email-masked] wrote:
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
>         Title           : Operational Considerations for BRSKI Registrar
>         Author          : Michael Richardson
> 	Filename        : draft-richardson-anima-registrar-considerations-00.txt
> 	Pages           : 18
> 	Date            : 2019-12-02
> 
> Abstract:
>    This document describes a number of operational modes that a BRSKI
>    Registration Authority (Registrar) may take on.
> 
>    Each mode is defined, and then each mode is given a relevance within
>    an over applicability of what kind of organization the Registrar is
>    deployed into.  This document does not change any protocol
>    mechanisms.
> 
>    This document includes operational advice about avoiding unwanted
>    consequences.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-richardson-anima-registrar-considerations/
> 
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-richardson-anima-registrar-considerations-00
> https://datatracker.ietf.org/doc/html/draft-richardson-anima-registrar-considerations-00
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>

---

From: Michael Richardson <[email-masked]>
Date: Wed, 04 Dec 2019 10:09:22 -0500

> trust anchor of the domain."

Thank you.

    > tagged the draft for the standards track, which seems wrong.

I meant to mark it as BCP (fixing), or perhaps it would informational.
I'm not really sure if makes sense to publish it in any rush.
Perhaps it belongs in a book or white paper.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-