Subject: [Anima] I-D Action: draft-ietf-anima-grasp-api-06.txt

From: [email-masked]
Date: Fri, 12 Jun 2020 13:04:00 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Autonomic Networking Integrated Model and Approach WG of the IETF.

        Title           : Generic Autonomic Signaling Protocol Application Program Interface (GRASP API)
        Authors         : Brian Carpenter
                          Bing Liu
                          Wendong Wang
                          Xiangyang Gong
	Filename        : draft-ietf-anima-grasp-api-06.txt
	Pages           : 30
	Date            : 2020-06-12

Abstract:
   This document is a conceptual outline of an application programming
   interface (API) for the Generic Autonomic Signaling Protocol (GRASP).
   Such an API is needed for Autonomic Service Agents (ASA) calling the
   GRASP protocol module to exchange autonomic network messages with
   other ASAs.  Since GRASP is designed to support asynchronous
   operations, the API will need to be adapted to the support for
   asynchronicity in various languages and operating systems.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-anima-grasp-api/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-anima-grasp-api-06
https://datatracker.ietf.org/doc/html/draft-ietf-anima-grasp-api-06

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-anima-grasp-api-06

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 13 Jun 2020 08:21:27 +1200

Hi,

This version was updated following the WG Last Call, mainly to handle the comments in Laurent's careful review. In my opinion the changes are all of an editorial nature, including useful clarifications; there is no change whatever to the technical details of the API. I will just mention a few points of interest:

(1) Laurent suggested adding definitions for "idempotent", "atomic access", and "operating system locks". We expanded the text slightly for the first two, and removed the reference to locks.

(2) "multi-threading, an event loop structure using polling, and an event loop structure using callback functions." Laurent suggested adding a reference for this, but we didn't find a good reference such as a standard textbook or a review article. Suggestions welcome.

(3) Laurent said "Wherever a "timeout" parameter appears, it is an integer expressed in milliseconds. - why specify the unit in an informational document?)". We think it's necessary to specify the unit, since portable apps need portable units.

(4) Laurent said "What is the reasoning for the default support of discovery for objectives?
there may be situation where the exposure of the objectives should be controlled." Our response is that GRASP has no authorization model; we trust an ASA because it has access to the ACP. This aspect would change if we added an authorization model to GRASP, so it's not an API problem today. (It is a topic for future work in ANIMA!)

Regards
   Brian Carpenter + co-authors

On 13-Jun-20 08:04, [email-masked] wrote:
> _______________________________________________
> Anima mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/anima
>