Subject: [Anima] terms parboiled and raw, but instead RVR and PVR

From: Michael Richardson <[email-masked]>
Date: Thu, 19 Aug 2021 14:48:57 -0400

https://github.com/anima-wg/constrained-voucher/pull/148

In our design team meeting today, the terms parboiled and raw were disliked.
We considered a number of things, settling on the terms:

PVR = Pledge Voucher Request
RVR = Registrar Voucher Request

I was concerned that P and R are rather close visually, and we condsidered:
  PdVR and ReVR, but did not go that way.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Peter van der Stok <[email-masked]>
Date: Fri, 20 Aug 2021 12:28:16 +0200

What about?

PRVR = Pledge-Registrar Voucher Request
RMVR = Registrar-Masa Voucher Request

Peter
Michael Richardson schreef op 2021-08-19 20:48:

> _______________________________________________
> Anima mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/anima

---

From: Esko Dijk <[email-masked]>
Date: Fri, 20 Aug 2021 15:13:52 +0000

> RMVR = Registrar-Masa Voucher Request

That looks ok too!

Another idea:

VR1 = Pledge-to-Registrar Voucher Request
VR2 = Registrar-to-MASA Voucher Request
(and we can use the ‘VR2 embeds VR1’ terminology for the prior-signed-voucher-request VR1 that is inside VR2)

The numbers 1 and 2 just denote the chronological order in which they are created.

Esko

From: Anima <[email-masked]> On Behalf Of Peter van der Stok
Sent: Friday, August 20, 2021 12:28
To: Michael Richardson <[email-masked]>
Cc: [email-masked]
Subject: Re: [Anima] terms parboiled and raw, but instead RVR and PVR

What about?

Peter

--
Michael Richardson <[email-masked]<mailto:[email-masked]>>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

_______________________________________________
Anima mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/anima

---

From: Michael Richardson <[email-masked]>
Date: Fri, 20 Aug 2021 21:06:46 -0400

> RMVR = Registrar-Masa Voucher Request

I don't object, but remember that the PRVR is also carried across the
BRSKI-MASA link (inside the RMVR), and decoded by the MASA.

I can see someone getting confused, but probably that's not the only thing
that they'd have trouble with.

We were trying to get to PvdS, as the TLA, but we failed.

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 21 Aug 2021 13:46:44 +1200

> We were trying to get to PvdS, as the TLA, but we failed.

PvDs is already taken (as a plural), by RFC7556. Sorry, Peter!

I think the world has enough acronyms, but these seem OK.
VR1 and VR2 seem OK too.

   Brian

---

From: Esko Dijk <[email-masked]>
Date: Mon, 23 Aug 2021 09:38:16 +0000

And another proposal to match the BRSKI name setting :)

‘draft VR’ = Pledge-to-Registrar Voucher Request
‘canned VR’ = Registrar-to-MASA Voucher Request

My preference though is PVR/RVR.

Esko

From: Esko Dijk
Sent: Friday, August 20, 2021 17:14
To: [email-masked]; Michael Richardson <[email-masked]>
Cc: [email-masked]
Subject: RE: [Anima] terms parboiled and raw, but instead RVR and PVR

That looks ok too!

Another idea:

Esko

From: Anima <[email-masked]<mailto:[email-masked]>> On Behalf Of Peter van der Stok
Sent: Friday, August 20, 2021 12:28
To: Michael Richardson <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Anima] terms parboiled and raw, but instead RVR and PVR

What about?

Peter