Subject: [Anima] /.well-known/brski reference to brski-registry

From: Michael Richardson <[email-masked]>
Date: Thu, 31 Mar 2022 11:47:41 -0400

We were discussing the /.well-known/cmp that is in being proposed in draft-ietf-lamps-cmp-updates,
We were comparing it to /.well-known/brski and /.well-known/est.
   https://www.iana.org/assignments/well-known-uris/well-known-uris.xhtml#well-known-uris-1

BRSKI has a sub-registry at:
   https://www.iana.org/assignments/brski-parameters/brski-parameters.xhtml#brski-well-known-uris

Question 1)
   Why isn't the sub-registry referenced in the /.well-known registry?
   It seems like the sub-registry should be linked in the related
   information.

Question 2)
   Should the CMP document be establishing a registry or not?

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: "Brockhaus, Hendrik" <[email-masked]>
Date: Thu, 31 Mar 2022 16:20:56 +0000

Thank you Michael for rising the questions.

> Von: Anima <[email-masked]> Im Auftrag von Michael Richardson
> Gesendet: Donnerstag, 31. März 2022 17:48
> 
> 
> We were discussing the /.well-known/cmp that is in being proposed in draft-ietf-
> lamps-cmp-updates, We were comparing it to /.well-known/brski and /.well-
> known/est.
> 
> Question 2)
As discussed during IETF 113 I plan to do these things in CMP Updates
- register 'cmp' in the "Well-Known URIs" registry
- define a protocol registry group "Certificate Management Protocol (CMP)"
- define a registry for "CMP Well-Known Arbitrary Label URI Segments" defining 'p' to be followed by a <profileLabel>.
In addition I would define a registry for "CMP Well-Known Operation Label URI Segments" in Lightweight CMP Profile containing the path segments defined three for http and coap use.

Does this makes sense?

Hendrik

---

From: Russ Housley <[email-masked]>
Date: Thu, 31 Mar 2022 13:52:51 -0400

> On Mar 31, 2022, at 12:20 PM, Brockhaus, Hendrik <[email-masked]> wrote:
> 

Hendrik:

That is consistent with the discussion lat week.

Russ

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 1 Apr 2022 08:44:45 +1100

From a registry expert POV -

> On 1 Apr 2022, at 2:47 am, Michael Richardson <[email-masked]> wrote:
> 
> 

Because they didn't ask for it, I imagine. Does seem like a good idea if that's the case.

>   Should the CMP document be establishing a registry or not?

Completely up to you -- how you manage the name spec "under" your registration depends on the application at hand. 

Cheers,

--
Mark Nottingham   https://www.mnot.net/

---

From: "Brockhaus, Hendrik" <[email-masked]>
Date: Fri, 1 Apr 2022 06:25:02 +0000

> Von: Russ Housley <[email-masked]>
> Gesendet: Donnerstag, 31. März 2022 19:53
> 
> >> We were discussing the /.well-known/cmp that is in being proposed in
> >> draft-ietf- lamps-cmp-updates, We were comparing it to
> >> /.well-known/brski and /.well- known/est.
> >>
> >> Question 2)
> > - define a registry for "CMP Well-Known Arbitrary Label URI Segments"
> defining 'p' to be followed by a <profileLabel>.
> > In addition I would define a registry for "CMP Well-Known Operation Label URI
> Segments" in Lightweight CMP Profile containing the path segments defined
> three for http and coap use.
> >
> > Does this makes sense?
> 
> Hendrik:
> 

Would it also be sufficient to have only one additional registry "CMP Well-Known URI Path Segments" containing the arbitrary label 'p' and the operation labels?

Hendrik