Subject: [Anima] I-D Action: draft-ietf-anima-network-service-auto-deployment-01.txt

From: [email-masked]
Date: Thu, 03 Mar 2022 19:16:30 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Autonomic Networking Integrated Model and Approach WG of the IETF.

        Title           : An Autonomic Mechanism for Resource-based Network Services Auto-deployment
        Authors         : Joanna Dang
                          Sheng Jiang
                          Zongpeng Du
                          Yujing
	Filename        : draft-ietf-anima-network-service-auto-deployment-01.txt
	Pages           : 13
	Date            : 2022-03-03

Abstract:
   This document specifies an autonomic mechanism for resource-based
   network services deployment through the Autonomic Control Plane (ACP)
   in a network.  This mechanism uses the GeneRic Autonomic Signaling
   Protocol (GRASP) in [RFC8990] to exchange the information among the
   autonomic nodes so that the resource along the service path can be
   coordinated.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-anima-network-service-auto-deployment/

There is also an htmlized version available at:
https://datatracker.ietf.org/doc/html/draft-ietf-anima-network-service-auto-deployment-01

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-anima-network-service-auto-deployment-01

Internet-Drafts are also available by rsync at rsync.ietf.org::internet-drafts

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 10 Mar 2022 13:34:58 +1300

Hi,

I have a few questions about this draft.

1) Format of objective-value:

objective-value = n-s-deployment-value ; An n-s-deployment-value is defined as Figure-1.

  n-s-deployment-value
      + service-information
          + source-ip-address
          + destination-ip-address
          + service-tag
      + resource-information
          + resource-requirement-pair
              + resource-type
              + resource-value

I don't understand this notation. What is it, and how is it
serialised as CBOR? For example, is it supposed to be a JSON-like
map of some kind (as proposed in draft-eckert-anima-grasp-dnssd or
draft-carpenter-anima-grasp-config)? We really need complete
CDDL, which can be checked automatically.

2) The proposal does not contain much detail yet.

"Resource requirements of different types can be described in
an objective option. The ResourceManager objective option supports
multi-faceted resource requirements and negotiation."

That implies a large amount of extension. How will extensibility
of "resourcetype" values be handled? An IANA registry? What
about "resvals" that are not a simple number?

Again, a JSON-like model might be appropriate, to allow easy
extensions. Would some extensions be general, and others vendor-
specific?

3) Will this proposal integrate with DetNet? (I have no knowledge
of how DetNet will be configured, but I expect that will involve
Yang and NetConf.)

4) More generally, I think this proposal needs to explain how it
will interact with NetConf, because today operators use NetConf.

Regards
    Brian Carpenter

On 04-Mar-22 16:16, [email-masked] wrote:
> _______________________________________________
> Anima mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/anima
>