Subject: Re: [Anima] /.well-known/brski reference to brski-registry

From: Michael Richardson <[email-masked]>
Date: Fri, 01 Apr 2022 09:43:54 -0400

Dear IANA,

In the brski entry in .well-known at:

>   https://www.iana.org/assignments/well-known-uris/well-known-uris.xhtml#well-known-uris-1

Could you, in the related information, link to:

> BRSKI has a sub-registry at:
>   https://www.iana.org/assignments/brski-parameters/brski-parameters.xhtml#brski-well-known-uris

Thank you.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: "Amanda Baber via RT" <[email-masked]>
Date: Sat, 02 Apr 2022 03:03:34 +0000

Hi Mark,

As the designated expert for the Well-Known URIs registry, can you approve this addition?

thanks,

Amanda Baber
IANA Operations Manager

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 4 Apr 2022 11:19:05 +1000

Yes.

> On 2 Apr 2022, at 2:03 pm, Amanda Baber via RT <[email-masked]> wrote:
> 
> Hi Mark,
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: Sean Turner <[email-masked]>
Date: Sun, 3 Apr 2022 22:36:01 -0400

> On Apr 1, 2022, at 02:25, Brockhaus, Hendrik <[email-masked]> wrote:
> 
> 
>> Von: Russ Housley <[email-masked]>
>> Gesendet: Donnerstag, 31. März 2022 19:53
>> 
>>> On Mar 31, 2022, at 12:20 PM, Brockhaus, Hendrik
>> <[email-masked]> wrote:
>>> 
>>> Thank you Michael for rising the questions.
>>> 
>>>> Von: Anima <[email-masked]> Im Auftrag von Michael Richardson
>>>> Gesendet: Donnerstag, 31. März 2022 17:48
>>>> 
>>>> 
>>>> We were discussing the /.well-known/cmp that is in being proposed in
>>>> draft-ietf- lamps-cmp-updates, We were comparing it to
>>>> /.well-known/brski and /.well- known/est.
>>>> 
>>>> Question 2)
>>>>  Should the CMP document be establishing a registry or not?
>>>> 
>>> As discussed during IETF 113 I plan to do these things in CMP Updates
>>> - register 'cmp' in the "Well-Known URIs" registry
>>> - define a protocol registry group "Certificate Management Protocol (CMP)"
>>> - define a registry for "CMP Well-Known Arbitrary Label URI Segments"
>> defining 'p' to be followed by a <profileLabel>.
>>> In addition I would define a registry for "CMP Well-Known Operation Label URI
>> Segments" in Lightweight CMP Profile containing the path segments defined
>> three for http and coap use.
>>> 
>>> Does this makes sense?
>> 
>> Hendrik:
>> 
>> That is consistent with the discussion lat week.
>> 
>> Russ
> 
> Would it also be sufficient to have only one additional registry "CMP Well-Known URI Path Segments" containing the arbitrary label 'p' and the operation labels?
> 
> Hendrik

When the /.well-known/est/ was registered we only did the top level, i.e., /est/. There are no registries for the /.well-known/est/*this part*.  It’s not clear to me that you need to do anything more than get /.well-known/cmp.

What will be the registration policy [0] for the ‘p’ values? I assume FCFS (first come first served)?

spt

[0] https://datatracker.ietf.org/doc/rfc8126/

---

From: Michael Richardson <[email-masked]>
Date: Mon, 04 Apr 2022 10:02:09 -0400

Sean Turner <[email-masked]> wrote:
    > When the /.well-known/est/ was registered we only did the top level,
    > i.e., /est/. There are no registries for the /.well-known/est/*this
    > part*.  It’s not clear to me that you need to do anything more than get
    > /.well-known/cmp.

Yes, and then we updated it with RFC8995, but at the last minute, we moved
all the new stuff into /.well-known/brski and established a registry.

    > FCFS (first come first served)?

I would think Specification Required if it's going to be part of a deployable
infrastructure.   (Not IETF Specification!)

---

From: Russ Housley <[email-masked]>
Date: Mon, 4 Apr 2022 10:29:09 -0400

> On Apr 1, 2022, at 2:25 AM, Brockhaus, Hendrik <[email-masked]> wrote:
> 
> 

I think so.

Russ

---

From: "Amanda Baber via RT" <[email-masked]>
Date: Mon, 04 Apr 2022 16:14:52 +0000

Hi Michael,

This update is complete:

https://www.iana.org/assignments/well-known-uris

Best regards,

Amanda Baber
IANA Operations Manager

---

From: Benjamin Kaduk <[email-masked]>
Date: Tue, 5 Apr 2022 10:31:50 -0700

> What will be the registration policy [0] for the ‘p’ values? I assume FCFS (first come first served)?

I had assumed that we were just registering the value 'p' in a single
combined registry of CMP operations and path labels, but that the stuff
after 'p' was site-local and did not need to be registered.  (Though a FCFS
registry for them is not wrong.)

-Ben

---

From: "Brockhaus, Hendrik" <[email-masked]>
Date: Wed, 6 Apr 2022 07:28:46 +0000

> Von: Benjamin Kaduk <[email-masked]>
> Gesendet: Dienstag, 5. April 2022 19:32
> 
> > >> Segments" in Lightweight CMP Profile containing the path segments
> > >> defined three for http and coap use.
> > >>>
> > >>> Does this makes sense?
> > >>
> > >> Hendrik:
> > >>
> > > Would it also be sufficient to have only one additional registry "CMP Well-
> Known URI Path Segments" containing the arbitrary label 'p' and the operation
> labels?
> > >
> > > Hendrik
> >
> > When the /.well-known/est/ was registered we only did the top level, i.e.,
> /est/. There are no registries for the /.well-known/est/*this part*.  It’s not clear
> to me that you need to do anything more than get /.well-known/cmp.
> >
> I had assumed that we were just registering the value 'p' in a single combined
> registry of CMP operations and path labels, but that the stuff after 'p' was site-
> local and did not need to be registered.  (Though a FCFS registry for them is not
> wrong.)
> 
> -Ben

Ben, thank you for clarifying this. This is also my understanding and I am about to update the drafts accordingly.

Hendrik