Subject: HTTP 30x response code for bulk redirect

From: Ted Hardie <[email-masked]>
Date: Wed, 2 Jun 2010 12:14:14 -0700

In discussions on the namedroppers list a side-issue on HTTP
redirection has cropped up.
The core of the question is how to support redirection for a flock of
resources that are all
being redirected. Client requests http://foo.example/resource1, gets a
redirect to
http://bar.example/resource1 and so on for resource1-resource51.   My
faulty memory
is telling me that a 30x that said "This resources and all other
resources at this host
have moved" was not done earlier for security reasons--why allow
someone controlling
http://foo.example/resource1 to say anything about http://foo.example/resource2,
since they might be associated with a different entity
(http://foo.example/~user1
and http://foo.example/~user2 being the classic example).  Is there
more to this,
or is there a way around the security issue using something like a
policy in .well-known?
E.g. allow a new 30x on a full-host basis, provided a policy in
.well-known permitted it?

regards,

Ted

---

From: Cyrus Daboo <[email-masked]>
Date: Wed, 02 Jun 2010 15:37:08 -0400

Hi Ted,

--On June 2, 2010 12:14:14 PM -0700 Ted Hardie <[email-masked]> wrote:

> http://foo.example/resource1 to say anything about
> http://foo.example/resource2, since they might be associated with a
> different entity

There is also a similar issue with child resources (collections in WebDAV). 
Can a client assume that a redirect for /resource1, also applies to 
/resource1/child1? This has come up in the context of CalDAV where a client 
needs to be told that a user's calendar-home (containing all their 
calendars) previously located in one place has moved to another (including 
moved to another server).

-- 
Cyrus Daboo

---

From: Eran Hammer-Lahav <[email-masked]>
Date: Wed, 2 Jun 2010 13:23:15 -0700

You can host-meta with a special redirection relation type and a template to express this. The tricky part is how to tie it to the HTTP response.

EHL

On 6/2/10 12:14 PM, "Ted Hardie" <[email-masked]> wrote:

regards,

Ted
_______________________________________________
Apps-Discuss mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/apps-discuss

---

From: Julian Reschke <[email-masked]>
Date: Thu, 03 Jun 2010 19:23:07 +0200

On 02.06.2010 21:37, Cyrus Daboo wrote:
> ...
> There is also a similar issue with child resources (collections in
> WebDAV). Can a client assume that a redirect for /resource1, also
> applies to /resource1/child1? This has come up in the context of CalDAV
> where a client needs to be told that a user's calendar-home (containing
> all their calendars) previously located in one place has moved to
> another (including moved to another server).
> ...

If /resource1 previously identified WebDAV collection, then it would be 
a safe assumption that all member resources (recursively) have moved as 
well.

Best regards, Julian

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 4 Jun 2010 16:24:54 +1000

Personally, I think something in .well-known should be allowed to say this, but I agree it's an area you need to step carefully in.

I'd also point out that *many* other mechanisms on the Web align policy on a "site" basis (with acknowledgement that this is a fuzzy concept); e.g., cookie scoping, some authentication mechanisms, cache invalidations, robot policy, privacy policy, etc.

Cheers,

--
Mark Nottingham     http://www.mnot.net/