Subject: Re: [apps-discuss] WG Review: Applications Area Working Group (APPSAWG)

From: Alfred Hönes <[email-masked]>
Date: Fri, 1 Oct 2010 09:37:59 +0200 (MESZ)

Barry Leiba wrote, regarding the criteria for work items in the
draft APPSAWG charter:

> ...  It might also make sense to use an unordered list (with "*")
> instead of an ordered one (with numbers), just to be clear that
> it's neither explicitly ordered nor exhaustive.

+1  --  Splendid observation!

The only downside would be that, in arguing about proposals or -- even
more omportantly -- in documenting the decision to refuse a proposal
for adoption, the language would become less transparent when it needs
to reference some of the criteria.  But IMO that is tractable.

BR,
  Alfred.

---

From: Alexey Melnikov <[email-masked]>
Date: Fri, 15 Oct 2010 09:18:26 +0100

Ted Hardie wrote:

>On Wed, Sep 29, 2010 at 1:01 AM, t.petch <[email-masked]> wrote:
>  
>
>>I think that the order of the list of considerations is unfortunate, as it might
>>be read as implying precedence.  I think that
>>(5) There is no existing related Working Group that is willing to
>>    
>>
>>>recharter to take on this work, and the document doesn't justify the
>>>formation of a new working group.
>>>      
>>>
>>should come top of the list.
>>
>>And the reference to URI I find unclear - I see that activity best performed on
>> [email-masked]
>>    
>>
>
>Hi Tom,
>
>I think you're right that [email-masked] would be the right place to
>discuss something
>about the evolution of URIs.  The IRI working group is the right place
>to discuss the
>internationalization issues there, and [email-masked] the right
>place to propose
>a new scheme.  But when I saw "URIs and XML", I assumed that this working
>group would cover questions of how to apply them in a specific
>context, rather than taking on work to change them.  If it did run across something that
>needed a major change, it would likely be moved off into a different (or new) group.
>
>Does that match others' expectations?
>  
>
Yes, that was the intent.

---

From: Alexey Melnikov <[email-masked]>
Date: Fri, 15 Oct 2010 09:40:17 +0100

Barry Leiba wrote:

>On Wed, Sep 29, 2010 at 3:49 PM, Alfred HÎnes <[email-masked]> wrote:
>  
>
>>At Wed, 29 Sep 2010 10:01:24 +0200, Tom Petch wrote:
>>    
>>
>>>I think that the order of the list of considerations is
>>>unfortunate, as it might be read as implying precedence.
>>>      
>>>
>...
>  
>
>>This clearly means the list presents a conjunction (all conditions
>>must be met), and it it non-exhaustive.
>>"AND" is commutative and associative.  So the order doesn't matter.
>>Thus, the APPSAWG chairs and the APP ADs have to consider all items.
>>    
>>
>
>Still, it makes sense to put the primary concerns at the top.  It
>might also make sense to use an unordered list (with "*") instead of
>an ordered one (with numbers), just to be clear that it's neither
>explicitly ordered nor exhaustive.
>
Ok, I've changed the list to be unordered.