Subject: [apps-discuss] nullMX, new code, and draft-klensin-smtp-521code-02

From: John C Klensin <[email-masked]>
Date: Sun, 07 Sep 2014 12:14:35 -0400

Hi.

I've just posted draft-klensin-smtp-521code-02, which changes
SMTP to support two new reply codes, 521 (to support the
behavior of dummy servers as discussed in RFC 1846) and 556
(primarily to support nullMX).

To reprise discussion on this list, use of two separate codes
helps distinguish between reaching the actual host and having it
indicate it doesn't support mail and finding out by indirect
means, such as a DNS entry.  The separation also works around an
SMTP violation in which a popular implementation assumes a
relationship among reply codes that share the last two digits.

The text is intended to treat nullMX as an example of a family
of indirect techniques rather than, e.g., creating a normative
reference to it or restricting use of the 556 code to that
particular case.  While it does not discuss the other cases, a
Submission server that knew that a particular domain, perhaps a
local one, did not accept any mail would be justified in
returning a 556 code whether a nullMX record was present or not. 

The draft is being mentioned on this list only because of the
relationship to nullMX.  The I-D is not expected to become an
AppsAWG work item.  As indicated in the I-D, discussion of
details not specific to nullMX should probably occur on the
ietf-smtp list.

    john

---

From: Arnt Gulbrandsen <[email-masked]>
Date: Sun, 7 Sep 2014 16:30:45 +0000

I don't think what postfix does is a protocol violation. The 4xy and 5xy reply codes were assigned according to the same principles, and so _should_ be similar apart from the permanent/temporary bit.

Arnt

---

From: John C Klensin <[email-masked]>
Date: Sun, 07 Sep 2014 13:10:13 -0400

--On Sunday, 07 September, 2014 16:30 +0000 Arnt Gulbrandsen
<[email-masked]> wrote:

> I don't think what postfix does is a protocol violation. The
> 4xy and 5xy reply codes were assigned according to the same
> principles, and so _should_ be similar apart from the
> permanent/temporary bit.

Reply is on the SMTP list as indicated in the draft.  Please
take the discussion there.

    john

---

From: Ned Freed <[email-masked]>
Date: Mon, 08 Sep 2014 13:24:42 -0700 (PDT)

> I don't think what postfix does is a protocol violation.

Of course it's not a protocol violation. The syntax restrictions on 5yz and
4yz codes are the same, so as long as you check the 5yz code for
validity you're not going to ever send back something illegal.

But returning a random valid response code isn't a protocol violation
either. That doesn't means it's something you should do.

> The 4xy and 5xy reply codes were assigned according to the same principles,
> and so _should_ be similar apart from the permanent/temporary bit.

Even the most cursory examination of the set of assigned codes shows this is
not the case. The fact that 521/421/221 align is essentially serendipitous.
I've already pointed out other cases where the alignment is poor.

				Ned

---

From: Scott Kitterman <[email-masked]>
Date: Mon, 08 Sep 2014 16:53:41 -0400

>I've already pointed out other cases where the alignment is poor.

AIUI, Postfix only relies on this alignment for x21, so that should be fine. 

Scott K