Subject: [apps-discuss] draft-ietf-appsawg-text-markdown vs Content-Disposition

From: Julian Reschke <[email-masked]>
Date: Mon, 23 Mar 2015 14:12:56 +0100

Hi there,

it would be good if the draft stated whether the C-D parameter 
"preview-type" is supposed to apply to Content-Disposition in HTTP, and 
to clarify, exactly how.

(Note that Content-Disposition in HTTP is defined by RFC 6266, which the 
draft currently doesn't even reference)

Best regards, Julian

---

From: Sean Leonard <[email-masked]>
Date: Mon, 23 Mar 2015 13:19:02 -0500

Thanks for the comments.

On Mar 23, 2015, at 8:12 AM, Julian Reschke <[email-masked]> wrote:

> Hi there,
> 
> it would be good if the draft stated whether the C-D parameter "preview-type" is supposed to apply to Content-Disposition in HTTP, and to clarify, exactly how.
> 
> (Note that Content-Disposition in HTTP is defined by RFC 6266, which the draft currently doesn't even reference)

I checked out RFC 6266. To my knowledge, there are “no special considerations” with regard to serving the preview-type parameter over HTTP. I can add some text or leave it blank. What I mean by “no special considerations”, is that whatever a MIME (e-mail) processor would do with it, an HTTP processor shouldn’t do anything particularly different.

If the content is provided over any Internet header-oriented protocol, the Content-Disposition data should be provided to the Markdown processor/displayer software for it to act on it.

I do not anticipate text/markdown content to be served over HTTP; my expectation is that text/markdown (along with various parameters) is processed on the server and delivered to a client over HTTP as text/html or similar.

So do folks want a statement about that and a reference to RFC 6266? I do not mind including it.

Best regards,

Sean

---

From: Sean Leonard <[email-masked]>
Date: Mon, 30 Mar 2015 12:33:13 -0700

On Mar 23, 2015, at 11:19 AM, Sean Leonard <[email-masked]> wrote:

> [...]

To follow up on this: I think that text-markdown and text-markdown-use-cases are pretty much ready for Last Call, unless folks want the RFC 6266 or more elaboration. Hopefully we can start that ball rolling in the next week in order to push them off of the queue.

Thanks,

Sean