Subject: [apps-discuss] New Proposed VNC URI Scheme

From: <[email-masked]>
Date: Tue, 24 Mar 2015 16:08:18 -0500

Hi all,

My co-author and I have prepared a proposed VNC URI scheme for review by the community available at:

http://www.ietf.org/internet-drafts/draft-warden-appsawg-vnc-scheme-00.txt

To provide a bit of background, VNC applications are fairly common means of providing remote desktop functionality. While the capabilities of VNC clients are fairly uniform and several of them support VNC URIs, the URI format consumed by each application differs. While we can't standardize every parameter in use by the varying clients, this document allow us to move toward interoperability while providing for backward compatibility and custom parameters.

We've implemented the scheme described in the document within the open source bVNC client on Android, which is launched from the Dell OpenManage Mobile app using a URI.

We greatly appreciate comments on the proposal, as well as a sense of support for processing the draft within the Applications Area Working Group. We plan to reach out to the authors of several VNC applications, but encourage anyone with contact information to forward this to others working in the area who may be interested.

Regards,

David Warden
Software Development Principal Engineer
Dell | Enterprise Solutions Group

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Tue, 24 Mar 2015 14:18:59 -0700

On Tue, Mar 24, 2015 at 2:08 PM, <[email-masked]> wrote:

> [...]
Thanks, David.

All: While considering this, please keep in mind that the URI Scheme
Registrations BCP will soon be updated, replaced by this one, which is
about to undergo its IESG Evaluation:

http://tools.ietf.org/html/draft-ietf-appsawg-uri-scheme-reg-04

We'll need to make sure this draft conforms to that one before the
registration can happen.

-MSK