Subject: [aqm] references on global sync & lock-out

From: Wesley Eddy <[email-masked]>
Date: Tue, 24 Jun 2014 14:27:38 -0400

Per the discussion in the telecon today about references for global
synchronization and lock-out, I think some excellent classic ones are:

Global Synchronization:

Zhang & Clark, "Oscillating Behavior of Network Traffic: A Case Study
Simulation", 1990
http://groups.csail.mit.edu/ana/Publications/Zhang-DDC-Oscillating-Behavior-of-Network-Traffic-1990.pdf

Floyd & Jacobson, "The Synchronization of Periodic Routing Messages", 1994
http://ee.lbl.gov/papers/sync_94.pdf

Lock-Out:

Floyd & Jacobson, "On Traffic Phase Effects in Packet-Switched
Gateways", 1992
http://www.icir.org/floyd/papers/phase.pdf

-- 
Wes Eddy
MTI Systems

---

From: Dave Taht <[email-masked]>
Date: Tue, 24 Jun 2014 12:11:05 -0700

> http://groups.csail.mit.edu/ana/Publications/Zhang-DDC-Oscillating-Behavior-of-Network-Traffic-1990.pdf

I would really like this sort of stuff (and the self similarity paper
already cited) revisited with modern traffic.

> http://ee.lbl.gov/papers/sync_94.pdf

(thank you for the hyperlinks!)

One of my issues with the above paper is that it predates bufferbloat
being a prevailing problem on networks and the huge amount of
additional bandwidth now available. Routing message size and frequency
now is only a problem with BGP, and in virtualized routed
environments.

The other issue, is that most link technologies today have wildly
variable access times to the media itself (notably wireless and wifi),
so these naturally act to desynchronize routing updates in the
protocols I'm familiar with.

Neither of my points have been proved! I've been meaning to rip out
desynchronization from babel for wireless interfaces for years now....

> http://www.icir.org/floyd/papers/phase.pdf

*Classic* but also dated. Is there nothing more recent?

I will see what I can find on bursty traffic.

>
>
> --
> Wes Eddy
> MTI Systems
>
> _______________________________________________
> aqm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/aqm

-- 
Dave Täht

NSFW: https://w2.eff.org/Censorship/Internet_censorship_bills/russell_0296_indecent.article

---

From: Andrew Mcgregor <[email-masked]>
Date: Wed, 25 Jun 2014 17:57:26 +1000

One useful reference on bursty traffic is:
Stefan Bodamer & Joachim Charzinski "Evaluation of Effective Bandwidth
Schemes for Self-Similar Traffic", 2000
http://www.ikr.uni-stuttgart.de/Content/Publications/Archive/Bo_IP00_32462.pdf

On 25 June 2014 05:11, Dave Taht <[email-masked]> wrote:

> NSFW:
> https://w2.eff.org/Censorship/Internet_censorship_bills/russell_0296_indecent.article
>

-- 
Andrew McGregor | SRE | [email-masked] | +61 4 1071 2221

---

From: "LAUTENSCHLAEGER, Wolfram (Wolfram)" <[email-masked]>
Date: Mon, 30 Jun 2014 08:19:00 +0000

I published a paper that reveals the root cause of global synchronization:
"A Deterministic TCP Bandwidth Sharing Model", http://arxiv.org/pdf/1404.4173v1

The findings in the paper are the theoretical basis for the GSP AQM proposal in
http://tools.ietf.org/html/draft-lauten-aqm-gsp-00

--
Wolfram Lautenschlaeger
Bell Labs

> -----Ursprüngliche Nachricht-----
> Von: aqm [mailto:[email-masked]] Im Auftrag von Wesley Eddy
> Gesendet: Dienstag, 24. Juni 2014 20:28
> An: [email-masked]
> Betreff: [aqm] references on global sync & lock-out
> 
> Simulation", 1990 http://groups.csail.mit.edu/ana/Publications/Zhang-DDC-
> Oscillating-Behavior-of-Network-Traffic-1990.pdf
> 
> Floyd & Jacobson, "On Traffic Phase Effects in Packet-Switched Gateways",
> 1992 http://www.icir.org/floyd/papers/phase.pdf
> 
> 
> --
> Wes Eddy
> MTI Systems
>