Subject: [aqm] GSP - calculation of time above/below the threshold

From: Polina Goltsman <[email-masked]>
Date: Mon, 17 Aug 2015 17:25:18 +0200

Dear Wolfram and Andrea,

The GSP-draft (and presentation at the last IETF meeting)  suggests the 
adaptation heuristic based on the time the queue spent below and above 
the threshold. However the draft provide any hints on how these vales 
are calculated.

Are they just accumulated, or is there some kind of averaging filter? 
Should these values be reset sometimes? Is empty queue a special case ?

Best Regards,
Polina

---

From: "LAUTENSCHLAEGER, Wolfram (Wolfram)" <[email-masked]>
Date: Tue, 18 Aug 2015 07:12:02 +0000

Polina,

The times above and below threshold are accumulated in one value, not two.
A time spent entirely above the threshold is added to that value. 
A time spent entirely below the threshold is subtracted from that value.
The accumulated value is clamped at zero. It must not be negative.

There is no extra averaging, just adding and subtracting.
There is no reset. At reduced traffic offer the accumulation approaches zero
anyway.
Empty queue is not a special case.

Best Regards,

Wolfram

> -----Ursprüngliche Nachricht-----
> Von: aqm [mailto:[email-masked]] Im Auftrag von Polina Goltsman
> Gesendet: Montag, 17. August 2015 17:25
> An: AQM IETF list
> Betreff: [aqm] GSP - calculation of time above/below the threshold
> 
> Dear Wolfram and Andrea,
> 
> the threshold. However the draft provide any hints on how these vales are
> calculated.
> 
> _______________________________________________
> aqm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/aqm