Subject: Re: [arcmedia] Fwd: New Version Notification for draft-seantek-kerwin-arcmedia-type-01.txt

From: Dave Crocker <[email-masked]>
Date: Thu, 04 Jun 2015 05:23:03 -0700

Folks,

G'day.

The revised draft was announced on this list one month ago.  There has
been no email traffic discussing it.

Is anyone (other than the authors) interested in this work?

d/

On 5/5/2015 4:28 PM, Matthew Kerwin wrote:
> [1]: https://github.com/Archive-TLMT/arcmedia/issues
> 
> ---------- Forwarded message ----------
> From: ** <[email-masked] <mailto:[email-masked]>>
> Date: 6 May 2015 at 08:29
> Subject: New Version Notification for
> draft-seantek-kerwin-arcmedia-type-01.txt
> To: Sean Leonard <[email-masked] <mailto:[email-masked]>>,
> Matthew Kerwin <[email-masked] <mailto:[email-masked]>>
> 
> 
> 
> A new version of I-D, draft-seantek-kerwin-arcmedia-type-01.txt
> has been successfully submitted by Matthew Kerwin and posted to the
> IETF repository.
> 
> Name:           draft-seantek-kerwin-arcmedia-type
> Revision:       01
> Title:          The Archive Top-Level Media Type for File Archives
> Document date:  2015-05-06
> Group:          Individual Submission
> Pages:          9
> URL:           
> https://www.ietf.org/internet-drafts/draft-seantek-kerwin-arcmedia-type-01.txt
> Status:       
>  https://datatracker.ietf.org/doc/draft-seantek-kerwin-arcmedia-type/
> Htmlized:     
>  https://tools.ietf.org/html/draft-seantek-kerwin-arcmedia-type-01
> Diff:         
>  https://www.ietf.org/rfcdiff?url2=draft-seantek-kerwin-arcmedia-type-01

-- 
Dave Crocker
Brandenburg InternetWorking
bbiw.net

---

From: Dave Crocker <[email-masked]>
Date: Fri, 12 Jun 2015 23:06:56 +0100

> Is anyone (other than the authors) interested in this work?

It's been another week and I've seen no discussion activity.

Not good.

My original question remains.

d/

---

From: Stian Soiland-Reyes <[email-masked]>
Date: Thu, 18 Jun 2015 17:33:09 +0100

My real life unfortunately has not slowed down, but I'm interested in
the work :)

I think the proposed draft looks good. I would want to propose a
generic fragment syntax (e.g. #/folder/filename.txt ) that applies
unless the registration overrides it - where there's still the option
of #somethingelse for archives like DMG which have partitions.

On 12 June 2015 at 23:06, Dave Crocker <[email-masked]> wrote:
> _______________________________________________
> arcmedia mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/arcmedia

-- 
Stian Soiland-Reyes, eScience Lab
School of Computer Science
The University of Manchester
http://soiland-reyes.com/stian/work/    http://orcid.org/0000-0001-9842-9718

---

From: Stian Soiland-Reyes <[email-masked]>
Date: Fri, 19 Jun 2015 12:11:38 +0100

My suggested Fragment identifier section:

https://github.com/Archive-TLMT/arcmedia/pull/9

---

From: Heather Flanagan <[email-masked]>
Date: Tue, 23 Jun 2015 17:04:06 +0100

> https://github.com/Archive-TLMT/arcmedia/pull/9

I know we're not directing client behavior here, but I wonder if it's
worth mentioning the use case of offline use of these archives? Or is
that too client-y?

I'm going to ping the folks over in the DPUB group at the W3C to see
if they have any useful feedback.

- -Heather

---

From: Matthew Kerwin <[email-masked]>
Date: Wed, 24 Jun 2015 07:09:31 +1000

> worth mentioning the use case of offline use of these archives? Or is

I think that depends on what we'd actually write. We haven't explicitly
said anything about online use, as it is. What sort of thing did you have
in mind?

---

From: Matthew Kerwin <[email-masked]>
Date: Wed, 24 Jun 2015 07:13:31 +1000

> https://github.com/Archive-TLMT/arcmedia/pull/9

Thanks for that. I've had a look at the PR. I think I'll merge it to use as
a starting point, and we can rewrite it from there. (As soon as I have some
time on my PC instead of my phone.)

Cheers

---

From: Stian Soiland-Reyes <[email-masked]>
Date: Thu, 25 Jun 2015 12:07:53 +0100

When you say offline use - do you mean "Not retrieved over
HTTP/email/* with a clear Content-Type header" ?

Media types are also used on the desktop and on mobile applications,
and additionally we ask for magic numbers in the registration which is
used by mime magic detections. File extensions are another aspect.

Are there other considerations?

On 23 June 2015 at 22:09, Matthew Kerwin <[email-masked]> wrote:
> I think that depends on what we'd actually write. We haven't explicitly said
> anything about online use, as it is. What sort of thing did you have in
> mind?
>
>>

---

From: Matthew Kerwin <[email-masked]>
Date: Mon, 29 Jun 2015 18:00:31 +1000

On 24 June 2015 at 07:13, Matthew Kerwin <[email-masked]> wrote:

> Thanks for that. I've had a look at the PR. I think I'll merge it to use
> as a starting point, and we can rewrite it from there. (As soon as I have
> some time on my PC instead of my phone.)
>
> Cheers
>

​Ok I'm back from my conference, and I've merged the pull request. It's
visible in the editor's copy online <
http://archive-tlmt.github.io/arcmedia/arcmedia/> but I won't submit a new
draft revision until we've had a bit of a read through and made sure we're
all okay with what it says.​

Thanks again for the words.

-- 
  Matthew Kerwin
  http://matthew.kerwin.net.au/

---

From: Stian Soiland-Reyes <[email-masked]>
Date: Mon, 29 Jun 2015 11:40:20 +0100

Thanks, I saw you fixed my references as well :-)

On 29 June 2015 at 09:00, Matthew Kerwin <[email-masked]> wrote:
>> On 19/06/2015 9:12 PM, "Stian Soiland-Reyes"
> Ok I'm back from my conference, and I've merged the pull request. It's
> visible in the editor's copy online
> <http://archive-tlmt.github.io/arcmedia/arcmedia/> but I won't submit a new
> all okay with what it says.
>