Subject: [art] "Home" documents for HTTP APIs

From: Mark Nottingham <[email-masked]>
Date: Wed, 15 Mar 2017 16:17:07 +1100

Hi art[-discuss],

I've had a document on the back burner for a while about a "home document" for non-brower uses of HTTP.

  https://datatracker.ietf.org/doc/draft-nottingham-json-home/
  https://mnot.github.io/I-D/json-home/

The idea is to promote good practice, especially regarding allowing the server to control its own URLs (as per RFC7320) -- especially in the case where there are likely to be multiple implementations, multiple servers and multiple clients deployed (i.e., standards).

This differentiates it from other "HTTP API description formats" that you might have come across. See the Introduction for a more full explanation.

It's come to a point where there's a non-trival (but not huge) community of folks interested in it and implementing it; e.g., see: 
  https://github.com/mnot/I-D/wiki/json-home
  https://github.com/mnot/I-D/issues?utf8=✓&q=label%3Ajson-home%20

However, I'm not sure about next steps. What I'd like to hear from folks here is whether people think defining this would help IETF protocols that use HTTP (of which there seem to be more every day).

Any thoughts?

Thanks,

--
Mark Nottingham   https://www.mnot.net/

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 23 Mar 2017 17:43:53 +0100

draft-ietf-core-links-json just finished second WGLC in core.
That is clearly solving a different problem (making RFC 6690 available in JSON/CBOR), but I can’t help noticing that there are some commonalities.
RFC 6690, of course, is the “home document” for CoRE.
Also, OCF has /oic/res, which is in the same mold.

No idea whether this semblance should have any impact on either document, but maybe food for thought.

(Yes, I have read Appendix D.  Maybe I should point to draft-hartke-t2trg-coral as one take on the “form” gap.  Input on this is very welcome over in T2TRG.)

Grüße, Carsten

[resent this because of "Message has implicit destination” breakage.]