Subject: [Asdf] I-D Action: draft-ietf-asdf-sdf-01.txt

From: [email-masked]
Date: Sun, 15 Nov 2020 14:51:03 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the A Semantic Definition Format for Data and Interactions of Things WG of the IETF.

        Title           : Semantic Definition Format (SDF) for Data and Interactions of Things
        Authors         : Michael Koster
                          Carsten Bormann
	Filename        : draft-ietf-asdf-sdf-01.txt
	Pages           : 35
	Date            : 2020-11-15

Abstract:
   The Semantic Definition Format (SDF) is a format for domain experts
   to use in the creation and maintenance of data and interaction models
   in the Internet of Things.  It was created as a common language for
   use in the development of the One Data Model liaison organization
   (OneDM) definitions.  Tools convert this format to database formats
   and other serializations as needed.

   An SDF specification describes definitions of SDF Objects and their
   associated interactions (Events, Actions, Properties), as well as the
   Data types for the information exchanged in those interactions.

   A JSON format representation of SDF 1.0 was defined in the previous
   (-00) version of this document.  SDF 1.1 is expected to be defined in
   a future version; the present document represents a draft on the way
   from 1.0 to 1.1.  Hence, this is not an implementation draft.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-asdf-sdf/

There is also an HTML version available at:
https://www.ietf.org/archive/id/draft-ietf-asdf-sdf-01.html

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-asdf-sdf-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 16 Nov 2020 00:10:09 +0100

I quickly typed in what I think the results of last week’s hackathon were, i.e. pretty much resolution on issue #3 and lots of progress on issue #4.

Lots of small editorial fixes, too.

I apologize for not having had the time to fix the CDDL-to-jso converter to somehow handle co-occurrence constraints expressed as group choices (which will probably blow up the jso further), so no appendix B today.  Certainly, the CDDL could use more in the way of co-occurrence, as indicated by the slightly revamped Table 4.

Continuing the resolution of #4 (with an eye on #3):
The remaining use of “pointer lists” is sdfRequired.  Do we understand when that is being used vs. the “required” quality of »type: object« sets of data qualities?

(I believe sdfRef is exactly what it should be; however, see my new issue https://github.com/ietf-wg-asdf/SDF/issues/7 for a detail we need to nail down.)

On to issue 2 and 5.

Grüße, Carsten

> On 2020-11-15, at 23:51, [email-masked] wrote:
> 
> 
> -- 
> ASDF mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/asdf