Subject: [Asdf] Github Actions for SDF converters and oneDM playground models

From: Jan Romann <[email-masked]>
Date: Tue, 24 Aug 2021 21:28:03 +0200

Dear all,

I am currently working on a converter [1] between SDF and Web of Things
(WoT) Thing Descriptions (TDs) and Thing Models (TMs). As a follow-up to
the discussions during the IETF hackathon, I set up a repository [2]
that is automatically updated with models from the OneDM playground that
have been converted to TMs whenever a push to the converter's main
branch occurs. This process is realized by a Github Actions workflow [3]
and a simple script [4] which iterates over all playground models. It
should be easily adaptable if you are also developing a converter from
SDF to another format, especially when it comes to converters that can
be used as a command line tool. For granting the comitting Action
access, you need to set up an API key with write permissions for the
destination repository and store it in the converter repository as a
secret [5].

A point that might be worth discussing in this context is if the
repositories with converted models should rather be located in the oneDM
(or ASDF) Github organization or if they should be maintained by the
converter developers themselves.

Best regards,

Jan Romann

[1] https://github.com/JKRhb/sdf-wot-converter-py
[2] https://github.com/JKRhb/onedm-playground-wot-tm
[3]
https://github.com/JKRhb/sdf-wot-converter-py/blob/main/.github/workflows/convert_sdf_models.yml
[4]
https://github.com/JKRhb/sdf-wot-converter-py/blob/main/convert_playground.sh
[5] See here for more information regarding the Action in the workflow:
https://github.com/marketplace/actions/push-a-file-to-another-repository

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 24 Aug 2021 22:08:03 +0200

On 2021-08-24, at 21:28, Jan Romann <[email-masked]> wrote:
> I set up a repository

… and for those who maybe don’t care about the specifics of the Github actions that much:

The translated models are ready for your perusal at...

https://github.com/JKRhb/onedm-playground-wot-tm/tree/main/tm

If you have tools that can process WoT TMs, feedback would be welcome.

Grüße, Carsten

---

From: Michael Koster <[email-masked]>
Date: Wed, 25 Aug 2021 07:23:20 -0700

Great! I really like seeing SDF conversions to other frameworks; it exposes a lot of aspects of the underlying design patterns.

I woud like to look a little closer at how we construct references to the SDF source definition. I don't quite see how the URI is resolved using "sdf:jsonPointer". Can you explain this part?

Best regards,

Michael

> On Aug 24, 2021, at 1:08 PM, Carsten Bormann <[email-masked]> wrote:
> 
> -- 
> ASDF mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/asdf

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 25 Aug 2021 16:25:39 +0200

> Great! I really like seeing SDF conversions to other frameworks; it exposes a lot of aspects of the underlying design patterns.

Indeed!

> I woud like to look a little closer at how we construct references to the SDF source definition. I don't quite see how the URI is resolved using "sdf:jsonPointer". Can you explain this part?

This is necessarily somewhat fudged at the moment; once the playground models have proper namespacing, these should simply be JSON pointers.

Grüße, Carsten