Subject: [Asdf] Sunday drafts for Friday's ASDF WG meeting

From: Carsten Bormann <[email-masked]>
Date: Sun, 7 Nov 2021 01:46:58 +0100

With the meeting week imminent and I-D submission open again, I just posted three drafts that might be useful to look at for the WG meeting on Friday:

(1) draft-ietf-asdf-sdf-09

https://www.ietf.org/archive/id/draft-ietf-asdf-sdf-09.html

-09 is almost the same as the pre-moratorium -08 (which added URIs as possible values for the “unit” quality), but now also defines a URN namespace for the inverse direction (e.g., RDF-based ecosystem formats that want to reference SDF units).
See note 1 to table 4 for the meat (the diff is extremely noisy due to an xml2rfc change).

Apart from tweaking at specific qualities such as “unit”, we of course need to continue the work of hardening the document for WGLC and IETF/IESG processing.
-08 had the replacement of a normative reference to json-schema.org material by a normative appendix that has the content we need.  We should now look at the specification and see if there are other parts that need to be finished before WGLC.

(2) draft-kiesewalter-asdf-yang-sdf-01

https://www.ietf.org/archive/id/draft-kiesewalter-asdf-yang-sdf-01.html

This contains a significant update to Jana's detailed descriptions of the SDF ⬌ YANG conversion.  Even if you don’t care that much about YANG, a lot can be learned from this exercise for other converters as well.  The most interesting problem that YANG poses is that it doesn’t tell you where in the data model the actual affordances are — in principle, you can target any point in the tree.  SDF instead clearly identifies the affordances, separate from the tree structure of any data.  This information simply isn’t present in the YANG model, so some guessing is required.  (There are a few other interesting observations, including about regular expressions.)

This draft is out of scope of the current charter and might even be considered a research contribution, but we submitted this to the ASDF WG because it is immediately relevant to the translatability of SDF models.

(3) draft-bormann-asdf-sdf-mapping-00

https://www.ietf.org/archive/id/draft-bormann-asdf-sdf-mapping-00.html

This contains a formal description for what a mapping file could be, as well as two examples of using such a mapping file (one of which uses W3C WoT Thing Models as the other ecosystem).

This draft is pretty early stage, but the intention is to move something like this forward to become a companion specification to the main SDF standard.

The draft stays clear of addressing the “class vs. instance” distinction (e.g., it uses WoT Thing *Models* to stay on the class side).
We need a processing model to handle instantiation, and maybe this can be made orthogonal to the augmentation function of a mapping file.
Both dimensions need links, but in very different ways, so there is likely to be more than just one additional component we still need to build for this.

			.oOo.

We have only one hour on Friday, so any discussion we could have here on the mailing list beforehand would ease the timing of the WG meeting.

Oh, and I should explicitly acknowledge the student contributions to the two individual drafts: it is a privilege to work with bright young students on this, and we had a little hackathon of our own this week to get the updates to the existing as well as the new draft in place.

Grüße, Carsten

---

From: Ari Keränen <[email-masked]>
Date: Wed, 10 Nov 2021 11:44:40 +0000

Thanks Carsten (and students)!

Some comments and thoughts inline.

> See note 1 to table 4 for the meat (the diff is extremely noisy due to an xml2rfc change).

This is great, thanks! I think RDF use of SenML units is very useful also beyond SDF. I wonder if we can do something to avoid the percent-encoding issue? Perhaps we (at least) just avoid "%" in the future SenML unit identifiers.
 
> -08 had the replacement of a normative reference to json-schema.org material by a normative appendix that has the content we need.  We should now look at the specification and see if there are othe…

I have a list of various small clarifications (mostly on terminology, more examples, but also on affordance use, instances, etc.) . Hopefully ready soon for a PR.
 
> This draft is out of scope of the current charter and might even be considered a research contribution, but we submitted this to the ASDF WG because it is immediately relevant to the translatabilit…

Will put this to the reading list and looking forward to hear more about your learnings in future interims.

> Both dimensions need links, but in very different ways, so there is likely to be more than just one additional component we still need to build for this.

Great! Agree that we need this piece standardized to close the loop with ecosystems and this is a great start. Also good points raised on the namespace use.

> Oh, and I should explicitly acknowledge the student contributions to the two individual drafts: it is a privilege to work with bright young students on this, and we had a little hackathon of our ow…

Excellent work!

Cheers,
Ari