Subject: Re: Fwd: [Asrg] How many legitimate SMTP servers?

From: Scott Nelson <[email-masked]>
Date: Fri, 09 May 2003 09:16:35 -0700

At 08:37 PM 5/8/03 -0400, Yakov Shafranovich wrote:
>
>>From: "Ken Hirsch" <[email-masked]>
>>
>>Does anybody have an idea of how many legitimate SMTP servers there are?
>>That is SMTP servers that are not used primarily for spam, have a static IP
>>address, and have been active in the last, say, 12 months.
>
>These might be a starting point:
>
>http://cr.yp.to/surveys.html
>http://www.isc.org/ds/
>

From the first link, I see that on 2001-10-03,
D. J. Bernstein estimates over 4 million 
 (estimate made from a sample of 1 million random IPs)
42% ran some flavor of sendmail,
17% ran Microsoft Exchange or IIS.
17% ran qmail
(there were others, see the original survey)

His methodology looks good, I trust these numbers were reasonably
accurate in 2001-10-03.  That was over 18 months ago,
a long time in internet years, but I think they probably haven't
changed all that much since then.

Scott Nelson <[email-masked]>

_______________________________________________
Asrg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/asrg

---

From: "Tom Thomson" <[email-masked]>
Date: Mon, 12 May 2003 15:20:38 +0100

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Scott
Nelson
Sent: 09 May 2003 17:17
To: [email-masked]
Subject: Re: Fwd: [Asrg] How many legitimate SMTP servers?

Scott Nelson <[email-masked]>
-----------------------------------------------------

I think "probably haven't changed all that much" is a bit suspect.  We can
expect the trends reported by DB to have continued.  So for example if the
decline in sendmail continued over the last 18 months as it had over the
previous couple of tears we should expect it to represent maybe 35% now.
The proportion of hosts that respond on port 45 had increased - why
shouldn't it have increased again?  The hostcount reports (for example those
from RIPE) indicate a considerable increase in the number of hosts over the
18 months since DB's last survey (continuing a long-standing trend) so we
might expect to see something over 5 million SMTP servers instead of
something over 4 million.

Of course we then have a second problem: DB's figures are for servers which
receive mail on port 25, while the original query was for servers that
transmit mail on port 25. These are not the same servers so the numbers may
not be right (far more transmit than receive, I think).

Tom

---

From: "Eric Dean" <[email-masked]>
Date: Mon, 12 May 2003 11:49:49 -0400

Here are some sender count statistics...not message counts...within a small
production system.  These are the number of senders and their current
states.  The number of messages passed/blocked are much greater.

maverix=# select sender_method,count(*) from maverix_senders group by
sender_method;

 sender_method |  count
---------------+---------
 AdminAction   |       67
 UserBlocked   |    31012
 BounceBlocked |   434796
 SelfVerified  |     4254
 UserVerified  |     8123

1) Sometimes, an Admin has to correct a black or whitelisted sender
2) Users add to their own blacklist.
3) We auto-block a lot of spam by receiving an SMTP error: unknown user
4) Senders do respond to C/R.
5) Users also verify a sender more often than a sender responds to C/R

As I mentioed, the probing is of more value than C/R