Subject: RE: [Asrg] (Position): Successful anti-spam techniques must avoid software patents

From: Yakov Shafranovich <[email-masked]>
Date: Thu, 29 May 2003 15:14:04 -0400

I am currently working on a draft summarizing IP issues relevant to the 
group AND a list of all IP claims with statements from owners.

But I believe it was mentioned in a list message before 
(https://www1.ietf.org/mail-archive/working-groups/asrg/current/msg02089.html):

 >From: [email-masked]
 >Date: Mon, 24 Mar 2003 16:03:12 -0800 (PST)
 >Subject: Re: [Asrg] ASRG work items
 >
 >lso I'd like to add additional topic - IPR. I know IRTF currently does
 >not have IPR policy, but I'd like one established just for this research
 >group. I think we can do the following:
 >1. Whenever somebody mentions technology where they know some patent exist
 >or may possibly apply to the technology, the person should make statement
 >about IPR rights. If this patent has not been mentioned before on list,
 >there should be information either together with IPR statement or at the
 >end of message with either:
 > a. If patent is received: US (or other country), Patent#, possibly link
 >    to the patent website
 > b. If patent is pending - Name of person or organization that filed it
 >    and date it was filed, possibly application#
 >2. I would like to see somebody on the list volunteer to maintain list
 >of all patents mentioned (see abobve) and this list provided either
 >regularly to email list or located and updated on rg website.

Yakov

At 07:43 AM 5/29/2003 -1000, Peter Kay wrote:

>Is this discussion of IPR policy within the scope of this list's
>discussion?
>
>I look at :
>
>http://www.irtf.org/asrg/
>
>And read the posting guidelines which say all conversation must be
>related to the work items at
>
>http://www.irtf.org/asrg/asrg-work-items.txt
>
>and there's nothing there about IPR. Perhaps IPR is a bigger issue to be
>taken at higher levels.
>
>As one who has patent-pending on an anti-spam technology, I've got a lot
>to say but won't if its inappropriate for this list.
>
>Peter Kay
>President
>TitanKey Software
>Web: www.titankey.com
>The only technology that stops spam BEFORE it's even sent
>
>
>
> > -----Original Message-----
> > From: David Wheeler [mailto:[email-masked]]
> > Sent: Wednesday, May 28, 2003 4:13 AM
> > To: Paul Judge
> > Cc: [email-masked]'
> > Subject: Re: [Asrg] (Position): Successful anti-spam
> > techniques must avoid software patents
> >
> >
> >
> >
> > Paul Judge wrote:
> >
> > >
> > > We've had previous discussions about IPR policy. Please see Vern
> > > Paxson's message on the topic:
> > >
> > https://www1.ietf.org/mail-archive/working->
>groups/asrg/current/msg0192
> > > 9.html
> > > . If anyone feels the need to voice additional positions on
> > this topic,
> > > please feel free to address them to me off-list.
> >
> >
> > Thanks for pointing me to the previous email.
> > However, that email simply points out that there's no policy
> > and that there appears to be a need for one... I don't see a
> > decision being made. In particular, it suggests that: "for
> > any technology discussed within RGs that has related IPR,
> > that the presence of the possible IPR be disclosed."
> >
> > While I believe that's too weak, required disclosure is at
> > least a good start for informed discussion, and that at least
> > is something that the working group could quickly agree on as
> > a starting point.
> >
> > Can the working group at least agree to require disclosure
> > the presence of any related IPR (including _pending_
> > patents)?  This is the sort of thing that has to be agreed on
> > NOW, during discussions, instead of waiting for "later" (when
> > it will be too late).  Otherwise, a few enterprising
> > individuals will submit patent requests on obvious ideas the
> > day before they post, work hard to make sure their idea is
> > implemented, and then surprise all with a patent (the U.S.
> > PTO, for example, is notoriously bad at identifying obvious
> > ideas). The result: anti-spam approaches will fail.
> >
> > --- David A. Wheeler
> >
> > _______________________________________________
> > Asrg mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/asrg
> >
> >
> >
>
>
>_______________________________________________
>Asrg mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/asrg

_______________________________________________
Asrg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/asrg

---

From: "Peter Kay" <[email-masked]>
Date: Fri, 30 May 2003 08:43:41 -1000

To me, this is the beauty of patents:  patent holders could and should
give full disclosure in groups like this and do not have to fear
infringement and/or loss of any IP.

So, to both below, I, personally am more than happy to completely "open
the kimono" let everyone know how this works. Because in a very real
sense, all I need to do is distribute the patent filing. All the gory
details are there.

Peter

> From: Spencer Dawkins [mailto:[email-masked]] 
> Sent: Friday, May 30, 2003 1:59 AM
> To: [email-masked]
> Dear Vern,
> Given that we're roughing out a (WG-sized) IPR policy, my 
> suggestion would be that "if you're willing to disclose IPR 
> using the current draft template from the IETF IPR working 
> group, then participating in discussions is OK".
> 
> Just to push the envelope a little on what "disclose" might 
> look like...
> 
> I'm not saying we need to adopt the (proposed) IETF mechanism 
> in IRTF, only that the current draft of the disclosure 
> template might help a participant understand what "disclose" 
> looks like.
> 
> Spencer
> 
> ----- Original Message -----
> From: "Vern Paxson" <[email-masked]>
> To: <[email-masked]>
> Sent: Friday, May 30, 2003 1:48 AM
> > Peter Kay writes:
> > > and there's nothing there about IPR. Perhaps IPR is a 
> bigger issue 
> > > to be taken at higher levels.
> >
> > Given that the IRTF does not have a formulated IPR policy, and that 
> > IPR issues are potentially of significant concern to this RG due to 
> > the participation of a number of folks from the commercial world, I 
> > don't have a problem with productive discussion of IPR 
> issues on the 
> > mailng list in this context.
> >
> > > As one who has patent-pending on an anti-spam technology, 
> I've got a 
> > > lot to say but won't if its inappropriate for this list.
> >
> > If you are not willing to disclose where this potential IPR 
> resides, 
> > then Yes, I think it would be inappropriate to participate in 
> > discussions that relate to it.  If you're willing to disclose its 
> > existence, then I think participating is okay.
> >
> > Vern