Subject: RE: [Asrg] seeking comments on new RMX article

From: "Eric D. Williams" <[email-masked]>
Date: Tue, 6 May 2003 13:55:04 -0400

I stand corrected.  I do not see that as a best practice (esp. related to 
secure configuration of an IP).

-e

On Tuesday, May 06, 2003 1:18 PM, Vernon Schryver 
[SMTP:[email-masked]] wrote:
> > From: "Eric D. Williams" <[email-masked]>
>
> > ...
> > > That seems to be based on the mistaken notion that there can be only
> > > a single PTR RR per IP address.
> >
> > There can only be one canonical reverse mapping for an IP address.
>
> Where does the word "canonical" appear in RFC 1034 in connection with
> PTR RRs?
>
> >                                                                     There
> >                                                                     can
> > be multiple forward A records.  That is not to say the a PTR record can't 
be
> >
> > dynamically configured. However, yes that is the case for any instance for 
a
> >
> > transient or permenant assignment of a PTR RR AFAIK.
> >
> > 100	IN	PTR	domain1.com.
> > 	IN	PTR	domain2.com.
> >
> > does not work AFAIK, I will give it a shot.
>
> Those are quite similar to the lines that temporarily cause this:
>     % nslookup -d 192.188.61.4
>     ...
> 	QUESTIONS:
> 	    4.61.188.192.in-addr.arpa, type = PTR, class = IN
> 	ANSWERS:
> 	->  4.61.188.192.in-addr.arpa
> 	    name = andesite.rhyolite.com
> 	    ttl = 86400 (1D)
> 	->  4.61.188.192.in-addr.arpa
> 	    name = ns3.rhyolite.com
> 	    ttl = 86400 (1D)
>     ...
>
>
> See also http://www.google.com/search?q=%22multiple+ptr%22+dns
>
>
> Vernon Schryver    [email-masked]
> _______________________________________________
> Asrg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/asrg

_______________________________________________
Asrg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/asrg

---

From: Vernon Schryver <[email-masked]>
Date: Tue, 6 May 2003 12:43:18 -0600 (MDT)

> secure configuration of an IP).

I don't understand the second sentence.  How is a system's security
affected by having more than one PTR RRs for an IP address? 

I would agree that because many applications and support tools don't
understand multiple PTR RRs per IP address, it would be unwise to
build a large scale protocol or application that depends on them being
widely supported immediately.