Subject: RE: [Asrg] 6. Propsals -- Labeling recommendations for the FTC

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Wed, 26 Nov 2003 11:00:57 -0800

How about

IETF:Advertisement
IETF:Spam
IETF:etc.

This tagging mechanism is used extensively in XML and the number of
namespace collisions is remarkably small. Even though xml also uses URI
namespace labels to define the meaning of the prefixes there are few
collisions.

Alternatively use the RFC number of the final draft:

RFC1234:Advertisement

That gets you into vanishingly small chances of collision.

What we are defining here is a shared vocabulary of terms. What the AI folk
incorrectly refer to as an Ontology (really its a system of 'being', the
claim for machina ex deus seems to come from misreading Heidegger).

All that we need to do is to ensure:

1) That all the interpreters of the tokens understand a given token in the
same way
2) That all the generators of the tokens use tokens that are understood by
the receivers.

I think either of the schemes achieves that. The IETF: approach is probably
preferable in the light of the CANSPAM act because it makes the origin
unambiguous. The RFC1234: approach is preferable as a general rule.

		Phill

> -----Original Message-----
> From: Eric S. Raymond [mailto:[email-masked]]
> Sent: Wednesday, November 26, 2003 12:15 PM
> To: Brett Watson
> Cc: [email-masked]
> Subject: Re: [Asrg] 6. Propsals -- Labeling recommendations 
> for the FTC
> 
> 
> Brett Watson <[email-masked]>:
> > I don't have any fundamental objection to the use of the "keywords"
> > field for this purpose, but I think that any special
> > universally-meaningful keywords which are introduced should be given
> > their own "namespace", purely out of respect for the original intent
> > of the field.
> 
> This just pushes the problem back a level.  How do you know you won't
> collide with someone else's namerspace grab? :-)
> -- 
> 		<a href="http://www.catb.org/~esr/">Eric S. Raymond</a>
> 
> _______________________________________________
> Asrg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/asrg
> 

_______________________________________________
Asrg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/asrg

---

From: "Eric S. Raymond" <[email-masked]>
Date: Wed, 26 Nov 2003 15:36:11 -0500

> unambiguous. The RFC1234: approach is preferable as a general rule.

I rather like that.