Subject: RE: [Asrg] 6. Propsals -- Labeling recommendations for the FTC

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Wed, 26 Nov 2003 06:50:41 -0800

If keywords are in a header then it really does not matter what language
they are in.

If we are encoding keywords into subject lines the result is liable to be
fragile. But even here there is a precedent, RE, FWD, WAS

BTW note that PICS and P3P are probably the least successful web protocols
deployment wise.

> -----Original Message-----
> From: Eric S. Raymond [mailto:[email-masked]]
> Sent: Wednesday, November 26, 2003 9:46 AM
> To: Eric Brunner-Williams in Portland Maine
> Cc: Eric S. Raymond; ASRG
> Subject: Re: [Asrg] 6. Propsals -- Labeling recommendations 
> for the FTC
> 
> 
> Eric Brunner-Williams in Portland Maine <[email-masked]>:
> > Eric,
> > 
> > i18n/l10n.
> > 
> > Eric
> 
> I thought about it.
> 
> Yes, the keywords and ADV are English.  There are 4, count 
> 'em 4 tokens;
> with a vocabulary that small, the benefits of 
> internationalization are 
> extremely dubious compared to the added complexity.
> 
> I'll add a 'graph about this to the Rationale.
> -- 
> 		<a href="http://www.catb.org/~esr/">Eric S. Raymond</a>
> 
> _______________________________________________
> Asrg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/asrg
> 

_______________________________________________
Asrg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/asrg

---

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Wed, 26 Nov 2003 11:09:44 -0800

> Brett Watson <[email-masked]>:
> > I don't have any fundamental objection to the use of the "keywords"
> > field for this purpose, but I think that any special
> > universally-meaningful keywords which are introduced should be given
> > their own "namespace", purely out of respect for the original intent
> > of the field.
> 
> This just pushes the problem back a level.  How do you know you won't
> collide with someone else's namerspace grab? :-)
> -- 

The other point in this regard is that people are unlikely to grab namespace
that is going to lead to their emails being deep-sixed.

It is in practice pretty easy to grab namespace in the IETF. Just deploy
something that uses it and the chance anyone will tread on you is
negligible.

There is an IP address that people are forbidden to use because it was the
default address in an ancient version of SunO/S. Try to use the address and
you would fail, even today.

Consider the following thought experiment. I want to use a DNS code type for
my own use. The WG refuses to accept my paper, I say screw them and deploy
anyway and use the next number in line to do so. I deploy on a wide scale.
What does the WG do when it comes to assign a code to the next draft that
comes along needing one? Does it insist on creating a collision or just skip
to the next one of the 65,000 free choices?

If it is possible to game the system against the IETF in this way the
reverse is also true. Nobody is likely to use one of these keywords as a
result of an accident, provided that we take a step outside the domain used
by human keyword generators.

		Phill