Subject: RE: [Asrg] user-level blacklisting patented

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Wed, 16 Mar 2005 14:21:04 -0800

Nathaniel Bornstein implemented a system of that type sometime in or before
1995 and I had a conversation to that effect with Tim Berners-Lee at MIT in
the spring of 1996.

The email callback loop itself was demonstrated in the COMLINK system in the
fall of 1994 at WWW'94#2 by John Mallery and Roger Hurwitz (see conference
proceedings) and deployed in Vice President Al Gore's Open Meeting on
Reinventing Government in 1995.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Devdas Bhagat
> Sent: Wednesday, March 16, 2005 4:26 PM
> To: [email-masked]
> Subject: Re: [Asrg] user-level blacklisting patented
> 
> 
> On 16/03/05 15:30 -0500, James Baldwin wrote:
> > On 16 Mar 2005, at 14:56, Peter Kay wrote:
> > 
> > > We fully recognized (and disclosed) that server-level
> > > white/blacklisting was
> > > prior art. We were purposely explicit in that this is a 
> user-level or
> > > user-controlled black/whitelist process which according to our 
> > > research was
> > > nonexistent before Jan 2000.
> > 
> > No mail clients rejected/filtered mail based on address 
> book contents
> > prior to Jan 2000? Or is that not covered by this patent? I've only 
> > given it a brief perusal in the past 10 minutes plus IANAL.
> 
> This is on the MTA, not the MUA.
> 
> Devdas Bhagat
> 
> _______________________________________________
> Asrg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/asrg
> 

_______________________________________________
Asrg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/asrg

---

From: "Peter Kay" <[email-masked]>
Date: Wed, 16 Mar 2005 13:29:02 -1000

> 
> So you are claiming that nobody before Jan 2000 did selective 
> blocking based on both the recipient and sender prior to the 
> DATA statement?  Or is "user-controlled" specifically part of 
> the patent? 

Our fundamental claim is based on an authorized sender list for a given
user. The additional claims talk about whitelisting, blacklisting,
challenge/response, and dynamic updating of that database based on sent
mail.