Subject: [Asrg] IPv6 BCP?!

From: "J.D. Falk" <[email-masked]>
Date: Mon, 04 Aug 2008 09:32:46 -0600

Are you guys really trying to define a BCP for IPv6 DNSBLs?  How can it
possibly be a Best Current/Common Practice when there aren't any IPv6 DNSBLs
yet?

Proposal: finish defining existing practice as previously agreed, and split
out IPv6 into a more theoretical document.

-- 
J.D. Falk
Return Path

Work with me!
http://www.returnpath.net/careers/

_______________________________________________
Asrg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/asrg

---

From: Dave Crocker <[email-masked]>
Date: Mon, 04 Aug 2008 09:00:39 -0700

> possibly be a Best Current/Common Practice when there aren't any IPv6 DNSBLs

AND...

Why should an IPv6 BL be different from an IPv4 one, except for the format of 
the addresses?

d/

-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net
_______________________________________________
Asrg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/asrg

---

From: John Levine <[email-masked]>
Date: 4 Aug 2008 16:05:14 -0000

>Are you guys really trying to define a BCP for IPv6 DNSBLs?

Nope.  We're just trying to define the format of bits on the wire
so when people build them, they'll interoperate.  This argument is
about my DNSBL spec, not Chris' BCP.

R's,
John

---

From: John Levine <[email-masked]>
Date: 4 Aug 2008 18:24:53 -0000

>Why should an IPv6 BL be different from an IPv4 one, except for the
>format of the addresses?

Um, are there any differences I've inadvertently introduced in the
current draft?  We've fended off attempts to make the values anything
other than A and TXT.  There's an open question about what the test
addresses should be, but I'm trying to figure out what the never
routable addresses analogous to 127/0 are.

R's,
John

---

From: "J.D. Falk" <[email-masked]>
Date: Mon, 04 Aug 2008 12:34:40 -0600

> about my DNSBL spec, not Chris' BCP.

Ah, okay, whew.  But even so, wouldn't it make more sense to do some
research into IPv6 DNSBLs before defining how they'll work?  Or if not,
wouldn't it make more sense to get the current spec published before adding
something uncertain & controversial?

-- 
J.D. Falk
Return Path

Work with me!

---

From: Dave Crocker <[email-masked]>
Date: Mon, 04 Aug 2008 11:39:48 -0700

> routable addresses analogous to 127/0 are.

Any reason not to simply add AAAA records to the mix and be done with it?

d/

-- 

   Dave Crocker

---

From: "David Nicol" <[email-masked]>
Date: Mon, 4 Aug 2008 14:20:07 -0500

> Any reason not to simply add AAAA records to the mix and be done with it?

IIRC it's that the current 6->4 mapping is supposed to eventually go
away, and the test address mappings SHOULD survive that event.
_______________________________________________
Asrg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/asrg

---

From: "Frank Ellermann" <[email-masked]>
Date: Mon, 4 Aug 2008 21:42:27 +0200

J.D. Falk wrote:
 
> wouldn't it make more sense to do some research into IPv6
> DNSBLs before defining how they'll work?

The only question that has to be answered is which IPv6 can
be the sacrifice maiden for an always listed test address.

Now after somebody got me to see that ::FFFF:127.0.0.2 is
not simple enough there is still the original proposal ::2,
and the new proposal in the meeting to use an IPv6 example
address.

Similar there was a s/test/invalid/ proposal for RHSBLs.

IMO it is perfect when a "proposed standard" proposes an
answer to a simple question.  There is no huge installed
base with different ideas (wrt IPv6), or with better ideas
(wrt RHSBLs).

It's not really "controversial", it would be only nice to
hear from some IPv6 experts that ::2 is okay as sacrifice.

I.e. that nobody would ever want to list or not list that
IP for "real".  Outside of a toy DNSBL with say "odd IPs",
where ::2 or 127.0.0.2 don't qualify as "odd enough".

 Frank

---

From: Tony Hansen <[email-masked]>
Date: Mon, 04 Aug 2008 22:10:03 -0400

::2 is reserved for IETF use. This seems like it could be a perfectly 
valid such use to be defined for it.

	Tony Hansen
	[email-masked]

---

From: John Levine <[email-masked]>
Date: 5 Aug 2008 09:03:30 -0000

> research into IPv6 DNSBLs before defining how they'll work?  Or if
> not, wouldn't it make more sense to get the current spec published
> before adding something uncertain & controversial?

For the most part, the way that v6 DNSBLs will work is obvious, just
use the v6 rDNS naming rather than v4 rDNS naming.  The only parts
that aren't obvious are arbitrary, notably the test addresses.  Since
they're arbitrary, it makes sense to me to define them now so that
when people start building v6 DNSBLs they interoperate.

R's,
John

---

From: John Levine <[email-masked]>
Date: 5 Aug 2008 09:03:30 -0000

R's,
John

---

From: "Frank Ellermann" <[email-masked]>
Date: Tue, 5 Aug 2008 14:39:06 +0200

Tony Hansen wrote:

> ::2 is reserved for IETF use. This seems like it could
> be a perfectly valid such use to be defined for it.

Nice, then s/test/invalid/ was the last technical point,
anything else is wordsmithing and maybe adding BCP 91 or
similar in the references.

 Frank