Subject: [atoca] WG adoption for draft-barnes-atoca-cap-mime

From: "Thomson, Martin" <[email-masked]>
Date: Wed, 19 Oct 2011 13:05:34 +0800

This is a call for consensus on the adoption of draft-barnes-atoca-cap-mime by the working group.

Please express your opinion on the following two points:

 a) If the work described by draft-barnes-atoca-cap-mime-01 is something that the working group should do

 b) If draft-barnes-atoca-cap-mime-01 should be adopted by the working group to address that need

The chairs will make a decision on this on the 2nd of October.

---

From: "Richard L. Barnes" <[email-masked]>
Date: Wed, 19 Oct 2011 09:48:04 -0400

> a) If the work described by draft-barnes-atoca-cap-mime-01 is something that the working group should do

+1

> b) If draft-barnes-atoca-cap-mime-01 should be adopted by the working group to address that need

+1

Not that I'm biased or anything :)
--Richard

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 19 Oct 2011 08:07:11 -0600

>  b) If draft-barnes-atoca-cap-mime-01 should be adopted by the working group to address that need

+1 to both. IMHO it's not absolutely necessary for this media type to be
registered via the WG, but I see no harm in doing so.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: "James M. Polk" <[email-masked]>
Date: Wed, 19 Oct 2011 11:57:22 -0500

At 12:05 AM 10/19/2011, Thomson, Martin wrote:
>This is a call for consensus on the adoption of 
>draft-barnes-atoca-cap-mime by the working group.
>

When did draft-ietf-atoca-cap go on the back burner within this WG?

Richard made this comment (that "it is no longer prioritized") a week 
or two ago as justification for writing this ID.

ISTM that since having two WG items doing accomplishing the same 
thing is confusing (registering the exact same MIME type to be used 
in exactly the same way), and I haven't heard a good answer.

without a good answer, I cannot voice support for this second ID.

James

>  a) If the work described by draft-barnes-atoca-cap-mime-01 is 
> something that the working group should do
>
>_______________________________________________
>atoca mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/atoca

---

From: "Richard L. Barnes" <[email-masked]>
Date: Wed, 19 Oct 2011 13:07:08 -0400

draft-ietf-atoca-sip-cap does a lot more than just define the MIME type.  We can remove the MIME type registration from that document and still have plenty to discuss.  That document should not be blocking for this one.

--Richard

On Oct 19, 2011, at 12:57 PM, James M. Polk wrote:

> Richard made this comment (that "it is no longer prioritized") a week or two ago as justification for writing this ID.
> 
> ISTM that since having two WG items doing accomplishing the same thing is confusing (registering the exact same MIME type to be used in exactly the same way), and I haven't heard a good answer.
>

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 19 Oct 2011 11:13:52 -0600

> draft-ietf-atoca-sip-cap does a lot more than just define the MIME type.  We can remove the MIME type registration from that document and still have plenty to discuss.  That document should not be…

Agreed.

James, is there *harm* in pulling the media type registration bits out
of draft-ietf-atoca-cap and advancing the two specs separately?

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: "James M. Polk" <[email-masked]>
Date: Wed, 19 Oct 2011 12:34:33 -0500

"we" means Brian - as editor of draft-ietf-atoca-cap, based on WG 
consensus and at the direction of the WG chairs. I haven't heard from 
Brian on this.

Plus, I don't see what's being blocked by draft-ietf-atoca-cap. It's 
been around for a long time, and I really don't see what's holding it 
up in this WG.

James

At 12:07 PM 10/19/2011, Richard L. Barnes wrote:
>draft-ietf-atoca-sip-cap does a lot more than just define the MIME 
>type.  We can remove the MIME type registration from that document 
>and still have plenty to discuss.  That document should not be 
>blocking for this one.
>
>--Richard
>
>
>
> > Richard made this comment (that "it is no longer prioritized") a 
> week or two ago as justification for writing this ID.
> >

---

From: "James M. Polk" <[email-masked]>
Date: Wed, 19 Oct 2011 12:38:19 -0500

At 12:13 PM 10/19/2011, Peter Saint-Andre wrote:
> > draft-ietf-atoca-sip-cap does a lot more than just define the 
> MIME type.  We can remove the MIME type registration from that 
> document and still have plenty to discuss.  That document should 
> not be blocking for this one.
>
>Agreed.
>

Why not progress draft-ietf-atoca-cap as is to WGLC, or are there 
parts that are controversial or unfinished?

Where's the rush to get this MIME type registered? I don't mean 
"uuuu, let's see how we can delay this some more", but it's obviously 
going to be registered using draft-ietf-atoca-cap (right now at 
least), so it's not like it isn't written anywhere. Is there a 
pressing need to split this out in a rather abrupt way?

James

---

From: "Richard L. Barnes" <[email-masked]>
Date: Wed, 19 Oct 2011 14:08:23 -0400

Just as a point of process: draft-ietf-atoca-cap should actually be draft-rosen-atoca-cap.  It was one of the two documents that the chairs accepted without a consensus call [1], and while there was a call to adopt the requirements draft [2], I don't see one for this one.  It doesn't make sense to call for a WGLC on a document that hasn't been adopted by the WG.

The latest we have on -atoca-cap is an instruction from the chairs to behave as if this document didn't exist [3]. Since draft-ietf-atoca-cap doesn't exist, we *definitely* need something to register a mime type :)

--Richard

[1] <http://www.ietf.org/mail-archive/web/atoca/current/msg00152.html>
[2] <http://www.ietf.org/mail-archive/web/atoca/current/msg00132.html>
[3] <http://www.ietf.org/mail-archive/web/atoca/current/msg00148.html>

On Oct 19, 2011, at 1:34 PM, James M. Polk wrote:

> "we" means Brian - as editor of draft-ietf-atoca-cap, based on WG consensus and at the direction of the WG chairs. I haven't heard from Brian on this.
> 
> Plus, I don't see what's being blocked by draft-ietf-atoca-cap. It's been around for a long time, and I really don't see what's holding it up in this WG.
> 
> James
>

---

From: "Carl Reed" <[email-masked]>
Date: Wed, 19 Oct 2011 13:03:04 -0600

+1 to both.

Carl

---

From: "Thomson, Martin" <[email-masked]>
Date: Thu, 20 Oct 2011 05:48:55 +0800

On 2011-10-20 at 05:08:23, Richard L. Barnes wrote:
> Just as a point of process: draft-ietf-atoca-cap should actually be 
> draft-rosen-atoca-cap.  It was one of the two documents that the 
> chairs accepted without a consensus call [1], and while there was a 
> call to adopt the requirements draft [2], I don't see one for this 
> one.  It doesn't make sense to call for a WGLC on a document that 
> hasn't been adopted by the WG.
>
> The latest we have on -atoca-cap is an instruction from the chairs to 
> behave as if this document didn't exist [3].

That's an accurate summary.

The last time this was discussed, the following points were established:
 - draft-rosen-atoca-cap was not ready for adoption (or the WG wasn't ready to accept it)
 - accepting draft-ietf-atoca-cap was a mistake, but a difficult one to reverse for various logistical reasons

The chairs requested that the authors of draft-rosen-atoca-cap re-issue the individual draft and use that as a basis for discussion.  My guess is that Richard has inferred from the absence of either draft or discussion, there was reduced interest in that work.  That may not be true, or that may change.  In fact, I'd encourage anyone who is interested in pursuing CAP over SIP to work with Brian, Hannes and Henning to advance that work.

--Martin

---

From: "James M. Polk" <[email-masked]>
Date: Wed, 19 Oct 2011 19:40:56 -0500

At 04:48 PM 10/19/2011, Thomson, Martin wrote:
>  - accepting draft-ietf-atoca-cap was a mistake, but a difficult 
> one to reverse for various logistical reasons
>
>The chairs requested that the authors of draft-rosen-atoca-cap 
>re-issue the individual draft and use that as a basis for 
>discussion.  My guess is that Richard has inferred from the absence 
>of either draft or discussion, there was reduced interest in that 
>work.  That may not be true, or that may change.  In fact, I'd 
>encourage anyone who is interested in pursuing CAP over SIP to work 
>with Brian, Hannes and Henning to advance that work.

I remember being one of the first (if not the first) to complain that 
there was no consensus call to adopt this item before it showed up as 
a WG item (all of a sudden). That didn't mean I didn't want the item 
adopted - which runs afoul of the statement "act as if it didn't exist".

What are the issues with -atoca-cap?

Why haven't the chairs called for consensus to adopt this item?

I seem to have missed an entire discussion on why -atoca-cap should 
not be adopted (because of flaw x, flaw Y and flaw Z)...

Or, are the chairs waiting for the terms and definitions and 
requirements and framework items to be adopted first?

It's obvious to me waiting isn't doing anyone any good.

my 2.35 cents (before deflation)

James

---

From: "Thomson, Martin" <[email-masked]>
Date: Thu, 20 Oct 2011 08:53:08 +0800

> What are the issues with -atoca-cap?

There has been discussion on several points.  I don't recall any specific, significant problems.  Look to the archives and meeting minutes.
 
> Why haven't the chairs called for consensus to adopt this item?

Actually, the question was asked at the first meeting.  The consensus at the time was to defer the question.  Since that time, there has been very little discussion and no update to the draft.  That is, aside from the draft-ietf- posting, which I believe had no substantive changes over the individual submission.

--Martin

---

From: Likepeng <[email-masked]>
Date: Thu, 20 Oct 2011 01:00:33 +0000

> Actually, the question was asked at the first meeting.  The consensus at the time was to defer the question.

That is my memory too.

Kind Regards
Kepeng

---

From: "James M. Polk" <[email-masked]>
Date: Wed, 19 Oct 2011 20:04:54 -0500

At 08:00 PM 10/19/2011, Likepeng wrote:
> > Actually, the question was asked at the first meeting.  The 
> consensus at the time was to defer the question.
>
>That is my memory too.

I'll keep my mouth shut (about this) then ...

James

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Thu, 20 Oct 2011 15:07:43 +0200

I don't think this should be a working group item.

ATOCA has a charter, and the main goals of that charter are currently not being met by any current author deliverables. This deliverable in no way advances that charter, and seems merely an attempt to hang something that may be related on to an existing working group.

I think ATOCA either has to concentrate on its main charter, or close. I strongly suspect the later, seeing as noone seems that interested in picking up the pen and producing stuff within the scope of the charter.

There is no reason by a mime type cannot progress outside a working group, and indeed, most do.

Regards

Keith

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Thomson, Martin
> Sent: 19 October 2011 06:06
> To: [email-masked]