Subject: [atoca] What is the scope of "Secure Alerting Format"

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 13 Sep 2012 09:57:58 -0400

In the revised plan, we're supposed to be concentrating on a "Secure Alerting Format"

But what is the scope of that?

I raised, for example, the issue of "area of interest" where the typical CAP message content is not machine actionable to filter messages to the right devices.  The polygon for "continental United States" is not practical to send, and many alerts just have the description.  Is the thing that gets us the area of interest we can route on in scope or not?

Is identity of the originator in scope?

A lot of this depends on the line between "transport" and "format", and I don't understand where we are drawing that line.

Brian

---

From: Richard Barnes <[email-masked]>
Date: Thu, 20 Sep 2012 21:58:18 -0400

In general, I would say that the "Secure Alerting Format" is something that 
1. Represents the alert using CAP or a profile of CAP (== "Alerting Format")
2. Allows the recipient to verify the identity of the originator and/or relay(s)

So the areas for discussion are (1) whether we want to just incorporate CAP by reference, or add some constraints, and (2) how we want to enable originator/relay authentication.

Couple of questions inline.

> I raised, for example, the issue of "area of interest" where the typical CAP message content is not machine actionable to filter messages to the right devices.  The polygon for "continental United…

I don't really know enough about CAP to comment in depth here, but this sounds at a high level like a CAP profiling problem.  "Alert originators SHOULD embed enough information in the CAP message so that the device receiving the alert can determine automatically whether it is in the area of interest or not."

It seems like a good question for the group whether profiling CAP is in scope here, since that might cause compatibility issues with legacy systems.  If we suppose that we might take a more "system-scale" view in the future, we could also kick the can down the road.  (Analogy: SIP allows codec negotiation; phonebcp says what codecs you MUST support.)

> Is identity of the originator in scope?

I would say that the question of which originators are authorized (i.e., which originators a recipient will accept) is out of scope; that's a provisioning/metadata question.  The techniques for associating the alert with one or more verified originator identities is in scope.  

In other words, the S/MIME might include a certificate chain that shows that the alert was signed by an entity with CN=FEMA, but if I'm in Bolivia I might choose to reject that because FEMA isn't an authority there.

> _______________________________________________
> atoca mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/atoca