Subject: Re: <draft-ietf-atommib-atm1ng-04.txt> posting

From: "Michael H. Grobelch" <[email-masked]>
Date: Fri, 22 May 1998 10:47:00 -0700

Kaj,

I  propose the following text to resolve both issues:

"This list contains the AAL5 VCC performance 
 parameters. It is indexed by the ifIndex 
 values of ATM interfaces at which AAL5
 Segmentation And Reassembly (SAR) function
 takes place."

Mike

>
>
>Kaj,
>
>Just so I'm clear:
>
>- this isn't intended to address (for the
>  switch case) whether the aal5VccTable is on the
>  interface at which AAL5 SAR takes place? Rather,
>  it just says it should be on the ATM ifIndex.
>
>If so, that's ok with me.
>
>As I mentioned before, I'm for modeling the AAL5 stuff
>at the interface at which SAR takes place.
>
>Mike
>
> >Message-Id: <9805220336.AA29034@joker>
> >X-Sender: [email-masked]
> >X-Mailer: QUALCOMM Windows Eudora Pro Version 4.0
> >Date: Thu, 21 May 1998 23:31:51 -0400
> >To: Jason Perreault <[email-masked]>, [email-masked],
> >        Gary Hanson <[email-masked]>
> >From: Kaj Tesink <[email-masked]>
> >Subject: RE: <draft-ietf-atommib-atm1ng-04.txt> posting
> >Cc: [email-masked]
> >In-Reply-To: <Pine.SUN.3.96.980521121711.2928C-100000@skeeter>
> >References: <9805181502.AA24066@joker>
> >Mime-Version: 1.0
> >Content-Type: text/plain; charset="us-ascii"
> >Content-Length: 5966
> >
> >At 12:28 PM 5/21/98 -0700, Gary Hanson wrote:
> >>
> >>Kaj,
> >>
> >>The new draft looks very good.  Thanks for the updates you made.
> >>
> >>Here's a suggestion for wording to remove the ambiguity of which
> >>interface, ATM or AAL5, is to be used as the index for the
> >>aal5VccTable.
> >>
> >>I notice that the atmInterfaceConfEntry, atmInterfaceDs3PlcpEntry,
> >>and atmInterfaceTCEntry DESCRIPTIONs all end with the clause "and is
> >>indexed by the ifIndex value of the ATM interface."  I suggest that
> >>this same clause be appended to the end of the DESCRIPTION for the
> >>aal5VccEntry.
> >
> >works for me. any objections out there?
> >
> >>
> >>This would render the indexing unambiguous, and would satisfy those
> >>who would expect to find the information indexed by ATM interface,
> >>VPI, and VCI, which I believe is the more commonly held indexing
> >>paradigm for this table. It would also logically extend (like the
> >>atmInterfaceConfEntry does) to indexing by an ATM Logical Port
> >>(ifType=80) interface.
> >>
> >>A couple of minor nits on the atm1ng-04 draft:
> >>- The new MIB boilerplate (when it stabilizes within the snmpv3 WG)
> >>  should be used.
> >
> >yep; learned about that recently
> >
> >>- Table 1 is split across pages 23..25, with page 24 almost empty.
> >>- The last sentence in the first paragraph of section 10 has several
> >>  spelling/numbering errors:
> >>  - parenticed instead of parenthesized
> >>  - numberss instead of numbers
> >>  - enumeratedg instead of enumerated
> >>  - Section 7.2 instead of Section 6.2
> >
> >thanks
> >
> >>
> >>I'll be out of e-shot for the next few weeks starting tomorrow, so
> >>I won't be able to reply to any more discussion on this draft for a
> >>while.
> >>
> >>Regards,
> >>Gary
> >>
> >> ______
> >>| ///  |       TM   Gary Hanson                [email-masked]
> >>|   ADC|Kentrox     14375 NW Science Park Dr.  503-641-3321 (FAX)
> >>|______|            Portland, Oregon  97229    800-733-5511 x6333
> >>
> >>
> >>On Mon, 18 May 1998, Kaj Tesink wrote:
> >>

> >>> Hi Jason,
> >>> 
> >>> You're right and I should have pressed the matter.
> >>> It simply appeared to me that there was no
> >>> complete consensus on what to put in.
> >>> If you think there was enough consensus would
> >>> you or someone else mind to formulate a precise 
> >>> text for inclusion? I copy this to the list.
> >>> I agree with you that it would be worthwhile.
> >>> 
> >>> Kaj
> >>> 
> >>> At 10:15 AM 5/18/98 -0400, you wrote:
> >>> >Kaj,
> >>> >
> >>> >A short time ago there was some discussion on the atommib
> >>> >list concerning which interface, ATM or AAL5, is used as the 
> >>> >index for the aal5VccTable. 
> >>> >
> >>> >I don't know what the resolution was, and I don't see, in the
> >>> >latest draft, any additional language to clarify which interface
> >>> >should be used. Is it the ATM interface?
> >>> >
> >>> >Thanks,
> >>> >
> >>> >Jason
> >>> >
> >>> >---- begin excerpt ----
> >>> >
> >>> >             -- AAL5 Virtual Channel Connection Performance Statistics
> >>> >               -- Table
> >>> >
> >>> >               -- This table contains the AAL5
> >>> >               -- performance statistics of a VCC at the
> >>> >               -- interface associated with an AAL5 entity in an ATM
> >>> >               -- host or ATM switch.
> >>> >
> >>> >
> >>> >               aal5VccTable        OBJECT-TYPE
> >>> >                    SYNTAX         SEQUENCE OF Aal5VccEntry
> >>> >                    MAX-ACCESS     not-accessible
> >
> >>> >                    STATUS         current
> >>> >                    DESCRIPTION
> >>> >                     "This table contains AAL5 VCC performance
> >>> >                      parameters."
> >>> >                    ::= { atmMIBObjects 12 }
> >>> >
> >>> >               aal5VccEntry        OBJECT-TYPE
> >>> >                    SYNTAX         Aal5VccEntry
> >>> >                    MAX-ACCESS     not-accessible
> >>> >                    STATUS         current
> >>> >                    DESCRIPTION
> >>> >                     "This list contains the AAL5 VCC
> >>> >                      performance parameters."
> >>> >                    INDEX { ifIndex, aal5VccVpi, aal5VccVci }
> >>> >                    ::= { aal5VccTable 1 }
> >>> >
> >>> >---- end excerpt ----

---

From: Keith McCloghrie <[email-masked]>
Date: Fri, 22 May 1998 11:38:07 -0700 (PDT)

Kaj/Gary,

>>atmInterfaceConfEntry does) to indexing by an ATM Logical Port

I agree it needs to be unambiguous.  However, I think there's a
downside to this proposal: some will find it counter-intuitive to
associate AAL5 information with the ifIndex having ifType=atm, when
there's an associated ifIndex which has ifType=aal5.

However, if the proposal goes ahead anyway, then I'd suggest a
modification to Mike's modification:

  "This list contains the AAL5 VCC performance
   parameters. It is indexed by the ifIndex of
   the ATM interface; specifically, by the ifIndex value
   identifying the interface which appears in the ifStackTable
   immediately below the associated ifType=aal5 interface."

Keith.

---

From: "Michael H. Grobelch" <[email-masked]>
Date: Fri, 22 May 1998 12:58:28 -0700

Folks,

 >From: Keith McCloghrie <[email-masked]>
 >Subject: Re: <draft-ietf-atommib-atm1ng-04.txt> posting
 >To: [email-masked] (Michael H. Grobelch)
 >Date: Fri, 22 May 1998 11:38:07 -0700 (PDT)
 >Cc: [email-masked], [email-masked], [email-masked]
 >
 >Kaj/Gary,
 >

I agree that using the aal5 ifIndex would be preferable.

But given that aal5 is not chosen, I think Keith's suggestion
of using ifStackTable is better, as it  allows for ATM,
proprietary virtual, or logical port interfaces.
And in the spirit of removing  ambiguity from the
text, I would say:

   "This list contains the AAL5 VCC performance
    parameters. It is indexed by the ifIndex of
    the ATM interface; specifically, by the ifIndex value
    identifying the interface which appears in the ifStackTable
    immediately below the associated ifType=aal5 interface.
    Note that the aal5 interface should be modelled as being
    on the interface at which the AAL5 Segmentation And 
    Reassembly (SAR) function takes place."

Mike

---

From: Keith McCloghrie <[email-masked]>
Date: Fri, 22 May 1998 14:25:05 -0700 (PDT)

I agree:

prefered solution: use the aal5 ifIndex
2nd best solution: use Mike's amended text.

Keith.

---

From: Juha Heinanen <[email-masked]>
Date: Sat, 23 May 1998 08:55:50 +0300 (EEST)

> there's an associated ifIndex which has ifType=aal5.

i fully agree with keith here.  in the network management system i
worked with, we expected the iftype of the ifindex to match the counter
values.

-- juha