Subject: RFC 1595: Counting of Far End parameters

From: Rajul Shah <[email-masked]>
Date: Fri, 05 Jun 1998 11:40:53 -0400

ANSI T1.231 says that counting of certain far-end performance monitoring
parameters is inhibited in the presence of near-end defects. Specifically,

	When Line AIS defect is present, the following far-end line
	parameters are NOT counted: CV, ES, and SES.

	When Path AIS or LOP is present, the following far-end path
	parameters are NOT counted: CV, ES, and SES.

Since RFC 1595 makes no mention of this (inhibition), I presume that an
implementation that wants to conform to (1595) must not go by the above
rules. True?

Rajul

Rajul Shah
[email-masked]
Tel: (978)250-3344 x285
http://www.avici.com

---

From: "C. M. Heard/VVNET, Inc." <[email-masked]>
Date: Fri, 5 Jun 1998 13:09:17 -0700 (PDT)

> implementation that wants to conform to (1595) must not go by the above

While RFC 1595 is indeed silent on these matters, I do not think that
the intent is to prohibit an implementation from inhibiting the far
end counts, as common sense requires.  Far end data is based on what
the remote NE reports to you.  In the presence of the above defects
you are not receiving a valid signal from the remote NE,
so there simply aren't any far end data to count.

Note that <draft-ietf-atommib-sonetng-02.txt> added a bunch of
xyzIntervalValidData objects.  If, for example,  a Line AIS
defect were present during a particular 15-minute interval, an
implementation that keeps track of such information would
presumably set the instance of sonetFarEndLineIntervalValidData
for that interval to false(2).

> Rajul

Mike
--
C. M. Heard/VVNET, Inc.
[email-masked]