Subject: Re: atm1ng mib

From: Ken Chapman <[email-masked]>
Date: Mon, 08 Jun 1998 16:44:49 -0400

I don't know if this has been rasied before, but...
I find the wording of the DESCRIPTION clauses for all of the
xyzIntervalValidData variable to be missleading:
"This variable indicates if there is valid data for this interval."
I think they should read:
"This variable indicates if the data for this interval is valid."

The way it is now, it sounds like it indicates if the data is 
*available* or not, rather than if the valid flag is set per 
ANSI T1.231 clause 9.1.2.2.
Am I the only one that is confused?
	Ken

At 01:49 PM 6/5/98 -0400, Kaj Tesink wrote:
>since i'll be 4 weeks off-line i wanna ask the wg
>whether there are any bugs in the atm1ng mib other than
>- the ones flagged by gary
>- the aal5 ifIndex issue
>so that we can wrapup after i return.
>
>kaj
>
>
>_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/
>_/                                                                      _/
>_/  Kaj Tesink                                                          _/
>_/  Bellcore                                                            _/
>_/  Business Internet Professional Services  vmail (732) 758-5254       _/
>_/  331 Newman Springs Rd.                   email [email-masked]  _/
>_/  Red Bank, NJ 07701                     faxmail (732) 758-2269       _/
>_/                                                                      _/
>_/  * NOTE AREA CODE CHANGE (908) --> (732) EFFECTIVE JUNE 1, 1997 *    _/
>_/                                                                      _/
>_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/
>
>
>

---

From: Gary Hanson <[email-masked]>
Date: Mon, 8 Jun 1998 15:06:24 -0700 (PDT)

Ken,
 
I'm not sure what you are referring to here.  I don't see any 
xyzIntervalValidData variables in the atm1ng mib.
 
Regards,
Gary

---

From: "C. M. Heard/VVNET, Inc." <[email-masked]>
Date: Mon, 8 Jun 1998 16:17:23 -0700 (PDT)

> ANSI T1.231 clause 9.1.2.2.

I fully agree, not least because the description clause for
sonetMediumValidIntervals seems to use the words "valid data
to mean "some valid data".

Perhaps we could make this even clearer by adapting the text of T1.231:

      "This variable assumes the value true(1) if the data stored
      for this interval is both valid and complete.  It is set to
      false(2) if the data stored for this interval is incomplete
      or otherwise invalid because:

      - the data stored for this interval is for a period greater
      or less than 15 minutes;  or

      - some data is missing (e.g., when a near-end defect prevents
      some far-end data from being collected)."

> Am I the only one that is confused?

No, I think that the description clauses should be fixed to eliminate
the ambiguity.

> 	Ken

Mike
--
C. M. Heard/VVNET, Inc.
[email-masked]