Subject: RFC 2495 Circuit Identifier used for what?

From: "Ediger, John" <[email-masked]>
Date: Mon, 5 Nov 2001 15:39:25 -0800

The MIB from RFC 2495 defined dsx1CircuitIdentifier as follows:

dsx1CircuitIdentifier OBJECT-TYPE
  SYNTAX  DisplayString (SIZE (0..255))
  MAX-ACCESS  read-write
  STATUS  current
  DESCRIPTION
         "This variable contains the transmission vendor's
         circuit identifier, for the purpose of
         facilitating troubleshooting."
  ::= { dsx1ConfigEntry 8 }

What does the MIB mean by "transmission vendor" and based on who the
"transmission vendor" is, what is meant by "circuit identifier"?

Thanks,
Jon Ediger

---

From: "Cecich, Vanessa" <[email-masked]>
Date: Tue, 6 Nov 2001 12:30:55 -0600

Jon;

In this instance, the circuit identifier would identify the location of the
circuit in relation to its DS1/E1/DS2/E2, on that specific piece of
equipment (Router, CSU/DSU, etc.).  Within the interface table, the
ifPhysAddress is equal to the value of the Circuit Identifier, which is the
physical address of the DS1/E1/DS2/E2 interface.  As stated below, it is
denoted as a string.  There are rules, within the RFC, on what to do if no
value has been assigned to the circuit identifier.   

Regarding the term 'transmission vendor', I am under the assumption, by
reading the RFC context, that the transmission vendor is associated with the
owner of the equipment (e.g., Carrier?), where the DS1/E1/DS2/E2 is
connected to.  The circuit identifier is the identifier the owner has
configured to represent the relevant information as described above.
Therefore for trouble shooting, the information identifying the circuit is
known, which identifies the facility that is being tested, on that owner's
equipment.  The reasoning behind my assumption, is that there are other
tables within the interface group to identify specific information
describing the interface (ifDescr and ifName), for example:  the
manufacturer, product name, etc. and the name of the interface name (e.g.,
port name, etc.) and therefore the term 'vendor' here does not represent the
'manufacturer or vendor' of this interface, but rather the 'owner'.

This is what I believe to be the interpretation of what these variables
mean.  Perhaps the team can give you more insight, based on their own
knowledge of usage of this OBJECT-TYPE.

Regards,
Vanessa F. Cecich

Vanessa F. Cecich
Product Engineering
Clear Communications
200 Tri-State International
Lincolnshire, IL 60069
[email-masked]
(847) 236-5378
 
www.clear.com

-----Original Message-----
From: Ediger, John [mailto:[email-masked]]
Sent: Monday, November 05, 2001 5:39 PM
To: [email-masked]'
Subject: RFC 2495 Circuit Identifier used for what?

Thanks,
Jon Ediger

---

From: Orly Nicklass <[email-masked]>
Date: Wed, 7 Nov 2001 07:54:41 +0200

Hi,

I kind of agree with the explanation regarding the owner.  
The interpretation that make sense to me as well as to Dave who edit the
RFC, although the wording could have been there before,
is that Transmission Vendor is the service provider who owns the box being
managed by the MIB.
Most Service Providers use an identifier called Circuit ID for each TDM
end-to-end Circuit in their network.  Each Service Provider will have their
own scheme for allocating this value.  Service Providers would like to be
able to look on the boxes and see which items have been provisioned for a
particular circuit by tagging each item with the Circuit ID. 
It seems like this could have been more useful for Cross-Connect than it
does for interfaces, but an
entire interface can be allocated to a single circuit.

Orly
-----------------------
Orly Nicklass, Ph.D
Associate VP, R&D
RAD Data Communications, Ltd.

[email-masked]

-----Original Message-----
From: Cecich, Vanessa [mailto:[email-masked]]
Sent: Tuesday, November 06, 2001 8:31 PM
To: 'mailto:[email-masked]'
Cc: [email-masked]'
Subject: RE: RFC 2495 Circuit Identifier used for what?

Jon;

Regards,
Vanessa F. Cecich

Vanessa F. Cecich
Product Engineering
Clear Communications
 
www.clear.com

-----Original Message-----
From: Ediger, John [mailto:[email-masked]]
Sent: Monday, November 05, 2001 5:39 PM
To: [email-masked]'
Subject: RFC 2495 Circuit Identifier used for what?

Thanks,
Jon Ediger

---

From: "Mak, L (Leen)" <[email-masked]>
Date: Wed, 7 Nov 2001 11:07:58 +0100

Hi,

FYI: the subject of circuit identifiers in a multioperator
environment is being considered in detail in ITU-T SG4.
There result of that work is available in Rec M.1400 
"DESIGNATIONS FOR INTER-OPERATOR NETWORKS".
This doc provides a wealth of details on circuit identifiers
and additional information, required for maintenace and
operation.

Regards.

Leen Mak.

> From: Orly Nicklass [mailto:[email-masked]]
> Sent: woensdag 7 november 2001 6:55
> To: 'Cecich, Vanessa'; 'mailto:[email-masked]'