Subject: Proposal for updaing the Optical Interface MIB

From: "Lam, Hing-Kam (Kam)" <[email-masked]>
Date: Thu, 8 Nov 2001 23:22:44 -0500

Hi,

In the last ITU-T SG15 meeting (October 2001), several draft ITU-T
recommendations have been consented, including G.874.1 (OTN NE
protocol-neutral management information model), G.874 (OTN NE Management
Requirements), G.798 (Characteristics of OTN Hierarchy Equipment Functional
Blocks), and G.7710 (ex. G.cemr - Common Equipment Management Function
Requirements).  The consented text of these documents are now available in
the ITU-T public directory
ftp://sg15opticalt:[email-masked]/tsg15opticaltransport/wp3/q14/.

These recommendations are referenced by the Optical Interface MIB. In
particular, the 01 (London) version
(http://www.ietf.org/internet-drafts/draft-ietf-atommib-opticalmib-01.txt)
of the optical interface mib is based on the 3/2001 version of G.874.1. The
consented version of G.874.1 has many updates since 3/2001. Therefore, the
optical interface mib should be updated too in order to align with G.874.1.

I would like to propose the following updates. The first set is editorial
updates. The second set is updates to the existing configuration tables to
align with G.874.1. The third set is possible additional configuration
tables to model functions that have not been covered by the current mib.

Editorial updates: 
a. Creating textual conventions for 
     TraceIdentifierTransmitted (TxTI), DAPIExpected (ExDAPI),
     SAPIExpected (ExSAPI), TraceIdentifierAccepted (AcTI),
     TIMDetMode, TIMActEnabled, DEGThr, DEGM, Directionality, BitRateK
b. Rename ODUkP to ODUk for better alignment with G.874.1 terminology 
c. Rearrange the order of ODUk and ODUkT for readability
d. Update the dates of the ITU-T references 
e. Update the terminology section 

Alignment with G.874.1 for the existing configuration tables:
f. Add the optIfOTMnTable for defining the OTMn structure 
   information (order, bit rates, reduced, interface type, 
   maximum TCM levels supported, and optical reach) 
g. Remove the AcTIStatus object from the OTSn, OTUk, ODUkP, 
   and ODUkT config tables
h. In optIfOTSnConfigTable: 
   add objects Directionality, AprStatus, AprControl
i. In the optIdOMSnConfigTable: 
   add object Directionality;
   remove object Order
j. In the optIfOChConfigTable: 
   add object Directionality; 
   remove the objects SinkAdaptActive, SourceAdaptActive, and 
   SinkFECEnabled (move to optIdOTUkConfigTable); 
   remove ais, lof, lom, and los from Current Status
k. In the optIfOTUkConfigTable: 
   add objects Directionality, BitRateK, SinkAdaptActive,
   SourceAdaptActive, and SinkFECEnabled (move from optIfOChConfigTable);
   add lof, ais, and lom to Current Status
l. In the optIfODUkConfigTable: 
   add objects Directionality, BitRateK, TcmFieldInUse, and PositionSeq;
   remove objects PayloadTypeTransmitted, PayloadTypeExpected,    
   PayloadTypeAccepted, ActiveAdaptFuncSource, ActiveAdaptFuncSink 
   (these should belong to the ODUk Client layer, which is not modeled 
   in the current MIB yet); 
   remove plm from Current Status
m. Combine the ODUkT Sink and Source ConfigTable; 
   add objects Directionality and Codirectional; 
   rename TcmId to TcmField; 
   add the value monitor to the SinkMode object.

Possible addition to model the G.874.1 non-intrusive monitoring (Nim) 
functions and GCC (General Control Channel) access:
n. Define configuration tables: 
   ODUk Nim config table, ODUkT Nim config table, 
   GCC0 config table, and GCC12 config table
o. In the optIfODUkConfigTable: 
   define object for activate/deactive ODUk Nim; 
   define object for add/remove TCM; 
   define object for add/remove GCC12 access
p. In the optIfOTUkConfigTable: 
   define object for add/remove GCC0 access

Comments will be appreciated.
A draft version of the mib will be provided soon.

Regards,
Kam

---

From: "Lam, Hing-Kam (Kam)" <[email-masked]>
Date: Sat, 10 Nov 2001 10:50:48 -0500

Hi,

I have updated the optical interface MIB with the proposed items (a) through
(m) as listed in the previous email (attached). Items (n) through (p) have
not be incorporated yet.
The draft is available at
ftp://sg15opticalt:[email-masked]/tsg15opticaltransport/wp3/q14/.
Let me know for any comments.
I plan to submit the mib soon for the Salt Lake City meeting.

Regards,
Kam

> -----Original Message-----
> From: Lam, Hing-Kam (Kam) [mailto:[email-masked]]
> Sent: Thursday, November 08, 2001 11:23 PM
> To: 'AToM Working Group'
> Subject: Proposal for updaing the Optical Interface MIB
> 
> 
> Hi,
>