Subject: RE: [Hubmib] RE: WIS ifStack issue

From: "Ayers, Mike" <[email-masked]>
Date: Thu, 6 Dec 2001 11:34:45 -0600

> From: C. M. Heard [mailto:[email-masked]] 
> Sent: Wednesday, December 05, 2001 09:15 PM

> On Wed, 5 Dec 2001, Ayers, Mike wrote:
> > 	Quickly, the problem I see with all this is that using 
> MAU MIB to
> > determine the payload assumes that a management system will 
> have access
> > to the original WIS MAU interface.
> 
> But how does having an extra layer between the sonetPath(50) and
> ethernetCsmacd(6) ifStack layers help this?  If a provider's 
> management
> system does not have access to the end system's ifMauTable entry, it
> will not have access to the end system's ifTable and ifStackTable
> entries, either.

	I would expect:

	+----------------+
	| BobCo          |
	| Bear Falls, ID |
	| Office         |
	+----------------+
	    ^
	    |<------ifStack: ethernetCsmacd/WIS/sonetPath/sonet
 	    |
          |<---10GBASE-R
	    |
 	    |<------ifStack: ethernetCsmacd/WIS/sonetPath/sonet
 	    V
	+-----------+
	|           |
	| SpiffyNet |
	|           |
	+-----------+
	    ^
 	    |<------ifStack: WIS/sonetPath/sonet
 	    |
          |<---OC-384 SONET
	    |
	    |<------ifStack: WIS/sonetPath/sonet
 	    V
	+------------------+
	| BigFatMegaTelco, |
	| International,   |
	| Incorporated     |
	+------------------+
	    ^
	    |<------ifStack: WIS/sonetPath/sonet
 	    |
          |<---OC-384 SONET
	    |
	    |<------ifStack: WIS/sonetPath/sonet
 	    V
	+-------------+
	|             |
	| DotComm.com |
	|             |
	+-------------+
	    ^
 	    |<------ifStack: ethernetCsmacd/WIS/sonetPath/sonet
	    |
          |<---10GBASE-R
	    |
	    |<------ifStack: ethernetCsmacd/WIS/sonetPath/sonet
 	    V
	+-----------------+
	| BobCo           |
	| Black Creek, PA |
	| Office          |
	+-----------------+

	So that what goes end to end is not just a SONET path, but a SONET
path carrying WIS encoded data.

/|/|ike

---

From: "C. M. Heard" <[email-masked]>
Date: Thu, 6 Dec 2001 10:46:41 -0800 (PST)

> 	I would expect:
         [ ... ]
>           |<------ifStack: WIS/sonetPath/sonet
         [ ... ]
> path carrying WIS encoded data.

But the intermediate SONET systems don't care what's in the SONET path
payload capacity.  They usually contain LTE, which transports the path
layer overhead and payload capacity completely transparently.  Indeed,
the whole point of having the WIS use the SONET frame structure is to
make it possible for SONET networks to transport Ethernet data without
having to know anything except that they are carrying an STS-192c path.

Mike