Subject: rfc-editor note for draft-ietf-atommib-atm2 (Fwd)

From: Erik Nordmark <[email-masked]>
Date: Thu, 10 Jul 2003 20:01:57 +0200 (CEST)

The document was approved by the IESG today with these tweaks (which
I'm pretty sure Bert has sent to the list in the past).

  Erik

----

RFC-editor notes:

- Page 73/74, pls change
  OLD:
   atmIlmiSrvcRegEntry OBJECT-TYPE
       SYNTAX       AtmIlmiSrvcRegEntry
       MAX-ACCESS   not-accessible
       STATUS       current
       DESCRIPTION
          "Information about a single service provider that is available to
          the user-side of an adjacent device through the ILMI."
       INDEX { atmIlmiSrvcRegIndex,
               atmIlmiSrvcRegServiceID,
               atmIlmiSrvcRegAddressIndex }
  NEW:
   atmIlmiSrvcRegEntry OBJECT-TYPE
       SYNTAX       AtmIlmiSrvcRegEntry
       MAX-ACCESS   not-accessible
       STATUS       current
       DESCRIPTION
          "Information about a single service provider that is available
          to the user-side of an adjacent device through the ILMI.

          Implementors need to be aware that if the size of
          atmIlmiSrvcRegServiceID exceeds 113 sub-identifiers then OIDs
          of column instances in this table will have more than 128 sub-
          identifiers and cannot be accessed using SNMPv1, SNMPv2c, or
          SNMPv3."
       INDEX { atmIlmiSrvcRegIndex,
               atmIlmiSrvcRegServiceID,
               atmIlmiSrvcRegAddressIndex }

-Pls remove obsolete and non-needed (there are no citations) references:
 Remove from the Normative References:
 [RFC1905], [RFC1906], [RFC2571], [RFC2572], [RFC2573], [RFC2574],
 [RFC2575]
 Remove from the Informative References:
 [RFC1157], [RFC2570], [RFC1155], RFC1212], [RFC1215], [RFC1901]

>----------------End Forwarded Message----------------<

---

From: "C. M. Heard" <[email-masked]>
Date: Fri, 11 Jul 2003 01:03:17 -0700 (PDT)

> I'm pretty sure Bert has sent to the list in the past).

I think that the note below needs a small correction.  The message from
smilint says:

mailbody:2542: [5] {index-exceeds-too-large} warning: index of row
`atmIlmiSrvcRegEntry' can exceed OID size limit by 16 subidentifier(s)

so the size limit on `atmIlmiSrvcRegEntry' is 128-16 = 112 sub-ids
(not 113).

>           atmIlmiSrvcRegServiceID exceeds 113 sub-identifiers then OIDs
                                            ^^^
                                            112
> >----------------End Forwarded Message----------------<

Thanks,

Mike Heard