Subject: RE: PaceBasicAtomID - maybe we're done

From: "David Orchard" <[email-masked]>
Date: Fri, 30 Jul 2004 16:39:30 -0700

I don't understand this argument.  An HTTP URI is owned by the domain authority.  It's as persistent as that authority decides.  It is not "by default transient".  If an authority wants persistent HTTP URIs, then it should follow some URI space scheme that does so, ie http://foo.com/uuid.  That's one of the great things about HTTP URIs.  The domain authority can choose which features it wants or doesn't want.  

Dave

> -----Original Message-----
> From: [email-masked] [mailto:owner-atom-
> [email-masked]] On Behalf Of Asbjørn Ulsberg
> Sent: Friday, July 30, 2004 4:05 PM
> To: Martin Duerst
> Cc: Atom-Syntax
> Subject: Re: PaceBasicAtomID - maybe we're done
> 
> 
> On Fri, 30 Jul 2004 14:45:24 +0900, Martin Duerst <[email-masked]> wrote:
> 
> > If I think that on the system I'm setting up, I can guarantee
> > persistence of http: as well or better than persistence of some
> > other scheme, why do you think you can tell me that it will
> > not be consistent?
> 
> HTTP URI's are by default transient in that they aren't owned by an
> entity, but just rented. HTTP URI's would only be stable identifiers if
> they could just be bought once by one entity, and if the exipry of that
> entity also expired the URI.
> 
> That doesn't mean that an HTTP URI can be sufficiently stable and unique,
> though. An HTTP URI containing the date a given resource was issued would
> most certainly be glboally unique at the time of creation, and almost
> certainly be universally unique for the future, even if the domain would
> be taken over by another entity.
> 
> The problem with HTTP URI's in this respect is not what they're not
> capable of providing, but what they're capable of not providing. A NewsML
> URI is actually invalid if it doesn't contain a date for when a resource
> was issued at a given internet domain.
> 
> This is not the case for HTTP URI's. Both
> 'http://example.com/2004/07/31/23212.html' and
> 'http://example.com/23212.html' are perfectly valid HTTP URI's. The former
> is very likely to be universally unique, the latter is very unlikely to
> be. The latter URI would be impossible to express in a NewsML URN.
> 
> --
> Asbjørn Ulsberg         -=|=-        [email-masked]
> «He's a loathsome offensive brute, yet I can't look away»

---

From: Mark Pilgrim <[email-masked]>
Date: Fri, 30 Jul 2004 22:47:13 -0400

On Fri, 30 Jul 2004 16:39:30 -0700, David Orchard <[email-masked]> wrote:
> 
> I don't understand this argument.  An HTTP URI is owned by the domain authority.  It's as persistent as that authority decides.

You say that like it's a good thing.

http://textism.com/article/494

-- 
Cheers,
-Mark