Subject: Re: Propose partial consensus on dates

From: Dare Obasanjo <[email-masked]>
Date: Sat, 24 Jul 2004 15:56:53 -0700 (PDT)

--- Arve Bersvendsen <[email-masked]> wrote:
> 
> You're wrong. Atom is more than what you choose to
> expose to the user through
> RSSBandit.  Atom is a syndication format for
> reading, it is an
> editing/publishing protocol, and it is an archive
> format. Never forget that.

I haven't. Unfortunately all the people pushing pet
features that make no sense in the syndication or
editing/publishing scenario seem to have. 

=====
THINGS TO DO IF I BECOME AN EVIL OVERLORD #25
No matter how well it would perform, I will never construct any sort of machinery which is completely indestructible except for one small and virtually inaccessible vulnerable spot.

__________________________________
Do you Yahoo!?
Yahoo! Mail - 50x more storage than other providers!
http://promotions.yahoo.com/new_mail

---

From: Bill de hÓra <[email-masked]>
Date: Sun, 25 Jul 2004 13:23:26 +0100

> editing/publishing scenario seem to have. 

Have you a compiled a list of such features in your opinion? 
Seriously,  as a contributor to one of the better OS readers, that 
would be good to know.

cheers
Bill

---

From: Dare Obasanjo <[email-masked]>
Date: Sun, 25 Jul 2004 09:39:41 -0700 (PDT)

> Seriously,  as a contributor to one of the better OS

It isn't that there are too many features but more
that people aren't acknowledging that the contents of
an entry when used for syndication are different from
when it is used as a payload of an API call or as an
archival format. 

For example, a created date is useful for an archival
format and probably should be required. It is
unncecessary in a syndication format and definitely
quite useless as data passed to the server as part of
an API call.  

I seriously think there should be profiles of Atom for
the 3 primary use cases and a glossary/inventory of
Atom elements that is the union of all the
elements/constructs in the 3 profiles. 

=====

__________________________________
Do you Yahoo!?
New and Improved Yahoo! Mail - Send 10MB messages!
http://promotions.yahoo.com/new_mail

---

From: "Bill Kearney" <[email-masked]>
Date: Sun, 25 Jul 2004 15:45:31 -0400

> when it is used as a payload of an API call or as an

+1.  The timestamps needed as a client pushes/pulls entries to/from whatever is
managing them are very likely to NEED to be different than those used in a thing
like a feed.  A feed, otoh, may well benefit from having it's own variations on
these.  Thus it becomes apparent that an archiving format would need to take
into account both and perhaps even add it's own.  Is this not clear to everyone
already?

> elements/constructs in the 3 profiles.

I can't see any reason not to support such a notion.  However, the profiles
necessary to support individual item management and syndication output are
probably a lot less complicated than what might be used for archiving.  If only
from the standpoint of dealing with versioning of entries.

-Bill Kearney
Syndic8.com