Subject: Re: PacePutDelete Withdrawn

From: [email-masked]
Date: 16 Jul 2004 15:09:20 -0000

Joe,

--- Joe Gregorio <[email-masked] wrote:

> Which is
fine since HTTP isn't defined to run over TCP/IP.
> > These networks
can still provide for
> > HTTP connectivity, by using the WSP (Wireless Session
Protocol) stack, provided
> > by the WAP browser. WSP provides a HTTP mapping
on top of most physical networks.
> > 
> > WSP has support for arbritrary
HTTP methods (OPTIONS, PUT, DELETE, ...).
> > But because the main user of
WSP stack is a WAP browser and this only ever
> > uses GET and POST, you
can only rely on these two methods two work reliably.
> > Support for other
methods on both phones and WAP gateways is very shaky.
> I was following
along up until here. I'm thinking of a wire trace 
> of an HTTP session and
I'm having trouble understanding
> how different methods could be problematic.
I am surely 
> missing something here.

Joe,

A WSP stack encodes
the HTTP request into a binary format and send that over WTP (Wireless Transport
Protocol) to a WAP gateway. The gateway decodes the request and send a normal
HTTP request to the designated web server. The gateway subsequently receives
the response, encodes it again and sends it enroute to the mobile phone.

The WSP stack is used by the WAP browser. It renders WML and allows the
user to interact with these pages. Similar to HTML it uses GET to follow links
and has functionality similar to HTML forms, which allow the user to POST
data to a web server.

So, even though the WSP specification allows for
arbitrary HTTP methods to be encoded, not all mobile phones and WAP gateways
support this and only support GET and POST.

In the early WAP days, even
POST support was not supported on some phones.

I guess this was the main
motivation for the MIDP JSR expert group to limit the number of required HTTP
methods. It ensures interoperability.

Net result: if your MIDlet opens
an HttpConnection on a Nokia3650 and call setRequestMethod("PUT") you get
an IOException.

If you are looking for someone, something to blaim, blaim
HTML.

Regards,

Peter

---

From: Joe Gregorio <[email-masked]>
Date: Fri, 16 Jul 2004 12:57:47 -0400

On 16 Jul 2004 15:09:20 -0000, [email-masked] 
> methods. It ensures interoperability.

Given the above explaination I would be concerned that
you could not POST arbitrary mime-types including
binary content without it being restricted to mulit-part mime.
Is this a concern?

    Thanks,
    -joe