Subject: Re: Created proposal: PaceProvideSchema

From: Randy Charles Morin <[email-masked]>
Date: Sun, 11 Jul 2004 08:24:26 -0700 (PDT)

Randy Charles Morin <[email-masked]> wrote:
>Writing a validator that accounts for cardinality of ordered 
>elements is substantially more difficult.
 
That should have been "cardinality of unordered elements".
Thanks,
 
Randy
http://www.kbcafe.com

---------------------------------
Do you Yahoo!?
Yahoo! Mail Address AutoComplete - You start. We finish.

---

From: Martin Duerst <[email-masked]>
Date: Mon, 12 Jul 2004 07:10:33 +0900

>That should have been "cardinality of unordered elements".

It is maybe slightly more difficult. It of course depends
on the internal structures of your validator that you already
have. When this was discussed in the XML Schema WG and with
others who commented on it, it even turned out that one
of the prototype implementations allowed it because that
seemed easier to implement than not allowing it.

But for us, of course, that's all rather irrelevant.
We have to take XSD the way it is.

Regards,    Martin.