Subject: Resource terminology

From: Danny Ayers <[email-masked]>
Date: Fri, 09 Jul 2004 22:09:44 +0200

Can someone please tell me if this was intentional (and if so, why?!) -

The charter, early on says:

Atom consists of:
    * A conceptual model of a resource

Is this a resource in the URI sense, or a new term for an Atom thing?

Either way, this seems very confusing.
Come back "Well-Formed Log Entry", all is forgiven...

Cheers,
Danny.

-- 

Raw
http://dannyayers.com

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 9 Jul 2004 22:38:12 -0700

> Is this a resource in the URI sense, or a new term for an Atom thing?

In the Web sense, yes.

> Come back "Well-Formed Log Entry", all is forgiven...

What exactly does that mean?

--
Mark Nottingham     http://www.mnot.net/

---

From: Danny Ayers <[email-masked]>
Date: Sat, 10 Jul 2004 17:42:59 +0200

>> Is this a resource in the URI sense, or a new term for an Atom thing?

Then why should a conceptual model of one appear in Atom - isn't that 
way too wide a scope? Shouldn't we just refer to the description in RFC 
2396bis, with description focussing solely on Atom-specific constructs?

> What exactly does that mean?

Sam's original aim [1] of modelling entries got shunted to one side 
early on with the mad dash for syntax, but it remains considerably 
easier than figuring out the semiotics/semantics of a resource in general.

Cheers,
Danny.

[1] 
http://www.intertwingly.net/blog/2003/06/16/Anatomy-of-a-Well-Formed-Log-Entry

-- 

Raw
http://dannyayers.com

---

From: Bill de hÓra <[email-masked]>
Date: Mon, 12 Jul 2004 15:45:12 +0100

>>> Is this a resource in the URI sense, or a new term for an Atom thing?

I think you can strike the statement in question without any loss of 
meaning to the spec.

cheers
Bill