Subject: RE: Referencing entry URI from content

From: "David Orchard" <[email-masked]>
Date: Fri, 22 Oct 2004 11:09:36 -0700

This seems vaguely like XInclude for attributes.

Dave
> -----Original Message-----
> From: [email-masked] [mailto:owner-atom-
> [email-masked]] On Behalf Of Danny Ayers
> Sent: Friday, October 22, 2004 4:27 AM
> To: [email-masked]
> Subject: Referencing entry URI from content
> 
> 
> Just a thought -
> 
> If "It's the Entries, Stupid!", then it doesn't seem unreasonable for
> the content to be able to carry a reference back to the entry. Is
> there any way this could work?
> 
> Just to clarify what I mean, here's a strawman with the kindling
> pre-lit - the entry has a URI, so presumably that would be an
> appropriate hook:
> 
> <entry>
>    <id>http://example.org</id>
>    <content type="application/xml">
>         <foo source="$id" />
>    </content>
> </entry>
> 
> When passed to subsequent processing, the content would appear as:
> 
> <foo source="http://example.org" />
> 
> The templating kind of approach here suggests one kind of situation in
> which it might be useful, another would be in a possible approach to
> extensibility, in which characteristics of the entry could be
> described within the content, by reference back to the entry id.
> 
> Relative XPaths may be a possible approach, only that seems even more
> fragile than the technique above.
> 
> I'm not really suggesting this is a requirement, just that if it were
> possible to achieve painlessly, it could well be useful.
> 
> Cheers,
> Danny.
> 
> --
> 
> http://dannyayers.com

---

From: Danny Ayers <[email-masked]>
Date: Mon, 25 Oct 2004 14:13:26 +0200

Thanks Dave, I didn't realise how far the spec had progressed (Proposed Rec.). 

Forgetting the subject line of this post, inclusion could be more
generally useful in Atom (the full content/summary kind of split
springs to mind).

http://www.w3.org/TR/xinclude/

-- 

http://dannyayers.com