Subject: RE: Default atom:content item

From: Dare Obasanjo <[email-masked]>
Date: Fri, 1 Oct 2004 21:00:08 -0700 (PDT)

--- Jon Davis <[email-masked]> wrote:

> If
> the draft spec has since
> been modified, I would greatly appreciate the
> education of the proper
> mechanism.

The most recent Atom draft is at
http://www.ietf.org/internet-drafts/draft-ietf-atompub-format-02.txt
 
> Until then, implementors are free to extend specs,
> as there is nothing in
> the atom:content specification that indicates that
> there must be no other
> attributes in this element. 

Interesting, I didn't realize the default rule for
dealing with specs was embrace and extend if they were
ambiguous. 

> This is a good thing,
> too; in XML
> implementations it is generally a bad idea to
> disallow custom attributes to
> XML nodes unless there is a very good reason, simply
> because of the
> extensibility, or the 'X', of XML.

This is news to me. Where is this rule of dealing with
Internet specifications written? 

> I shared about my implementation because the spec
> proved insufficient in
> this area. I posted to this group to allow
> discussion of this mechanism; if
> anyone knows of a better idea for this mechanism,
> please share.
>
> Discussing the adaptation of the draft Atom
> specification, including the 0.3
> draft, is the purpose of this list, is it not?

Indeed. 

=====
THINGS TO DO IF I BECOME AN EVIL OVERLORD #23
I will keep a special cache of low-tech weapons and train my troops in their use. That way -- even if the heroes manage to neutralize my power generator and/or render the standard-issue energy weapons useless -- my troops will not be overrun by a handful of savages armed with spears and rocks.

		
__________________________________
Do you Yahoo!?
New and Improved Yahoo! Mail - 100MB free storage!
http://promotions.yahoo.com/new_mail

---

From: "Jon Davis" <[email-masked]>
Date: Fri, 1 Oct 2004 21:08:24 -0700

> http://www.ietf.org/internet-drafts/draft-ietf-atompub-format-02.txt

Thank you. This answers my other thread.

Would whoever is in charge of atomenabled.org please make the above URL
clearly labeled as such? Or is that not the official information site for
the Atom objective?

Jon

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
On Behalf Of Dare Obasanjo
Sent: Friday, October 01, 2004 9:00 PM
To: Jon Davis; [email-masked]
Subject: RE: Default atom:content item

--- Jon Davis <[email-masked]> wrote:

> If
> the draft spec has since
> been modified, I would greatly appreciate the education of the proper 
> mechanism.

> Until then, implementors are free to extend specs, as there is nothing 
> in the atom:content specification that indicates that there must be no 
> other attributes in this element.

Interesting, I didn't realize the default rule for dealing with specs was
embrace and extend if they were ambiguous. 

> This is a good thing,
> too; in XML
> implementations it is generally a bad idea to disallow custom 
> attributes to XML nodes unless there is a very good reason, simply 
> because of the extensibility, or the 'X', of XML.

This is news to me. Where is this rule of dealing with Internet
specifications written? 

> I shared about my implementation because the spec proved insufficient 
> in this area. I posted to this group to allow discussion of this 
> mechanism; if anyone knows of a better idea for this mechanism, please 
> share.
>
> Discussing the adaptation of the draft Atom specification, including 
> the 0.3 draft, is the purpose of this list, is it not?

Indeed. 

=====
THINGS TO DO IF I BECOME AN EVIL OVERLORD #23 I will keep a special cache of
low-tech weapons and train my troops in their use. That way -- even if the
heroes manage to neutralize my power generator and/or render the
standard-issue energy weapons useless -- my troops will not be overrun by a
handful of savages armed with spears and rocks.

---

From: "Jon Davis" <[email-masked]>
Date: Fri, 1 Oct 2004 21:16:42 -0700

> http://www.ietf.org/internet-drafts/draft-ietf-atompub-format-02.txt

The mechanism being discussed is not mentioned here.

I am implementing with the default attribute as described in the original
post of this thread until this group comes up with a better mechanism.

Jon

-----Original Message-----

 

Indeed. 

=====