Subject: Re: PaceReformedContent3

From: Asbjørn Ulsberg <[email-masked]>
Date: Sun, 03 Oct 2004 01:34:49 +0200

On Thu, 30 Sep 2004 08:39:29 +0900, Martin Duerst <[email-masked]> wrote:

> So you are saying that type='TEXT/plain' or type="IMAGE/SVG+XML' are
> legal, but type='html' or type='xhtml' aren't?

Blech!

> I have nothing against using different casing in the examples to make
> the distinction clear, but I think it is an extremely bad idea to
> have an attribute where some of the values are case-sensitive and
> others are not.

I agree entirely.

-- 
Asbjørn Ulsberg    -=|=-     http://virtuelvis.com/quark/
«He's a loathsome offensive brute, yet I can't look away»

---

From: Martin Duerst <[email-masked]>
Date: Sun, 03 Oct 2004 18:34:05 +0900

At 19:46 04/09/29 -0700, Tim Bray wrote:

>On Sep 29, 2004, at 4:39 PM, Martin Duerst wrote:
>
>Exactly.  You check for a literal match against "TEXT", "HTML", or "XHTML" 
>and if all three fail then you hand it to a media-type handler, which 
>presumably knows about the rules for media types.  Why is it better if I 
>have to do case-folding before checking?  -Tim

Given that I found the word 'case' exactly once in the Pace,
and not in the context of upper/lower case, I think it would
be extremely prudent to at least make these expectations
VERY explicit in the text.

But I still think they will be confusing to quite a few people.

Regards,    Martin.