Subject: Re: RSS 1.1

From: Henry Story <[email-masked]>
Date: Tue, 18 Jan 2005 17:25:43 +0100

Ah. It looks like the RSS1.0 people are moving along. Their new format 
even
has a small OWL file to go with it. I thought we could better them by 
having
one first!

Henry Story

On 18 Jan 2005, at 15:00, Sean B. Palmer wrote:
> I'm pleased to announce the release of RSS 1.1: a bugfix version of RSS
> 1.0, being one of the most popular RDF applications to date.
>
>    http://inamidst.com/rss1.1/
>    - RSS 1.1 Specification
>
> This specification has been developed by a group of RSS 1.0 users
> including myself who sought not just to resolve the various bugs 
> therein
> but also to incorporate the latest features of RDF and improve the
> integrity of the specification in general.
>
> To coincide with the release, we're also making available a number of
> tools, including an RSS 1.1 feed validator, a converter, a test suite,
> and various implementations for Movable Type, Wordpress, and others, 
> all
> of which are linked to from the following guide:
>
>    http://inamidst.com/rss1.1/guide
>    - A Rough Guide to RSS 1.1
>
> Discussion of the format may be had in any of the following fora,
> depending upon the particular nature of the feedback:
>
>    * www-rdf-interest - Reply to this thread if you have comments about
>      the applicability of RDF to RSS in general, or RSS 1.1's specific
>      use of RDF features.
>    * irc.freenode.net #rss1.1 - For real time communication with the
>      developers of the specification, and any general comments.
>    * rss-dev mailing list: http://groups.yahoo.com/group/rss-dev/
>      For feedback on how RSS 1.1 relates to 1.0 and other syndication
>      formats.
>
> Specific typographical corrections may be sent directly to the editors,
> the contact details for whom are in the specification.
>
> Thanks,
>
> -- 
> Sean B. Palmer, http://inamidst.com/sbp/
>
>

---

From: Danny Ayers <[email-masked]>
Date: Tue, 18 Jan 2005 18:29:41 +0100

---------- Forwarded message ----------
From: Sean B. Palmer <[email-masked]>
Date: Tue, 18 Jan 2005 14:00:09 +0000
Subject: RSS 1.1
To: [email-masked]

This specification has been developed by a group of RSS 1.0 users
including myself who sought not just to resolve the various bugs therein
but also to incorporate the latest features of RDF and improve the
integrity of the specification in general.

To coincide with the release, we're also making available a number of
tools, including an RSS 1.1 feed validator, a converter, a test suite,
and various implementations for Movable Type, Wordpress, and others, all
of which are linked to from the following guide:

Thanks,

-- 

http://dannyayers.com

---

From: Graham <[email-masked]>
Date: Tue, 18 Jan 2005 18:55:49 +0000

>>    - A Rough Guide to RSS 1.1

They've removed the required stable identifier (rdf:about) from the 
entries, which was the main thing RSS 1.0 had going for it. Atom is now 
the only vaguely sensible format going.

Graham

---

From: "Jeremy Gray" <[email-masked]>
Date: Tue, 18 Jan 2005 11:27:17 -0800

> -----Original Message-----
> From: [email-masked]
[mailto:[email-masked]] On Behalf Of Graham
> Sent: Tuesday, January 18, 2005 10:56 AM
> To: Henry Story
> Cc: Atom WG
> Subject: Re: RSS 1.1
> 
> entries, which was the main thing RSS 1.0 had going for it.

I have yet to take more than a quick scan through the proposed RSS 1.1
specification, but I too noticed that backwards step. As a proponent of RDF
and of RSS 1.0, I also noticed several other backwards steps* that I'll have
to dig into when I have a bit more time.

(* Even more constraints that make it even less useful to RDF-based systems,
which makes no sense given that non-RDF systems are obviously going to go
with Atom, leaving RSS 1.x in a position to become more RDF-focused, not
less.)
 
> Atom is now the only vaguely sensible format going.

Other than RSS 1.0, of course. :)

Jeremy Gray

---

From: Martin Duerst <[email-masked]>
Date: Wed, 19 Jan 2005 16:23:39 +0900

>    http://inamidst.com/rss1.1/

I note the progress from the RSS 1.0 Content Module (encoded) to
the RSS 1.1 Payload Module (not encoded). I haven't studied the rest.

Regards,    Martin.