Subject: PaceOrderSpecAlphabetically

From: Sam Ruby <[email-masked]>
Date: Sun, 30 Jan 2005 12:34:42 -0500

== Abstract ==
Order the Element Definitions in the specification alphabetically.

== Status ==
Open

== Rationale ==
The order of elements in section 4 of draft-ietf-atompub-format-05.txt 
is not obvious, making it more difficult to find information.  Failing 
to come up with a better order, I'd simply suggest alphabetical.

== Proposal ==
Sort sections 4.1 through 4.21 alphabetically based on the section 
header (effectively, the element name).

== Impacts ==
None.  This only affects the specification itself, not any documents.

== Notes ==
As this is purely editorial, it does not actually require a Pace.  I'm 
merely putting this out in case it spurs dicussion.

A case could be made to do partial ordering (for example, treat 
atom:feed and atom:entry special), but this seems to be a slippery 
slope, and I believe that sections 1.2 (Example) coupled with section 2 
(Atom documents) provide an adequate introduction to these concepts.

----

CategoryProposals

---

From: Tim Bray <[email-masked]>
Date: Sun, 30 Jan 2005 10:17:22 -0800

> Order the Element Definitions in the specification alphabetically.

+1  -Tim

---

From: Walter Underwood <[email-masked]>
Date: Sun, 30 Jan 2005 16:12:00 -0800

> Order the Element Definitions in the specification alphabetically.

+1. Yes, please. It works fine for the HTTP spec.

wunder
--
Walter Underwood
Principal Architect, Verity

---

From: Asbjørn Ulsberg <[email-masked]>
Date: Mon, 31 Jan 2005 02:06:18 +0100

> Order the Element Definitions in the specification alphabetically.

Sounds like a very good idea. +1.

-- 
Asbjørn Ulsberg     -=|=-    http://virtuelvis.com/quark/
«He's a loathsome offensive brute, yet I can't look away»