Subject: how to write spec language for language variants?

From: Eric Scheid <[email-masked]>
Date: Sat, 29 Jan 2005 17:09:44 +1100

nitpickers welcome.

I have this spec text in my draft Pace...

>   atom:head elements MAY contain one or more atom:foo elements, so
>   long no two atom:foo elements have the same combination of
>   atom:hreflang, xml:lang, or atom:type.

I also considered writing it like this...

>   atom:head elements MAY contain one or more atom:foo elements, so
>   long as they differ in the values they have for the attributes
>   atom:hreflang, xml:lang, or atom:type.

I'm not comfortable with either wording. Seems clumsy.

meta-question: should the spec even bother asserting this restriction?

e.

---

From: fantasai <[email-masked]>
Date: Sun, 30 Jan 2005 10:51:57 -0500

> meta-question: should the spec even bother asserting this restriction?

I don't think it's really necessary.

~fantasai

---

From: Paul Hoffman <[email-masked]>
Date: Sun, 30 Jan 2005 19:00:15 -0800

>I'm not comfortable with either wording. Seems clumsy.

The first seems quite clear to me, the second is clumsy and open to 
misinterpretation.

>meta-question: should the spec even bother asserting this restriction?

Probably not without good justification.

--Paul Hoffman, Director
--Internet Mail Consortium