Subject: Top 100s

From: Danny Ayers <[email-masked]>
Date: Thu, 13 Jan 2005 19:09:13 +0100

fyi, Dare has blogged on "Syndicating Ordered Lists" pointing to
Netflix's rather thin RSS 2.0 feed, pointing to some holes in the
format(s). I know this scenario came up a while back somewhere around
'order', I'm not really sure how well covered it is now (or needs to
be).

http://www.25hoursaday.com/weblog/PermaLink.aspx?guid=a257ba40-b9fd-4cba-959a-2bba6ae917f0

Cheers,
Danny.

-- 

http://dannyayers.com

---

From: Robert Sayre <[email-masked]>
Date: Thu, 13 Jan 2005 18:04:22 -0500

> 'order', I'm not really sure how well covered it is now (or needs to

OK, there are two issues there. 1 is ordering of the items, while the 
second is something similar to versioning.

It occurs to me that Roy's PaceFeedRecursive might solve the second 
problem pretty simply.

<feed ...>
	<head>
	<title>Netflix Top 100</title>
	<id>foo</id>
	<link href="http://example.org/top100" />
	</head>

	<feed>
		<head>
		<title>Netflix Top 100 -- Week of 2005-01-07</title>
		<id>bar</id>
		<link href="http://example.org/2005/01/07/top100" />
		</head>

		... 100 movies ...
	</feed>
</feed>

... next week ...

<feed ...>
	<head>
	<title>Netflix Top 100</title>
	<id>foo</id>
	<link href="http://example.org/top100" />
	</head>

	<feed>
		<head>
		<title>Netflix Top 100 -- Week of 2005-01-14</title>
		<id>baz</id>
		<link href="http://example.org/2005/01/14/top100" />
		</head>

		... 100 movies ...
	</feed>
</feed>