Subject: Re: Issues with draft-ietf-atompub-format-04

From: Robert Sayre <[email-masked]>
Date: Tue, 25 Jan 2005 22:49:32 -0500

Eric Scheid wrote:

>On 26/1/05 11:03 AM, "Robert Sayre" <[email-masked]> wrote:
>
>  
>
>>>It is a bit vague that this TYPE attribute differs from the one in
>>>section 3.1.1. Where this one MUST have a MIME type as value the other
>>>MUST NOT.
>>>      
>>>
>>This is incorrect.
>>    
>>
>
>huh?
>
>link constructs MAY have a type attribute whose value MUST be a MIME type
>
>text constructs MAY have a type attribute whose value MUST be one of TEXT,
>HTML, or XHTML, and MUST NOT be a MIME type.
>  
>

Ah, you're right. Still don't see how it's vague, though.

Robert Sayre

---

From: Eric Scheid <[email-masked]>
Date: Wed, 26 Jan 2005 15:01:26 +1100

On 26/1/05 2:49 PM, "Robert Sayre" <[email-masked]> wrote:

>> [3.1.1 says TYPE is one thing]
>> [3.5.2 says TYPE is the opposite]

> Ah, you're right. Still don't see how it's vague, though.

It's only clear what's going on when the reader juxtaposes the two sections,
and realises that the concept named 'type' in section [3.1.1] is not the
same concept named 'type' in section [3.5.2]. Without that juxtaposition,
the reader might well never realise that 'type' != 'type' and conflate the
two concepts. Even you made that mistake just now, and you're the editor of
the document. Pity the poor reader.

Looking at it from a usability of specifications p.o.v., it doesn't hurt to
have cross references.

e.

---

From: Robert Sayre <[email-masked]>
Date: Tue, 25 Jan 2005 23:10:38 -0500

>the document. Pity the poor reader.

I made that mistake because the draft in front of me is organized quite 
differently than the one in front of you.

Bring this issue up again after the next draft if you still think it's 
worthwhile to embark on a campaign to rename an attribute.

Robert Sayre

---

From: Martin Duerst <[email-masked]>
Date: Wed, 26 Jan 2005 22:11:17 +0900

>Looking at it from a usability of specifications p.o.v., it doesn't hurt to

I agree this is a problem. Either we find new names for the attributes
so that each element has a different attribute, or we put pointers
to the other 'type' attribute(s) in each section about a type attribute
(and ideally also a table somewhere that shows all of them).

If we don't do it, confusion will be guaranteed, and we will
know we are the ones to blame.

Regards,    Martin.

---

From: Anne van Kesteren <[email-masked]>
Date: Sun, 30 Jan 2005 18:00:08 +0100

> differently than the one in front of you.

It was unclear to me as well.

-- 
  Anne van Kesteren
  <http://annevankesteren.nl/>