Subject: Multiple content allowed?

From: Norman Walsh <[email-masked]>
Date: Thu, 27 Jan 2005 12:03:04 -0500

Someone sent me this, noting that it was not valid according to the
grammar I posted. He thought it was legal according to the spec,
and I'm not sure. What say you?

<feed xmlns="http://purl.org/atom/ns#draft-ietf-atompub-format-04"
  xmlns:xhtml="http://www.w3.org/1999/xhtml"
  xmlns:mods="http://www.loc/gov/mods/v3"
  version="draft-ietf-atompub-format-04 : do not deploy">
  <head xml:lang="en">
    <author>
      <name>Anonymous User</name>
    </author>
    <title>Public Space Readings</title>
    <link href="http:://www.test.com"/>
    <category label="topic" term="public space"/>
    <updated>2005-01-25T13:52:08Z</updated>
  </head>
  <entry>
    <title>Some Article</title>
    <content type="application/xml+annote">
      <xhtml:div clas="bibnotes">
        <xhtml:div class="summary">
          <xhtml:p>Some notes</xhtml:p>
        </xhtml:div>
      </xhtml:div>
    </content>
    <content type="application/xml+mods">
      <mods:mods ID="doe99">
        <mods:titleInfo>
          <mods:title>Some Title</mods:title>
        </mods:titleInfo>
      </mods:mods>
    </content>
    <updated>2005-01-25T13:52:08Z</updated>
    <link href="http://www.example.com/one.xml"/>
  </entry>
</feed>

                                        Be seeing you,
                                          norm

-- 
Norman Walsh <[email-masked]> | The lasting pleasures of contact with
http://nwalsh.com/            | the natural world are not reserved for
                              | scientists but are available to anyone
                              | who will place himself under the
                              | influence of the earth, sea and sky and
                              | their amazing life.--Rachel Carson

---

From: Bill de hÓra <[email-masked]>
Date: Thu, 27 Jan 2005 17:15:38 +0000

> and I'm not sure. What say you?

My first thought is that unless there a use-case for multiple content 
blocks, you've found a bug in the spec.

cheers
Bill

---

From: Robert Sayre <[email-masked]>
Date: Thu, 27 Jan 2005 12:28:07 -0500

> blocks, you've found a bug in the spec.

http://www.atompub.org/2005/01/10/draft-ietf-atompub-format-04.html#rfc.section.5.12

"atom:entry elements MUST  contain zero or one atom:content elements."

PaceReformedContent3 made multiple content elements invalid. I wonder 
why that example couldn't use an xhtml summary element.

Robert Sayre

---

From: Eric Scheid <[email-masked]>
Date: Fri, 28 Jan 2005 10:12:27 +1100

> and I'm not sure. What say you?

not legal.

    5.12 "atom:content" Element

    The "atom:content" element either contains or links to the
    content of the entry. atom:entry elements MUST contain zero
    or one atom:content elements.

... although I can't remember why we went zero or one. Maybe as a result of
getting rid of the multipart/ madness. I like the idea of multiple <content>
elements as alternates (particularly with xml:lang or different @type)

e.