Subject: PaceOriginalAttribute

From: Antone Roundy <[email-masked]>
Date: Thu, 5 May 2005 09:20:06 -0600

-1.

I don't see that this solves any problem.  It may help people avoid 
accidentally generating invalid feeds (if we stick to not to allowing 
duplication of atom:id within a feed), but it does it by simply 
shunting the issue off into a different element which doesn't have 
duplication constraints.  It doesn't address the DOS problem--neither 
accidental nor intentional.  And it doesn't make it any easier to 
determine whether or not entries in different feeds with the same 
atom:id are really the same entry or not.  In fact, it just complicates 
the task by requiring the inspection of two elements instead of one.

---

From: Robert Sayre <[email-masked]>
Date: Thu, 5 May 2005 12:14:39 -0400

On 5/5/05, Antone Roundy <[email-masked]> wrote:
> 
> -1.
> 
> I don't see that this solves any problem.  

I suggest you reread it. Your analysis is deeply flawed.

> It may help people avoid
> duplication constraints. 

Incorrect. Think harder about what PubSub services do. They take an
entry, and munge it (people like that). They move the feed data to
atom:source, and probably add their own extension elements to it. I
think they are "forwarding" a message. My proposal preserves the
identity of the original message, while requiring the service to mint
an identifier for its forwarded message.

> It doesn't address the DOS problem--neither
> accidental nor intentional.  

Oh yes it does. Each entry's provenance is documented. The data format
accurately states that the intermediary has munged the original entry.

> And it doesn't make it any easier to

Incorrect. What it does is explicitly state that two different feeds
think they are fowarding the same entry.

Robert Sayre

---

From: Antone Roundy <[email-masked]>
Date: Thu, 5 May 2005 10:43:31 -0600

> an identifier for its forwarded message.

Okay, the forwarded message has it's own all-in-one-element identifier. 
  This sounds useful...except that someone may accidentally or 
intentionally duplicate that identifier too.

> accurately states that the intermediary has munged the original entry.

Maybe I am missing something, but if so...well, by definition, I'm not 
seeing it.  Let's look at an example.  Say your aggregator sees these 
in different feeds:

<feed>
	<id>foo:foo</id>
	<entry>
		<id>foo:bar</id>
		<title>I'm the real thing</title>
	</entry>
</feed>

<feed>
	<id>bar:bar</id>
	<entry>
		<id>bar:foo</id>
		<source>
			<id>foo:foo</id>
			<original>foo:bar</original>
		</source>
		<title>I may be an imposter</title>
	</title>
</feed>

Do you display one or both?  How would your decision making process 
differ from if you were to see the following in the second case?

<feed>
	<id>bar:bar</id>
	<entry>
		<id>foo:bar</id>
		<source>
			<id>foo:foo</id>
		</source>
		<title>I may be an imposter</title>
	</title>
</feed>

And what if we added a third case?

<feed>
	<id>qwerty:bar</id>
	<entry>
		<id>bar:foo</id>
		<source>
			<id>foo:foo</id>
			<original>foo:bar</original>
		</source>
		<title>I'm definitely an imposter</title>
	</title>
</feed>

> think they are fowarding the same entry.
Yeah, they think they are, or at least claim to think so.  But isn't 
that the same thing that is stated if you see the following in two 
feeds?

<feed>
	<id>bar:bar</id>
	<entry>
		<id>foo:bar</id>
		<source>
			<id>foo:foo</id>
		</source>
		<title>I may be an imposter</title>
	</title>
</feed>

This says that this feed is (or at least claims it is) forwarding the 
entry with the id "foo:bar" from the feed "foo:foo".

I am honestly trying to see more in this, but as yet, I don't.

---

From: Robert Sayre <[email-masked]>
Date: Thu, 5 May 2005 19:21:50 -0400

> I am honestly trying to see more in this, but as yet, I don't.

OK, now let's say you're subscribed to "imposter" in PubSub.

<feed>
      <id>bar:bar</id>
      <entry>
                 <id>quux:quux1</id>
                 <source orginal="foo:bar">
                         <id>foo:foo</id>
                 </source>
                 <title>I may be an imposter</title>
        </entry>
      <entry>
                 <id>quux:quux2</id>
                 <source orginal="foo:bar">
                         <id>baz:baz</id>
                 </source>
                 <title>I may be an imposter</title>
        </entry>
 </feed>

Robert Sayre

---

From: Antone Roundy <[email-masked]>
Date: Fri, 6 May 2005 15:49:32 -0600

>                  <title>I may be an imposter</title>

Sorry, I don't understand the point of this example.  I read it as 
saying that these two entries from different feeds claimed the same id. 
  I don't know whether they really are the same entry, or whether one or 
both of their original ids were minted erroneously (accidentally 
duplicating another entry's id) or maliciously (attempting to DOS 
someone else's entry).  I can't see any way of resolving that question 
that I wouldn't have if PubSub had given me this instead:

<feed>
       <id>bar:bar</id>
       <entry>
                  <id>foo:bar</id>
                  <source>
                          <id>foo:foo</id>
                  </source>

---

From: Graham <[email-masked]>
Date: Tue, 10 May 2005 23:54:35 +0100

-1

An entry only needs one identifier. The way to solve this problem (if  
it needs solving) is allowing duplicate ids under some or all  
circumstances.

Graham

---

From: Robert Sayre <[email-masked]>
Date: Tue, 10 May 2005 20:22:51 -0400

> it needs solving) is allowing duplicate ids under some or all

Hmm. I'd be curious to hear what you think the problem is. Every
system I can think of that does forwarding or versioning assigns
multiple identifiers. Perhaps you have an example system in mind?

Robert Sayre

---

From: Graham <[email-masked]>
Date: Wed, 11 May 2005 02:06:01 +0100

> multiple identifiers. Perhaps you have an example system in mind?

atompub-format-08:

"When an Atom document is relocated, migrated, syndicated,  
republished, exported or imported, the content of its atom:id element  
MUST NOT change."

Graham

---

From: Robert Sayre <[email-masked]>
Date: Tue, 10 May 2005 21:36:12 -0400

> republished, exported or imported, the content of its atom:id element

No, I mean a deployed system.

Robert Sayre