Subject: draft-ietf-atompub-protocol-04.txt

From: Greg Smith <[email-masked]>
Date: Tue, 10 May 2005 16:26:07 -0700 (PDT)

In reference to draft-ietf-atompub-protocol-04.txt

Just a quick readthrough and I have a few comments:

4.2 Discovery: good description and "easing" into the
meat of the document.

6. Should probably reference "see section
8.1.1.3.1.1".

6.1 In the table, what does "x" mean? Not allowed?
Seems like it means something else, but not explicitly
stated.

I'm concerned about the ability of a client, given a
Service Document (whether Autodiscovered or not), to
determine what the Service Document covers. I think
this is where the "entry" and "generic" types are
going, but it seems like it might be advantageous to
tie the Service Document to Content-Types. Suppose I
am a blog hosting service and I allow direct photo,
video, audio, and text blogs. By "direct" I mean I
allow someone to post a photo directly to a photo blog
without any text or metadata in it whatsoever.

I will probably want a "public" service document that
lists the hrefreadonly links for viewers and a
"private" service document for my posting clients. If
I do this, and then provide a series of collections
within the service document, there is no way to
automatically sort out what kind of content to post to
each of the collections. If I want you to be able to
program "dumb" clients that provide little or no
metadata (like directly from a camera or mp3 recorder
or phone), then it would be nice to provide a "photo"
collection to POST my photos to.

While we could create a whole series of "entry",
"generic", and other types, it might be better to
consider listing for each collection, the acceptable
Content-Types.

Right now, it looks like a client has to trial and
error the Content-Types to determine the allowed
Content-Types. It would even be nice to provide a
"preferred" Content-Type for each collection as well,
but I'm not sure that would be necessary.

Just my thoughts. I'm sorry if this has been hashed
over already, I'm new to the group.

Greg Smith

__________________________________ 
Do you Yahoo!? 
Yahoo! Small Business - Try our new resources site!
http://smallbusiness.yahoo.com/resources/

---

From: Joe Gregorio <[email-masked]>
Date: Tue, 10 May 2005 20:39:52 -0400

Greg,
   All excellent observations and comments. My replies are inline.

> 6. Should probably reference "see section

Good points. I have started an errata page for this draft on the wiki:

http://www.intertwingly.net/wiki/pie/ProtocolDraft04Errata

> but I'm not sure that would be necessary.

This document is just the 'basic' protocol, where we are describing
the basic mechanisms and collection types. We are expecting to produce
a further specification that covers editing collections of other types
of documents, such as templates, etc.

    Thanks,
    -joe

-- 
Joe Gregorio        http://bitworking.org