Subject: some xmlns:atom tomfoolery

From: Eric Scheid <[email-masked]>
Date: Sat, 28 May 2005 18:52:23 +1000

An Atom Entry can have XML content, right...

Consider this example:

<feed xmlns="http://...atom">
    ...
    <entry>
        <title>the minimal Atom Entry</title>
        <summary>A minimal entry has only ...</summary>
        <content type="application/atom+xml">
            <entry>
                ...
            </entry>
        </content>
    </entry>
</feed>

Entirely legal, but who wants to bet the feed validator throws a fit ;-)

e.

---

From: "A. Pagaltzis" <[email-masked]>
Date: Sat, 28 May 2005 13:02:02 +0200

> Entirely legal, but who wants to bet the feed validator throws

Most aggregators will probably ignore the content, and likely not
even do anything useful with the entry.

Hmm. Escher Atom?

    <entry xmlns="http://...atom">
        <title>The inifinite Atom Entry:</title>
        <summary>Reflecting on myself.</summary>
        <content type="application/atom+xml" src="#" />
    </entry>

Regards,
-- 
Aristotle

---

From: Sam Ruby <[email-masked]>
Date: Sat, 28 May 2005 12:15:51 -0400

> Entirely legal, but who wants to bet the feed validator throws a fit ;-)

I'll take that bet.

- Sam Ruby

---

From: [email-masked] (John Panzer)
Date: Sat, 28 May 2005 14:09:12 -0700

>        <content type="application/atom+xml">
Or perhaps:
                            <feed>
                                   ...
                            </feed>

:^)

---

From: Tim Bray <[email-masked]>
Date: Sat, 28 May 2005 14:39:46 -0700

>>        <content type="application/atom+xml">

You guys are sick, evil, and twisted.  Snicker.   -Tim

---

From: Eric Scheid <[email-masked]>
Date: Sun, 29 May 2005 19:36:29 +1000

>>        <content type="application/atom+xml">

hmmm... seriously though, that's one way to provide a package of multipart
content. An example might be a play list. A bit of difficulty subscribing to
that feed though ;-)

e.