Subject: Re: atom:type, xsl:output

From: James Cerra <[email-masked]>
Date: Tue, 24 May 2005 20:46:46 -0700 (PDT)

Graham,

> > Secondly, XML may be entity (or CDATA) encoded like
> > @type="html" or plain xml like @type="xhtml".  This is
> If I follow you right, you misunderstand. Atom documents are  
> unambiguous. XML has to be inserted literally, with no entity  
> escaping (except for entities that are part of text nodes) allowed.

I'm not so sure.  The spec seems to hint at the answer, but provides no
cannonical interpretation like it does with @type="html".

After being processed by a XML processor, any entites should be dereferenced to
their text values and placed into the document tree.  So this:

> > <atom:content type="application/xml">
> > &lt;?xml version="1.0?>
> > &lt;tag /></atom:content>

would become the text string:

> > <atom:content type="application/xml">
> > <xml version="1.0?>
> > <tag /></atom:content>

I agree that is bad; see my response to A. Pagaltzis.  But I'm sure someone
will make the mistake I made - either out of ignorance like me or the desire to
be "compatible" - without this pitfall being mentioned in the spec.

--
Jimmy Cerra

__________________________________ 
Do you Yahoo!? 
Yahoo! Small Business - Try our new Resources site
http://smallbusiness.yahoo.com/resources/

---

From: Henri Sivonen <[email-masked]>
Date: Wed, 25 May 2005 10:43:54 +0300

On May 25, 2005, at 06:46, James Cerra wrote:

> fter being processed by a XML processor, any entites should be 
> dereferenced to

No. It becomes a tree:
Element atom:content having attribute type="application/xml"
    |
    \ Text: <xml version="1.0?> <tag />

(Newlines omitted.)

-- 
Henri Sivonen
[email-masked]
http://hsivonen.iki.fi/