Subject: Dealing with namespace prefixes when syndicating signed entries

From: Antone Roundy <[email-masked]>
Date: Wed, 29 Jun 2005 14:44:53 -0600

Mulling more...

Let's say an aggregator is putting these two entries into the same 
aggregate feed:

<feed ... xmlns:a="foo" xmlns:b="bar">
	...
	<entry>
		[signature]
		<a:foo ... />
		<b:bar ... />
		...
	</entry>
</feed>

<feed ... xmlns:b="foo" xmlns:a="bar">
	...
	<entry>
		[signature]
		<b:foo ... />
		<a:bar ... />
		...
	</entry>
</feed>

Perhaps a reasonable way to deal with the namespace prefix conflict 
would be for the signature to be applied after a transform that yielded 
this (putting full namespace names in where the prefixes were):

	<[atom's namespace]:entry>
		[signature]
		<foo:foo ... />
		<bar:bar ... />
		...
	</[atom's namespace]:entry>

Unprefixed attributes would naturally remain unprefixed, but elements 
in the default namespace would need to have their namespace names 
prepended.

---

From: James M Snell <[email-masked]>
Date: Wed, 29 Jun 2005 16:09:57 -0700

After digging through things a bit I *believe* the Exclusive 
Canonicalization spec handles this.  It was designed to allow a chunk of 
signed XML to be portable from one containing element to another.  
http://www.w3.org/TR/2002/REC-xml-exc-c14n-20020718/ 

Antone Roundy wrote:

> would be for the signature to be applied after a transform that 
> yielded this (putting full namespace names in where the prefixes were):
>

---

From: Bill de hÓra <[email-masked]>
Date: Thu, 30 Jun 2005 03:31:03 +0100

Antone Roundy wrote:

> [...]
> [...]

ex-c14n is where to deal with this - it's a necessary preprocessing step
to dsigging XML and walks the line between the Infoset and bytewise
needs. IIRC it can result in moving the namespace declarations around.

cheers
Bill