Subject: Re: Signifying a Complete Feed

From: "A. Pagaltzis" <[email-masked]>
Date: Thu, 13 Oct 2005 21:02:46 +0200

* Byrne Reese <[email-masked]> [2005-10-13 20:55]:
> No I suppose not. But there are edge cases where people may not
> include content in a post. They may simply use the title... in
> maintaining a list of links for example. But I suppose there is
> a difference between:
> 
> <entry>
>  <title>foo</title>
> </entry>
> 
> And 
> 
> <entry>
>  <title>foo</title>
>  <content></content>
> </entry>
> 
> I think that is clear enough.

That is exactly correct.

If you want to ship a complete representation, you ship an
atom:entry, and if the resource is empty, then that atom:content
is empty.

If the atom:entry has no atom:content, then that always means
that it is a partial representation only.

Regards,
-- 
Aristotle Pagaltzis // <http://plasmasturm.org/>

---

From: Graham <[email-masked]>
Date: Thu, 13 Oct 2005 21:37:30 +0100

> that it is a partial representation only.

Point to any text in the spec that backs this up.

Graham

---

From: Robert Sayre <[email-masked]>
Date: Thu, 13 Oct 2005 16:51:18 -0400

> Point to any text in the spec that backs this up.

The spec says only "The 'atom:content' element either contains or
links to the content of the entry."

Any assertion that there is no other content to be had is not
testable, and therefore rightly excluded from the spec. I don't see
what harm the proposed extension could do, but it doesn't sound like
something I would implement. What's the benefit?

Robert Sayre

---

From: "James Holderness" <[email-masked]>
Date: Thu, 13 Oct 2005 23:06:22 +0100

> Point to any text in the spec that backs this up.

"4.2.13 The "atom:summary" element is a Text construct that conveys a short 
summary, abstract, or excerpt of an entry. "

To me, that implies that there exists a resource somewhere that is a more 
complete representation of what is being provided in the summary. If there 
is no atom:content element then the entry can't possibly contain that full 
representation. Surely then that would make it partial representation?

In reality though I've seen feeds with atom:content elements that wouldn't 
be considered complete by any stretch of the imagination. I've also seen 
entries with no atom:content where the full text is included in the 
atom:summary. For an Atom processor there are really no guarantees about 
anything regardless of what the spec may or may not say.

Regards
James