Subject: clarification needed: order of children of atom:entry

From: Eric Scheid <[email-masked]>
Date: Thu, 27 Oct 2005 14:46:37 +1000

Section 4.1.2 of the Atom Syndication Format spec states this:

   "This specification assigns no significance to the order of
    appearance of the child elements of atom:entry."

Is this referring to the immediate children only of atom:entry, or of all
descendents?

I'm hoping for the former, otherwise this:

<entry>
    <content type="xhtml">
        <div xmlns="..">
            <h1>heading</h1>
            <p>para.1</p>
            <p>para.2</p>
        </div>
    </content>
    ...
</entry>

... could become the following when passing some intermediary:

<entry>
    <content type="xhtml">
        <div xmlns="..">
            <p>para.2</p>
            <p>para.1</p>
            <h1>heading</h1>
        </div>
    </content>
    ...
</entry>

e.

---

From: James M Snell <[email-masked]>
Date: Wed, 26 Oct 2005 22:08:16 -0700

Immediate children.

---

From: "A. Pagaltzis" <[email-masked]>
Date: Thu, 27 Oct 2005 08:09:22 +0200

* Eric Scheid <[email-masked]> [2005-10-27 06:55]:
> Is this referring to the immediate children only of atom:entry,
> or of all descendents?

It would say descendents if it meant descendents, no?

Regards,
-- 
Aristotle Pagaltzis // <http://plasmasturm.org/>

---

From: Eric Scheid <[email-masked]>
Date: Thu, 27 Oct 2005 16:25:50 +1000

> It would say descendents if it meant descendents, no?

not if it was speaking in more general terms.

e.

---

From: Tim Bray <[email-masked]>
Date: Thu, 27 Oct 2005 05:27:27 -0700

> Is this referring to the immediate children only of atom:entry, or  

In the XML context, the term "child elements" is not ambiguous.  So I  
think it means what it says, which is what you want it to mean. -Tim