Subject: Re: icon and logo on entry

From: James M Snell <[email-masked]>
Date: Tue, 25 Oct 2005 13:08:27 -0700

I've been wanting to do the same thing for link elements.  Let's propose 
a single solution:

<entry>
  <x:logo type="{media-type}">{url}</x:logo>
  <x:icon type="{media-type}">{url}</x:icon>
  <link>
    <x:logo type="{media-type}">{url}</x:logo>
    <x:icon type="{media-type}">{url}</x:icon>
  </link>
</entry>

Both elements should follow the exact same rules as the existing 
atom:logo and atom:icon elements.

- James

Henry Story wrote:

>
> I'd like to propose an extension that would allow something very much  
> like
> icon and logo to be added to an entry, the way it currently is  
> allowed on a feed.
> I have been publishing entries like this for over a year now [1], and  
> so has
> James Gosling [2], and other users of BlogEd. It would be really nice  
> to keep
> this semantic information in the feed somehow.
>
> Perhaps something like:
>
> <feed xmlns="http://www.w3.org/2005/Atom">
>
>      <title>Example Feed</title>
>      <link href="http://example.org/"/>
>      <updated>2003-12-13T18:30:02Z</updated>
>      <author>
>        <name>John Doe</name>
>      </author>
>      <id>urn:uuid:60a76c80-d399-11d9-b93C-0003939e0af6</id>
>      <logo>./Image1-large.jpeg</logo>
>      <icon>./Image1-small.jpeg</icon>
>      <entry>
>        <title>Atom-Powered Robots Run Amok</title>
>        <ext:logo>./Image5-large.jpeg</logo>
>        <ext:icon>./Image5-small.jpeg</icon>
>        <link href="http://example.org/2003/12/13/atom03"/>
>        <id>urn:uuid:1225c695-cfb8-4ebb-aaaa-80da344efa6a</id>
>        <updated>2003-12-13T18:30:02Z</updated>
>        <summary>Some text.</summary>
>      </entry>
> </feed>
>
> Though from what I have said in other posts about relative uris in
> extension elements I suppose it would be better to have a new link type.
>
> Any ideas?
>
> Henry
>
> [1] http://bblfish.net/blog/
>     http://blogs.sun.com/roller/page/bblfish/
> [2] http://blogs.sun.com/roller/page/jag/
>
>
>
>

---

From: Henry Story <[email-masked]>
Date: Tue, 25 Oct 2005 21:58:27 +0200

Perhaps something like:

Any ideas?

Henry

---

From: Henry Story <[email-masked]>
Date: Tue, 25 Oct 2005 22:23:59 +0200

On 25 Oct 2005, at 22:08, James M Snell wrote:

>
> I've been wanting to do the same thing for link elements.

Nice :-)

> Let's propose a single solution:
>
> <entry>

Is the above a single solution, or two solutions? I can't quite tell the
difference.

Would they (it?) be equivalent to the following:

     <entry>
        <title>Atom-Powered Robots Run Amok</title>
        <link rel="logo" href="/Image5-large.jpeg"/>
        <link rel="icon" href="/Image5-small.jpeg"/>
        <link href="http://example.org/2003/12/13/atom03"/>
        <id>urn:uuid:1225c695-cfb8-4ebb-aaaa-80da344efa6a</id>
        <updated>2003-12-13T18:30:02Z</updated>
        <summary>Some text.</summary>
      </entry>

I would think the media type is very much optional here.

> atom:logo and atom:icon elements.

Do you mean rules, or do you mean semantics? (ie: we just copy and  
paste the text
from the atom syntax doc, replacing feed with entry)

Henry

>
> - James
>
> Henry Story wrote:
>
>
>>
>> I'd like to propose an extension that would allow something very  
>> much  like
>> I have been publishing entries like this for over a year now [1],  
>> and  so has
>> James Gosling [2], and other users of BlogEd. It would be really  
>> nice  to keep

---

From: Henry Story <[email-masked]>
Date: Tue, 25 Oct 2005 22:30:04 +0200

Oh I think I get it now. You want to specify the logo and icon of a  
resource
on the other side of a link.

So generalizing the suggestion:

    <entry>
        <title>Atom-Powered Robots Run Amok</title>
        <link rel="logo" href="/Image5-large.jpeg"/>
        <link rel="icon" href="/Image5-small.jpeg"/>
        <link href="http://example.org/2003/12/13/atom03">
              <link rel="logo" href="http://example.org/2003/12/13/ 
atom03-large.jpeg"/>
              <link rel="icon" href="http://example.org/2003/12/13/ 
atom03-small.jpeg"/>
        </link>
        <id>urn:uuid:1225c695-cfb8-4ebb-aaaa-80da344efa6a</id>
        <updated>2003-12-13T18:30:02Z</updated>
        <summary>Some text.</summary>
    </entry>

Makes sense to me.

Henry

---

From: James M Snell <[email-masked]>
Date: Tue, 25 Oct 2005 13:32:09 -0700

Yep.. the only challenge with your example is that atom:link's should 
not contain atom:link's...