Subject: RE: New Link Relations -- Ready to go?

From: "Byrne Reese" <[email-masked]>
Date: Sat, 22 Oct 2005 02:02:11 -0400

+1 to all.

Wheeee! 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Mark Nottingham
> Sent: Thursday, October 20, 2005 4:53 PM
> To: Atom Syntax
> Subject: New Link Relations -- Ready to go?
> 
> 
> At this point, I believe the following represent as close to 
> consensus as we're able to get (although I'm happy to be 
> proven wrong, as long as there are counterproposals that can 
> gain consensus).
> 
> To move forward, please either +1 or -1 them, preferably with 
> replacement text if you -1. Once there seems to be rough 
> consensus, I plan to make a request to IANA and point the 
> IESG to this discussion thread to illuminate their deliberations.
> 
>   -  Attribute Value: previous
>   -  Description: A URI that refers to the immediately 
> preceding document in a series of documents.
>   -  Expected display characteristics: Undefined.
>   -  Security considerations: Automated agents should take 
> care when this relation crosses administrative domains (e.g., 
> the URI has a different authority than the current document). 
> Such agents should also take care to detect circular references.
> 
>   -  Attribute Value: next
>   -  Description: A URI that refers to the immediately 
> following document in a series of documents.
>   -  Expected display characteristics: Undefined.
>   -  Security considerations: Automated agents should take 
> care when this relation crosses administrative domains (e.g., 
> the URI has a different authority than the current document). 
> Such agents should also take care to detect circular references.
> 
>   -  Attribute Value: first
>   -  Description: A URI that refers to the furthest preceding 
> document in a series of documents.
>   -  Expected display characteristics: Undefined.
>   -  Security considerations: Automated agents should take 
> care when this relation crosses administrative domains (e.g., 
> the URI has a different authority than the current document). 
> Such agents should also take care to detect circular references.
> 
>   -  Attribute Value: last
>   -  Description: A URI that refers to the furthest following 
> document in a series of documents.
>   -  Expected display characteristics: Undefined.
>   -  Security considerations: Automated agents should take 
> care when this relation crosses administrative domains (e.g., 
> the URI has a different authority than the current document). 
> Such agents should also take care to detect circular references.
> 
>   -  Attribute Value: subscribe
>   -  Description: A URI that refers to a feed document 
> containing a set of the most recent entries in the feed. This 
> URI is intended to be subscribed to to keep abreast of recent 
> changes in the feed. When different from the URI of the 
> document where it occurs, it indicates that its value should 
> be used for this purpose in place of the current document's URI.
>   -  Expected display characteristics: Undefined.
>   -  Security considerations: Users should be informed of the 
> actual URI they are subscribing to, and subscription should 
> only take place when it is explicitly requested.
> 
> 
> --
> Mark Nottingham     http://www.mnot.net/
> 
>

---

From: "Byrne Reese" <[email-masked]>
Date: Sat, 22 Oct 2005 02:02:14 -0400

> >Second, although less important - even applications which do support 
> >rel="subscribe" will have to implement a fallback behaviour. 
> Arguably, 
> >they already do in some fashion, because a feed may omit the 
> rel="self" 
> >link, so I don't know if this is such a pressing issue.
> >
> >For these two (similar) reasons I think it might be wise to keep 
> >rel="self" in the role that this new rel="subscribe" thing 
> is supposed 
> >to fulfill, and invent a new relationship that can point to the 
> >canonical location of the archive feed document.
> >
> >  
> >
> -1.  self always points to *this* document and is only usable 
> for subscribing to *this* document.  You cannot use it to 
> point to a separate document.

I agree with James. I like to think of it like this:

* = current page/document/feed in a 9 page archive

1    2    3    4    5    6    7    8    9
|----|----|----|----*----|----|----|----|
^              ^    ^    ^              ^
rel=subscribe  |    |    rel=next       rel=last
Rel=first      |    rel=self
               |    "current page"     
               rel=prev

You should subscribe to the HEAD of the feed (assuming there are
multiple pages to the feed.

Self is analogous to "this" and should be /purely/ (excuse the circular
definition) self referencial.