Subject: Fwd: PaceResurrectAutodiscovery

From: Geoffrey Sneddon <[email-masked]>
Date: Sat, 25 Nov 2006 15:04:27 +0000

On 25 Nov 2006, at 14:24, Lachlan Hunt wrote:

> Tse Shing Chi (Franklin/Whale) wrote:
>>>> I think that only <link> should be used. All feeds linked by <a>  
>>>> should be ignored during the process of autodiscovery.
>>> Why?
>> Autodiscovery should be limited to <head>...</head>. If an author  
>> wants his feeds to be discovered automatically by UAs, he should  
>> use <link>. Providing additional or same feed links using <a> is  
>> only for linking and does not affect the autodiscovery. Scanning  
>> whole document is not necessary and increases the complexity.
>
> Ah, but this works!
>
> <html>
> <head>
>  <title>Feed Autodiscovery</title>
> </head>
> <body>
>   <p>... really long body ...</p>
>   <link rel="alternate" type="application/atom+xml" href="/feed">
> </body>
> </html>
>
> I tested that with both HTML and XHTML and both tests worked in  
> Firefox, Opera and Safari. IE7 was the only broswer that appeared  
> to do what you suggest, at least to some degree.  But given that  
> IE7 is in the minority in this case, and doesn't handle link  
> elements in the body like other browsers (the way it's being  
> defined in HTML5), I consider that a bug in IE.

The link element is currently defined as being able to used "In a  
head element." in HTML5, in the current WD.

- Geoffrey Sneddon

<Seems I accidentally sent this just to Lachlan, not to the mailing  
list. Duh. Good attempt at a first post on a mailing list.>

---

From: Lachlan Hunt <[email-masked]>
Date: Sun, 26 Nov 2006 02:59:20 +1100

Geoffrey Sneddon wrote:
> The link element is currently defined as being able to used "In a head 
> element." in HTML5, in the current WD.

I was referring to the way browsers have to handle it in non-conforming 
documents.

| If the insertion mode is "in body"
|    Handle the token as follows:
|    ...
|    A start tag token whose tag name is one of: "base", "link", "meta",
|    "style", "title"
|        Parse error. Process the token as if the insertion mode had
|        been "in head".

That effectively means, no matter where the link element occurs, it has 
to be inserted into the head.

http://www.whatwg.org/specs/web-apps/current-work/#in-body

-- 
Lachlan Hunt
http://lachy.id.au/

---

From: "Tse Shing Chi \(Franklin/Whale\)" <[email-masked]>
Date: Sun, 26 Nov 2006 00:19:11 +0800

Parse Error! [ http://www.whatwg.org/specs/web-apps/current-work/#parse ]

Quote

"The error handling for parse errors is well-defined: user agents must either act as described below when encountering such problems, or must abort processing at the first error that they encounter for which they do not wish to apply the rules described"

Franklin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Lachlan Hunt
Sent: Saturday, November 25, 2006 23:59
To: Geoffrey Sneddon
Cc: [email-masked]
Subject: Re: Fwd: PaceResurrectAutodiscovery

-- 
Lachlan Hunt
http://lachy.id.au/

---

From: Lachlan Hunt <[email-masked]>
Date: Sun, 26 Nov 2006 03:27:39 +1100

Tse Shing Chi (Franklin/Whale) wrote:
> Parse Error! [
> http://www.whatwg.org/specs/web-apps/current-work/#parse ]
> 
> Quote
> 
> "The error handling for parse errors is well-defined: user agents
> must either act as described below when encountering such problems,
> or must abort processing at the first error that they encounter for
> which they do not wish to apply the rules described"

What's your point?  The first option is the way normal web browsers have 
to behave in the real world, the second, known as draconian error 
handling, is available for other types of UAs that aren't requried to 
gracefully recover from all errors.

-- 
Lachlan Hunt
http://lachy.id.au/

---

From: "Tse Shing Chi \(Franklin/Whale\)" <[email-masked]>
Date: Sun, 26 Nov 2006 00:40:19 +0800

Sorry for a broken reply...

What I want to say is that <link> outside <head> causes a parse error which UAs can choose to correct or to abort processing; even though UAs choose to correct the error, it is still an error. 

Franklin

-----Original Message-----
From: Lachlan Hunt [mailto:[email-masked]] 
Sent: Sunday, November 26, 2006 00:28
To: Tse Shing Chi (Franklin/Whale)
Cc: [email-masked]
Subject: Re: Fwd: PaceResurrectAutodiscovery

-- 
Lachlan Hunt
http://lachy.id.au/