Subject: Re: [atom-syntax] [RFC 4685] uri in xml namespace

From: "Judy Piper" <[email-masked]>
Date: Sun, 5 Nov 2006 00:47:23 -0500

I was expecting a Namespace document that explains the namespace URI itself
and the relationship between the spec and the URI.  Am I wrong to expect
this behavior?

Thanks,
Judy-
On 10/17/06, James M Snell <[email-masked]> wrote:
>
>
> Done!
>
> - James
>
>
> Nicolas Krebs wrote:
> > The RFC 4685 define an xml namespace with
> > "http://purl.org/syndication/thread/1.0".
> > An HTTP GET http://purl.org/syndication/thread/1.0 answer
> > HTTP/1.x 302 Found
> > Location:
> http://www.ietf.org/internet-drafts/draft-snell-atompub-feed-thread-12.txt
> >
> > which redirect to
> >
> http://www.ietf.org/internet-drafts/draft-snell-atompub-feed-thread-12.txt
> >
> > which answer
> > HTTP/1.x 404 Not Found
> >
> > Please fix this issue and make http://purl.org/syndication/thread/1.0
> > redirecting to http://www.ietf.org/rfc/rfc4685.txt or
> > http://tools.ietf.org/html/rfc4685 or http://www.rfc-editor.org/*4685*.
> >
> >
> >
> >
> >
>
>

---

From: Asbjørn Ulsberg <[email-masked]>
Date: Thu, 09 Nov 2006 23:50:44 +0100

On Sun, 05 Nov 2006 06:47:23 +0100, Judy Piper <[email-masked]>  
wrote:

> I was expecting a Namespace document that explains the namespace URI  
> itself and the relationship between the spec and the URI.  Am I wrong to
> expect this behavior?

What is to be expected when resolving a namespace URI is undefined, but a  
common solution is to have a document explaining what the URI means and  
how the vocabulary residing in that namespace can be used. In other words;  
just as you say. Redirecting directly to the specification works, but an  
informative and perhaps more human friendly document inbetween would  
indeed be nice.

A good example is the XHTML namespace URI:

   <http://www.w3.org/1999/xhtml>

-- 
Asbjørn Ulsberg     -=|=-    http://virtuelvis.com/quark/
«He's a loathsome offensive brute, yet I can't look away»

---

From: James M Snell <[email-masked]>
Date: Thu, 09 Nov 2006 17:08:34 -0800

I've updated the purl registration so that it redirects to the RFC.  I
can, alternatively, have it direct to a summary page like the XHTML
namespace does if that's what folks would prefer.

- James

Judy Piper wrote:
> I think that has been understood; I believe that James will be
> addressing this namespace issue.
> 
> Judy-
> [snip]

---

From: "Judy Piper" <[email-masked]>
Date: Thu, 9 Nov 2006 20:16:55 -0500

James wrote:
[snip]
have it direct to a summary page like the XHTML
[snip]
+1
Judy-

namespace

---

From: "Judy Piper" <[email-masked]>
Date: Thu, 9 Nov 2006 20:04:26 -0500

I think that has been understood; I believe that James will be addressing
this namespace issue.

Judy-

---

From: Martin Duerst <[email-masked]>
Date: Fri, 10 Nov 2006 16:01:07 +0900

>   <http://www.w3.org/1999/xhtml>

Yes, this is a good example in general, but misses one important
point. It should say explicitly that the namespace URI is
http://www.w3.org/1999/xhtml. Why? Because somebody by chance
may arrive at this page from another URI, such as
http://Www.w3.org/1999/xhtml (Opera and Firefox convert this to
http://www.w3.org/1999/xhtml, probably due to the Latin/Cyrillic
confusion/scare a while ago, but IE doesn't).

Regards,    Martin.

#-#-#  Martin J. Du"rst, Assoc. Professor, Aoyama Gakuin University
#-#-#  http://www.sw.it.aoyama.ac.jp       mailto:[email-masked]

---

From: Asbjørn Ulsberg <[email-masked]>
Date: Fri, 10 Nov 2006 17:41:43 +0100

On Fri, 10 Nov 2006 08:01:07 +0100, Martin Duerst <[email-masked]>  
wrote:

> http://www.w3.org/1999/xhtml.

I agree. Let's hope James takes this into consideration when he creates  
the HTML document for the Atom namespace URI.

---

From: Asbjørn Ulsberg <[email-masked]>
Date: Fri, 10 Nov 2006 17:40:30 +0100

On Fri, 10 Nov 2006 02:08:34 +0100, James M Snell <[email-masked]>  
wrote:

> I've updated the purl registration so that it redirects to the RFC.

Great.

> I can, alternatively, have it direct to a summary page like the XHTML

Even better. +1.