Subject: searches - was Re: Adding POST capability to atom:link

From: Henry Story <[email-masked]>
Date: Wed, 8 Nov 2006 17:57:45 +0100

One very powerful solution would be to use a "sparql" link as  
described in PaceSparqlLink [1]
This would point to a service end point such as the following:

http://roller.blogdns.net:2020/snorql/

to which a simple SPARQL POST or GET request can be made. The above  
url points to the html view of the form which you can query and find  
out about all the entries on the attached roller server at

http://roller.blogdns.net:8080/roller/

Henry

[1] http://www.intertwingly.net/wiki/pie/PaceSparqlLink

On 26 Oct 2006, at 18:24, Gopalan Sri wrote:
> Hello,
>
> I am trying to use opensearch to do some paging of my search  
> results and
> I have a question regard adding POST capabilities to the atom:link
> construct.
>
> The information I want to pass back to the server is complex in nature
> and makes sense to capture in XML.  My question is whether or not  
> there
> are any thoughts or plans to extend the atom:link contruct to support
> something like this:
>
> <link rel="next" href="http://example.com/" type="application/atom 
> +xml"
> action="POST">
>     <parameter name="q">
>         <xxx:Payload/>
>     </parameter>
>     <parameter name="blah" value="blah"/>
> </link>
>
> Thanks.
> Sri Gopalan
> Booz Allen Hamilton
> Office: Allen 147
> Tel: 703.377.1404
> Mobile: 703.395.4057

---

From: Jan Algermissen <[email-masked]>
Date: Wed, 8 Nov 2006 20:49:30 +0100

On Nov 8, 2006, at 5:57 PM, Henry Story wrote:

> http://www.intertwingly.net/wiki/pie/PaceSparqlLink

Are you really suggesting to use POST for querying (as the Pace says)?

You wouldn't even be able to send someone a link to the [feed that  
is] the
query result or page through the result etc.

??

Jan

---

From: Henry Story <[email-masked]>
Date: Thu, 9 Nov 2006 18:40:21 +0000

> Are you really suggesting to use POST for querying (as the Pace says)?

Sorry, it was my misreading of SPARQL protocol to think that POST was  
necessary. You can also use GET, though that would end up creating  
very large URLs. Not sure if there is a way one could shorten SPARQL  
queries. Perhaps work for a SPARQL extension.

I'll change the Pace.

Henry