Subject: Representing bookmarks

From: Brendan Taylor <[email-masked]>
Date: Fri, 9 Mar 2007 13:12:28 -0700

I'd like to represent bookmarks using Atom, so that I can manipulate
them using the Publishing Protocol.

I discussed this briefly with Aristotle on IRC. He has an XSLT which
transforms del.icio.us into Atom [1]; (the important bit of) the entries
it produces look like this:

  <entry>
    <title>The Atom Syndication Format</title>
    <summary>An alternative to RSS2.</summary>
    <link href="http://www.ietf.org/rfc/rfc4287"/>
    <category term="rfc"/>
  </entry>

(I was thinking along the same lines, but using content/@src instead of
link/@href.)

But he (and now I) is not entirely happy with this solution. 

Linking to the RFC as an alternate representation of the entry suggests
that the entry and the RFC issue from the same source. (ie. if the
entry appears in a feed that lists me as an author it implies that
RFC4287 was written by me)

So, what's the right way?

1: <http://plasmasturm.org/code/delicious-atom/>

---

From: James M Snell <[email-masked]>
Date: Fri, 09 Mar 2007 12:55:10 -0800

For Lotus Connections we're representing bookmarks as....

<entry>
  <id>...</id>
  <title>...</title>
  <author><name>...</name></author>
  <content>...</content>
  <link href="{bookmark url}" />
  <category term="{tag}" />
  <updated>...</updated>
</entry>

This works for everything we need.

- James

---

From: Erwan Loisant <[email-masked]>
Date: Fri, 09 Mar 2007 13:17:06 -0800

> them using the Publishing Protocol.

I'm not sure whether they're doing it "the right way" or not, but
blogmarks.net is APP to manipulate bookmarks; that may be worth checking
it.

http://dev.blogmarks.net/wiki/DeveloperDocs

Erwan

---

From: Sylvain Hellegouarch <[email-masked]>
Date: Fri, 09 Mar 2007 21:41:39 +0000

> http://dev.blogmarks.net/wiki/DeveloperDocs

That's actually a very interesting link. Thanks.

- Sylvain

---

From: "A. Pagaltzis" <[email-masked]>
Date: Fri, 9 Mar 2007 22:51:41 +0100

* Brendan Taylor <[email-masked]> [2007-03-09 21:50]:
> He has an XSLT which transforms del.icio.us into Atom [1]; (the
> important bit of) the entries it produces look like this:
> 
>   <entry>
> (I was thinking along the same lines, but using content/@src
> instead of link/@href.)
> 

For the purpose of discussion, here’s how I’d do that now:

    <entry>
        <title>The Atom Syndication Format</title>
        <link href="http://del.icio.us/url/longhashvaluehere"/>
        <link rel="related" href="http://www.ietf.org/rfc/rfc4287"/>
        <content type="xhtml"><div xmlns="...">
            <a href="http://www.ietf.org/rfc/rfc4287"/>The Atom Syndication Format</a>:
            An alternative to RSS2.
        </div></content>
        <category term="rfc"/>
    </entry>

It bugs me to repeat the link in the content, but the all-around
absence of support for `related` links requires this sort of hack
to make the feed useful with today’s aggregators. Even then, such
a feed would not be useful as a Live Bookmark in Firefox.

Regards,
-- 
Aristotle Pagaltzis // <http://plasmasturm.org/>

---

From: "A. Pagaltzis" <[email-masked]>
Date: Fri, 9 Mar 2007 22:58:23 +0100

* Erwan Loisant <[email-masked]> [2007-03-09 22:40]:
> I'm not sure whether they're doing it "the right way" or not,

Oh yeah, they do. The bookmark is a `related` link, the
`alternate` link points at a page for the link on Blogmarks
itself, and the description, if any, is in `content`. Just as
it should be. They don’t even throw crappy aggregators a bone
by duplicated the bookmark as a link in the content, which is
just as well.

Regards,