Subject: Fwd: I-D ACTION:draft-nottingham-atompub-feed-history-09.txt

From: Mark Nottingham <[email-masked]>
Date: Tue, 24 Apr 2007 12:35:46 +1000

FYI; the only substantial change here is to the Security  
Considerations (as a result of security directorate review).

Diffs at:
http://www.mnot.net/drafts/draft-nottingham-atompub-feed-history/ 
draft-nottingham-atompub-feed-history-09-from-8.diff.html

Begin forwarded message:

> From: [email-masked]
> Date: 24 April 2007 5:50:02 AM
> To: [email-masked]
> Subject: I-D ACTION:draft-nottingham-atompub-feed-history-09.txt
> Reply-To: [email-masked]
>
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
>
>
> 	Title		: Feed Paging and Archiving
> 	Author(s)	: M. Nottingham
> 	Filename	: draft-nottingham-atompub-feed-history-09.txt
> 	Pages		: 17
> 	Date		: 2007-4-23
> 	
> This specification defines three types of syndicated Web feeds that
>    enable publication of entries across one or more feed documents.
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-nottingham-atompub-feed- 
> history-09.txt
>
> To remove yourself from the I-D Announcement list, send a message to
> [email-masked] with the word unsubscribe in the body of
> the message.
> You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
> to change your subscription settings.
>
> Internet-Drafts are also available by anonymous FTP. Login with the
> username "anonymous" and a password of your e-mail address. After
> logging in, type "cd internet-drafts" and then
> "get draft-nottingham-atompub-feed-history-09.txt".
>
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
> Internet-Drafts can also be obtained by e-mail.
>
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE /internet-drafts/draft-nottingham-atompub-feed-history-09.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
>
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> Content-Type: text/plain
> Content-ID: <[email-masked]>
>
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/i-d-announce

--
Mark Nottingham     http://www.mnot.net/

---

From: James M Snell <[email-masked]>
Date: Mon, 23 Apr 2007 21:40:14 -0700

Thank you for the diff.  Looking forward to this being finished.

- James

Mark Nottingham wrote:
> 
> FYI; the only substantial change here is to the Security Considerations
> (as a result of security directorate review).
> 
> Diffs at:
> http://www.mnot.net/drafts/draft-nottingham-atompub-feed-history/draft-nottingham-atompub-feed-history-09-from-8.diff.html
> [snip]

---

From: "Franklin Tse" <[email-masked]>
Date: Tue, 24 Apr 2007 18:53:14 +0800

Two issues found.

In "Example: Atom-formatted Complete Feed", there is no <description> element in Atom 1.0, <subtitle> should be used instead.

<?xml version="1.0" encoding="utf-8"?>
   <feed xmlns="http://www.w3.org/2005/Atom"
    xmlns:fh="http://purl.org/syndication/history/1.0">
    <title>NetMovies Queue</title>
    <description>The DVDs you'll receive next.</description>

Also,

7.2. Informative References

   [RSS2]                          Winer, D., "RSS 2.0 Specification",
                                   2005, <http://blogs.law.harvard.edu/
                                   tech/rss>.

Should the reference be changed to http://www.rssboard.org/rss-specification by the RSS Advisory Board?

Franklin Tse

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 24 Apr 2007 21:08:45 +1000

On 24/04/2007, at 8:53 PM, Franklin Tse wrote:

> Two issues found.
>
> In "Example: Atom-formatted Complete Feed", there is no  
> <description> element in Atom 1.0, <subtitle> should be used instead.
>

Oops; I think you reported this previously, no? Will fix this in AUTH48.

> specification by the RSS Advisory Board?

If someone can point me at a definitive place where Dave Winer cedes  
control of the spec to the RSS Advisory Board, and says that that's  
the new URI to use, I'll change it; I don't really want to dig too  
deep into the morass of RSS politics.

I asked him and didn't get a response, and that's the most widely- 
cited URL out there, according to the search engines; since it's an  
informative reference in any case, it's good enough.

Cheers and thanks,

---

From: "Franklin Tse" <[email-masked]>
Date: Tue, 24 Apr 2007 19:48:19 +0800

> Oops; I think you reported this previously, no? Will fix this in AUTH48.

Ya, I have reported this previously :)

> informative reference in any case, it's good enough.

I have Cc-ed this email to the RSS-Public Mailing List and hopefully there will be an answer.

Thanks,
Franklin Tse

---

From: "James Holderness" <[email-masked]>
Date: Tue, 24 Apr 2007 13:30:57 +0100

> control of the spec to the RSS Advisory Board, and says that that's  the 
> new URI to use, I'll change it; I don't really want to dig too  deep into 
> the morass of RSS politics.

As I understand it, the RSS Advisory Board was pushing for the use of that 
url because the Harvard site was neglected and often  not working. Dave 
never endorsed that url though, and has since done a lot of work setting up 
a new site for the spec, which is probably what you should be using.

New spec url:
http://cyber.law.harvard.edu/rss/rss.html

Dave's announcement of the new site:
http://www.scripting.com/stories/2007/04/13/newRss20SpecSiteDeployed.html

Regards
James

PS: I don't speak for Dave Winer or the RSS Advisory Board. This is just 
MHO.

---

From: Paul Hoffman <[email-masked]>
Date: Tue, 24 Apr 2007 07:31:18 -0700

>Oops; I think you reported this previously, no? Will fix this in AUTH48.

GAAAAH. NO! Fix it now, please. AUTH48 is only for non-technical changes.

>deep into the morass of RSS politics.

+1

---

From: Rogers Cadenhead <[email-masked]>
Date: Sat, 28 Apr 2007 20:37:13 -0700 (PDT)

Regarding the question asked here about the RSS 2.0
specification, the position of the RSS Advisory Board
is that people ought to use the following permanent
URL when linking to the current version of the spec:

http://www.rssboard.org/rss-specification

The board has published the spec since 2003. Dave
Winer resigned from the board in 2004.

Rogers Cadenhead,
RSS Advisory Board chairman