Subject: Fwd: I-D ACTION:draft-nottingham-atompub-feed-history-10.txt

From: Mark Nottingham <[email-masked]>
Date: Tue, 22 May 2007 19:52:19 +1000

FYI. Diffs at:
   http://www.mnot.net/drafts/draft-nottingham-atompub-feed-history/ 
draft-nottingham-atompub-feed-history-10-from-09.diff.html

Changes include;
- text for example of how archived feeds work
- more explanatory abstract
- update previously registered link relations to point to this doc
- expanded security considerations
- removed URI for RSS, as policy discourages use of URIs for  
references (and it's contentious)
- various tweaks and corrections

Cheers,

Begin forwarded message:

> From: [email-masked]
> Date: 22 May 2007 5:50:02 AM
> To: [email-masked]
> Subject: I-D ACTION:draft-nottingham-atompub-feed-history-10.txt
> Reply-To: [email-masked]
>
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
>
>
> 	Title		: Feed Paging and Archiving
> 	Author(s)	: M. Nottingham
> 	Filename	: draft-nottingham-atompub-feed-history-10.txt
> 	Pages		: 18
> 	Date		: 2007-5-21
> 	
> This specification defines three types of syndicated Web feeds that
>    enable publication of entries across one or more feed documents.
>    This includes "paged" feeds for piecemeal access, "archived" feeds
>    that allow reconstruction of the feed's contents, and feeds that  
> are
>    explicitly "complete".
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-nottingham-atompub-feed- 
> history-10.txt
>
> To remove yourself from the I-D Announcement list, send a message to
> [email-masked] with the word unsubscribe in the body of
> the message.
> You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
> to change your subscription settings.
>
> Internet-Drafts are also available by anonymous FTP. Login with the
> username "anonymous" and a password of your e-mail address. After
> logging in, type "cd internet-drafts" and then
> "get draft-nottingham-atompub-feed-history-10.txt".
>
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
> Internet-Drafts can also be obtained by e-mail.
>
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE /internet-drafts/draft-nottingham-atompub-feed-history-10.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
>
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> Content-Type: text/plain
> Content-ID: <[email-masked]>
>
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/i-d-announce

--
Mark Nottingham     http://www.mnot.net/

---

From: "James Holderness" <[email-masked]>
Date: Tue, 22 May 2007 12:38:55 +0100

> draft-nottingham-atompub-feed-history-10-from-09.diff.html

Some of the RSS examples are not valid - unescaped markup in description 
elements.

Regards
James

---

From: "Franklin Tse" <[email-masked]>
Date: Tue, 22 May 2007 20:17:23 +0800

Also, some <guid> and <link> elements do not point to the same URL. This is a bad practice that should not be included in a specification.

The <link> element should be removed or a 'isPermaLink="false"' attribute should be added to the <guid> element.

Franklin

---

From: "James Holderness" <[email-masked]>
Date: Tue, 22 May 2007 14:34:15 +0100

> Also, some <guid> and <link> elements do not point to the same URL. This 
> is a bad practice that should not be included in a specification.
>

At the very least the urn <guid> needs an isPermaLink attribute set to 
false. Using a urn as a permalink is simply not valid.

Regards
James

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 23 May 2007 14:19:15 +1000

Anything else?

On 22/05/2007, at 11:34 PM, James Holderness wrote:

>
>> Also, some <guid> and <link> elements do not point to the same  
>> URL. This is a bad practice that should not be included in a  
>> specification.
>>
>> The <link> element should be removed or a 'isPermaLink="false"'  
>> attribute should be added to the <guid> element.
>
> At the very least the urn <guid> needs an isPermaLink attribute set  
> to false. Using a urn as a permalink is simply not valid.
>
> Regards
> James
>

---

From: "James Holderness" <[email-masked]>
Date: Wed, 23 May 2007 07:27:36 +0100

Nothing that I noticed error wise but, since you asked, I personally think 
it would be clearer if you removed all the optional channel elements 
(language, pubDate, lastBuildDate, docs, generator, managingEditor and 
webMaster) from the RSS examples and made the message content the same as 
the Atom examples. At least I would think changing the links might be a good 
idea (example.org rather than nasa.gov).

Not a big deal though - just a suggestion.

Regards
James

>>> Also, some <guid> and <link> elements do not point to the same  URL. 
>>> This is a bad practice that should not be included in a  specification.
>>>

---

From: "Franklin Tse" <[email-masked]>
Date: Wed, 23 May 2007 14:51:31 +0800

I think lastBuildDate and managingEditor should not be removed since they are equal to atom:updated and atom:author respectively.

Franklin

---

From: "James Holderness" <[email-masked]>
Date: Wed, 23 May 2007 08:37:41 +0100

Franklin Tse wrote:
> I think lastBuildDate and managingEditor should not be
> removed since they are equal to atom:updated and atom:author
> respectively.

I considered that, but it seems to me the only reason they are in the Atom 
examples is because Atom requires those elements - they don't actually add 
anything illustrative to the example. However, if you really want to make 
the examples identical element-for-element, then the Atom feeds should all 
include a subtitle element to match RSS's required channel description. 
IMHO.

Regards
James

---

From: "Franklin Tse" <[email-masked]>
Date: Wed, 23 May 2007 16:22:57 +0800

In section 4.2 of the draft,

   In Atom-formatted archived feeds, two entries are duplicates if they
   have the same atom:id element.  The update time of an entry is
   determined by its atom:updated element, and likewise the update time
   of a feed document is determined by its feed-level atom:updated
   element.

In RSS 2, the equivalent of atom:feed/atom:updated is rss/channel/lastBuildDate. I think it is a good practice to always include it.

By the way, do publishers need to use an atom:id element in RSS 2 feeds since there is no equivalent in RSS 2?

Franklin

---

From: James M Snell <[email-masked]>
Date: Wed, 23 May 2007 01:43:26 -0700

Well, for an RSS feed, it's URL pretty much plays the role of the
identifier*.  An atom:id certainly could be used, but I wouldn't imagine
that any sane implementation would make it anything different than the
URL of the RSS feed itself.

* quite honestly, I've never really understood why atom:feed requires an
  atom:id :-)

- James

Franklin Tse wrote:
> [snip]
> [snip]

---

From: "Franklin Tse" <[email-masked]>
Date: Wed, 23 May 2007 16:51:49 +0800

When the URL of a feed is changed, its atom:id can remain unchanged, and that is assumed to be the same feed theoretically.

(I am not sure if that is the case in the real world)

Franklin

---

From: James M Snell <[email-masked]>
Date: Wed, 23 May 2007 01:56:57 -0700

Yeah, I understand why it can be useful, I just don't know why it's
*required*. Ah well, that proverbial ship has sailed ;-)

---

From: Sam Ruby <[email-masked]>
Date: Thu, 24 May 2007 10:10:51 -0400

> * quite honestly, I've never really understood why atom:feed requires an

For an RSS feed, Venus assumes that the <link> element plays the role of 
an identifier.  Assumes being the operative word.

In RSS (all flavors), channel link is required.  In Atom, feed id is 
required.

In any case, one can have multiple feeds (possibly in different formats) 
all at different URIs all identifying the same thing.

- Sam Ruby

---

From: John Panzer <[email-masked]>
Date: Thu, 24 May 2007 22:10:18 -0700

> all at different URIs all identifying the same thing.

Would these two qualify as having the same IDs (were they Atom)?

http://www.engadget.com/rss.xml
http://www.engadget.com/headlines.xml

-John

---

From: "Franklin Tse" <[email-masked]>
Date: Fri, 25 May 2007 15:03:48 +0800

What would happen if an RSS feed contains atom:id?

Franklin