Subject: Re: I-D ACTION:draft-nottingham-atompub-feed-history-09.txt

From: Mark Nottingham <[email-masked]>
Date: Fri, 11 May 2007 12:47:17 +1000

Thanks, Roger. After looking over the links that Randy and others  
kindly forwarded, consulting with the AD, and hearing nothing from  
Dave, it looks like we'll go with this link.

The citation will look like this;

> [RSS2]                      Winer, D., "RSS 2.0 Specification",
>                                    2005, <http://www.rssboard.org/
>                                    rss-specification>.

On 29/04/2007, at 1:37 PM, Rogers Cadenhead wrote:

>
> Regarding the question asked here about the RSS 2.0
> specification, the position of the RSS Advisory Board
> is that people ought to use the following permanent
> URL when linking to the current version of the spec:
>
> http://www.rssboard.org/rss-specification
>
> The board has published the spec since 2003. Dave
> Winer resigned from the board in 2004.
>
> Rogers Cadenhead,
> RSS Advisory Board chairman
>

--
Mark Nottingham     http://www.mnot.net/

---

From: Sam Ruby <[email-masked]>
Date: Wed, 16 May 2007 09:43:51 -0400

Mark Nottingham wrote:
> 
> Thanks, Roger. After looking over the links that Randy and others kindly 
> forwarded, consulting with the AD, and hearing nothing from Dave, it 
> looks like we'll go with this link.

Did you check Dave's weblog?  He's recently restored, and is actively 
promoting, an alternate link:

http://www.scripting.com/stories/2007/04/30/wikipediaEditing.html

These dueling versions of the RSS 2.0 specification differ in minor 
details (e.g., range of skipHours), major features (permissability 
namespaced attributes on existing RSS elements), and roadmap.

- Sam Ruby

---

From: "A. Pagaltzis" <[email-masked]>
Date: Wed, 16 May 2007 16:50:59 +0200

* Sam Ruby <[email-masked]> [2007-05-16 16:10]:
> Mark Nottingham wrote:
> >Thanks, Roger. After looking over the links that Randy and
> >others kindly forwarded, consulting with the AD, and hearing
> >nothing from Dave, it looks like we'll go with this link.
> 
> Did you check Dave's weblog?  He's recently restored, and is
> actively promoting, an alternate link:
> 
> These dueling versions of the RSS 2.0 specification differ in
> minor details (e.g., range of skipHours), major features
> (permissability namespaced attributes on existing RSS
> elements), and roadmap.

So evidence confirms experience anew: RSS always has involved
politics and always will.

I propose that this spec stay out of it. To me it does not seem
reasonable to take a political stand on behalf of the reader.

So if conceivable, include both links (with a caveat lector if
necessary). Is that a possibility?

Regards,
-- 
Aristotle Pagaltzis // <http://plasmasturm.org/>

---

From: James M Snell <[email-masked]>
Date: Wed, 16 May 2007 08:37:07 -0700

Nothing new and nothing surprising. I'd be happier with removing all
references to RSS in the document.  It's a simple matter to write up a
few blog posts describing the use of the spec with RSS.

- James

---

From: Paul Hoffman <[email-masked]>
Date: Wed, 16 May 2007 09:04:21 -0700

>necessary). Is that a possibility?

Yes, and that is a very good suggestion. Let the reader decide which 
they want to believe.

---

From: "James Holderness" <[email-masked]>
Date: Wed, 16 May 2007 17:40:43 +0100

Sam Ruby wrote:
> These dueling versions of the RSS 2.0 specification differ

They look the same to me. Can you provide some links and/or quotes?

> in minor details (e.g., range of skipHours),

"An XML element that contains up to 24 <hour> sub-elements whose value is a 
number between 0 and 23, representing a time in GMT"

http://www.rssboard.org/skip-hours-days#skiphours
http://cyber.law.harvard.edu/rss/skipHoursDays.html#skiphours

> major features (permissability namespaced attributes on existing RSS 
> elements),

"A RSS feed may contain elements not described on this page, only if those 
elements are defined in a namespace."

http://www.rssboard.org/rss-specification#extendingRss
http://cyber.law.harvard.edu/rss/rss.html#extendingRss

> and roadmap.

"the RSS spec is, for all practical purposes, frozen at version 2.0.1. We 
anticipate possible 2.0.2 or 2.0.3 versions, etc. only for the purpose of 
clarifying the specification"

http://www.rssboard.org/rss-specification#roadmap
http://cyber.law.harvard.edu/rss/rss.html#roadmap

Regards
James

---

From: Tim Bray <[email-masked]>
Date: Wed, 16 May 2007 10:05:08 -0700

On May 16, 2007, at 9:04 AM, Paul Hoffman wrote:

> Yes, and that is a very good suggestion. Let the reader decide  
> which they want to believe.

The IESG's gonna *love* that.  -Tim

---

From: Sam Ruby <[email-masked]>
Date: Wed, 16 May 2007 14:08:45 -0400

> They look the same to me. Can you provide some links and/or quotes?

My apologies.  My terminology was not precise.

This is a stable link:

   http://cyber.law.harvard.edu/rss/rss.html

By stable, I mean that it is the stated intent of the author and the 
hosting organization that this document will not change.

By contrast, this is not a stable link:

"The current version of the RSS spec will always be available at this link"

My read (tell me if you differ) that is it the explicit intention of the 
author and hosting organization to revise that document; and in 
particular has been drafting a significant revision in public:

   http://www.rssboard.org/rss-draft-1

"If adopted, this will become version 2.0.9 of the specification."

In general, I believe that the IETF requires stable links.

- Sam Ruby

---

From: Rogers Cadenhead <[email-masked]>
Date: Wed, 16 May 2007 12:51:53 -0700 (PDT)

There's a stable link to the current RSS 2.0
specification here:

http://www.rssboard.org/rss-2-0-8

This will not change at any point in the future.

The following link will always point to the
most-current version:

http://www.rssboard.org/rss-specification,

--- Sam Ruby <[email-masked]> wrote:
> My read (tell me if you differ) that is it the
> explicit intention of the author and hosting
> organization to revise that document; and in 
 
>    http://www.rssboard.org/rss-draft-1

The draft spec is a proposal that has not been
approved by the RSS Advisory Board.

As it states at the top of that page, "Because this
document has not been adopted by the board, current
implementers should continue to rely on version
2.0.8."

The board has never voted to express an intent to
replace the existing spec. The last time a vote was
called on the draft spec on RSS-Board (our mailing
list), the motion died for lack of a second.

---

From: Paul Hoffman <[email-masked]>
Date: Wed, 16 May 2007 13:18:09 -0700

>In general, I believe that the IETF requires stable links.

s/requires/strongly prefers/

No link is guaranteed stable, but some (such as ones that are hosted 
by people who say they intend to change them in the future) are known 
to be worse.

---

From: James M Snell <[email-masked]>
Date: Wed, 16 May 2007 14:04:29 -0700

In this case the link is not only possibly unstable, it's also under
dispute.  I think it would be best for everyone involved to simply drop
the reference from the document and remove any mention of RSS.

- James

Paul Hoffman wrote:
> No link is guaranteed stable, but some (such as ones that are hosted by
> people who say they intend to change them in the future) are known to be
> worse.
> 
>

---

From: Bill de hOra <[email-masked]>
Date: Thu, 17 May 2007 00:22:12 +0100

James M Snell wrote:
> I'd be happier with removing all
> references to RSS in the document.  

Me too. A few years out, it won't matter.

cheers
Bill

---

From: Sam Ruby <[email-masked]>
Date: Wed, 16 May 2007 20:02:44 -0400

> people who say they intend to change them in the future) are known to be 

These following URIs are purported to be stable and equivalent, modulo 
formatting differences:

http://cyber.law.harvard.edu/rss/rss.html
http://www.rssboard.org/rss-2-0-1-rv-5

- Sam Ruby