Subject: Fw: Atom bidi attribute, empty string value

From: "Franklin Tse" <[email-masked]>
Date: Sun, 13 May 2007 20:28:29 +0800

The following message is sent by Sammy...

James, would you explain it?

Franklin

----- Original Message -----
From: "Sammy" <[email-masked]>
To: "Franklin Tse" <[email-masked]>
Sent: Sunday, May 13, 2007 20:06
Subject: RE: Atom bidi attribute, empty string value

I need to understand something please, why isn't the attribute dir preceded with a namespace prefix?

Example:

<feed xmlns="http://www.w3.org/2005/Atom" xmlns:dirns="http://www.example.org/dir/namepsace" xml:lang="he" dirns:dir="rtl">
..

Regards,
Sammy

---

From: James M Snell <[email-masked]>
Date: Sun, 13 May 2007 09:47:51 -0700

Rather than create a new xml namespace, the bidi spec adds the dir
attribute to the Atom namespace and adds it to the atomCommonAttributes
construct.  Basically, the spec plugs what I think is a hole in the
RFC4287 spec.

- James

---

From: "A. Pagaltzis" <[email-masked]>
Date: Sun, 13 May 2007 21:03:39 +0200

* James M Snell <[email-masked]> [2007-05-13 19:05]:
> Rather than create a new xml namespace, the bidi spec adds the
> dir attribute to the Atom namespace

Attributes never inherit the namespace from any other part of the
infoset, so attributes written without a prefix are always in the
null namespace.

Regards,
-- 
Aristotle Pagaltzis // <http://plasmasturm.org/>

---

From: James M Snell <[email-masked]>
Date: Sun, 13 May 2007 13:52:46 -0700

Well, yeah, sorry for not being concise on that point.  The point was
more that there really was no need for a new namespace for the
attribute. :-)

- James

---

From: Sammy <[email-masked]>
Date: Mon, 14 May 2007 11:41:33 +0300

Is that what the undefinedAttribute says in the spec? Because I really don't get what the local:* part in "attribute* -(xml:base | xml:lang | local:*)" means. In other words, if you wanted to stick to the spec, couldn't you have had dirns:dir instead of just dir: ?

Regards,
Sammy

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of James M Snell
Sent: Sunday, May 13, 2007 11:53 PM
To: atom-syntax
Subject: Re: Fw: Atom bidi attribute, empty string value

- James

---

From: "Franklin Tse" <[email-masked]>
Date: Mon, 14 May 2007 17:52:48 +0800

local: = "" (null namespace)

>> infoset, so attributes written without a prefix are always in the

So, "dir" is valid. What's the problem then?

Also, please note the bidi draft is an update to the atomCommonAttributes section of RFC 4287.

Franklin

---

From: Sammy <[email-masked]>
Date: Mon, 14 May 2007 13:09:36 +0300

undefinedAttribute = attribute * - (xml:base | xml:lang | local:*) { text }

Doesn't this mean that you CAN'T include NEITHER xml:base NOR xml:lang NOR local:* ?

Regards,
Sammy

-----Original Message-----
From: Franklin Tse [mailto:[email-masked]]
Sent: Monday, May 14, 2007 12:53 PM
To: Sammy
Cc: James M Snell; atom-syntax
Subject: Re: Fw: Atom bidi attribute, empty string value

Franklin

---

From: "Franklin Tse" <[email-masked]>
Date: Mon, 14 May 2007 18:31:20 +0800

No, the RELAX NG Compact Schema in RFC 4287 is informative (non-normative).

The bidi draft updates atomCommonAttributes with:

     atomCommonAttributes =
       attribute xml:base { atomUri }?,
       attribute xml:lang { atomLanguageTag }?,
       attribute dir { "ltr" | "rtl" | "" }?,
       undefinedAttribute*

Franklin

----- Original Message -----
From: "Sammy" <[email-masked]>
To: "Franklin Tse" <[email-masked]>
Cc: "James M Snell" <[email-masked]>; "atom-syntax" <[email-masked]>
Sent: Monday, May 14, 2007 18:09
Subject: RE: Fw: Atom bidi attribute, empty string value

Regards,
Sammy

-----Original Message-----
From: Franklin Tse [mailto:[email-masked]]
Sent: Monday, May 14, 2007 12:53 PM
To: Sammy
Cc: James M Snell; atom-syntax
Subject: Re: Fw: Atom bidi attribute, empty string value

Franklin