Subject: Re: New Version Notification for draft-divilly-atom-hierarchy-00

From: Al Brown <[email-masked]>
Date: Wed, 27 May 2009 09:36:02 -0600

I am not sure that thread agrees about prefetching the link and including inside.

It does support the notion of extreme extension or extension beyond planning.

I, personally, think there is an alternative  that does not have the semantic conflict Julian mentioned nor the performance / caching issues with prefetching the link and including.

Best, Al
Sent from BlackBerry.

----- Original Message -----
From: "Nikunj R. Mehta" [[email-masked]]
Sent: 05/26/2009 02:07 PM MST
To: Julian Reschke <[email-masked]>
Cc: Atom-Syntax Syntax <[email-masked]>
Subject: Re: New Version Notification for draft-divilly-atom-hierarchy-00

On May 25, 2009, at 8:42 AM, Julian Reschke wrote:

> with respect to <http://tools.ietf.org/html/draft-divilly-atom-hierarchy-00#section-3 
> >, "Inline Representation of Hierarchical Resources"...
>
> It seems to be that using atom:link as a container elements  
> stretches its semantics of "reference from an entry or feed to a Web  
> resource" too much.

I don't agree with that. A previous discussion on this mailing list  
more than a year ago [1] has already concluded that it is perfectly  
legal to do so. Additionally, the hierarchy-ID approach appears  
similar to the approach taken by the RFC4287 with atom:content usage  
models, where several options about inline and out-of-line content  
delivery are available.

>
>
> As Al pointed out on the CMIS mailing list (<http://lists.oasis-open.org/archives/cmis/200905/msg00186.html 
> >), it may be better to use a container element inside atom:entry.
>
> So, the example in <http://tools.ietf.org/html/draft-divilly-atom-hierarchy-00#section-3.2.3 
> >:
>
>   <atom:entry>
>     <atom:link rel="down"
>       href="/finance/feeds/default/portfolios/1/positions">
>       <atom:feed>
>         <atom:link rel="self"
>          href="/finance/feeds/default/portfolios/1/positions"/>
>          ...
>       </atom:feed>
>     </atom:link>
>     ...
>   </atom:entry>
>
> would become
>
>   <atom:entry>
>     <atom:link rel="down"
>       href="/finance/feeds/default/portfolios/1/positions" />
>     <ah:children>
>       <atom:feed>
>         <atom:link rel="self"
>          href="/finance/feeds/default/portfolios/1/positions"/>
>          ...
>       </atom:feed>
>     </ah:children>
>     ...
>   </atom:entry>
>
> BR, Julian

Nikunj
http://o-micron.blogspot.com

[1] http://www.imc.org/atom-syntax/mail-archive/msg20464.html

---

From: "Nikunj R. Mehta" <[email-masked]>
Date: Thu, 28 May 2009 12:01:40 -0700

Is this (yet another) case of your email client failing? I could not  
make sense of your last para.

Nikunj

On May 27, 2009, at 8:36 AM, Al Brown wrote:

> I, personally, think there is an alternative  that does not have the  
> semantic conflict Julian mentioned nor the performance / caching  
> issues with prefetching the link and including.
>
> Best, Al
> Sent from BlackBerry.
>
>