Subject: A question of RTP palyoad format for MPEG video

From: "CCFang" <[email-masked]>
Date: Sat, 11 Mar 2000 16:17:08 +0800

Dear all

    I have a question about MPEG over RTP.
    RTP timestamp represents the presentation time of MPEG picture of audio frame.
    If B pictures present in stream, it may not be monotonically increasing.
    How do we calculate the "jitter" in this case?

    And the timestamp will the same for all packets that make up a picture or audio frame.
    Should we use the first packet or last packet to calculate the "jitter" ?

Best regards

CCFang

---

From: "CCFang" <[email-masked]>
Date: Sun, 12 Mar 2000 16:13:50 +0800

hi..

    I see a document say that jitter be calculated only on teh first packet of a video frame, or only on "I" frames for MPEG.
    But, how to know it is a "I" frame by RTP layer?

    I am very confused with that RTP is a transport protocol.
   
CCFang
  ----- Original Message ----- 
  From: CCFang 
  To: [email-masked] 
  Sent: Saturday, March 11, 2000 4:17 PM
  Subject: A question of RTP palyoad format for MPEG video

  Dear all

  Best regards

  CCFang

---

From: "Ram Kordale" <[email-masked]>
Date: Sun, 12 Mar 2000 07:18:33 -0800

If you follow RFC 2250 for RTP packetization of MPEG, the MPEG specific header
will contain 3 bits that indicate the picture type.

On Mar 12,  4:13pm, CCFang wrote:
> Subject: Re: A question of RTP palyoad format for MPEG video
>
> [ Attachment (multipart/alternative): 4127 bytes ]
>-- End of excerpt from CCFang

-- 

Ram Kordale
Kasenna Inc.

---

From: "Nam Kyu Kim" <[email-masked]>
Date: Mon, 13 Mar 2000 08:44:52 +0900

Hi CCFang.

There is no need rtp timestamp to increase montonically in calculating jitter, 
because we need only relative difference time between terminals.
And I think it should be the first packet to calculate the jitter.
I am also in the initial stage of implementing RTP, so above is not sure.

Am I right?

Have a nice day..
-----------------------------------------------------
Nam Kyu Kim 
R & D Team 9
Mobile Telecommunication Terminal Division
HYUNDAI ELECTRONICS INDUSTRIES Co., Ltd.

TEL : (82-2)580-5511       FAX : (82-2)580-5487
Home : (82-2)2282-3077   C.P. : 017-211-3077
E-mail : [email-masked]
-----------------------------------------------------
  Dear all

  Best regards

  CCFang