Subject: Re: I-D ACTION:draft-ietf-avt-rtp-cn-00.txt

From: "Hari Krishna Vuppaladhadiam" <[email-masked]>
Date: Thu, 9 Mar 2000 10:45:53 -0800

Hi everyone,

   Are there any standards to generate CNG for the listed codecs like G711,
G726 etc.. Can anyone show some pointers to it?

Thanks
Hari

-----Original Message-----
From: [email-masked] <[email-masked]>
To: IETF-Announce: ; <IETF-Announce: ;>
Cc: [email-masked] <[email-masked]>
Date: Thursday, March 09, 2000 3:43 AM
Subject: I-D ACTION:draft-ietf-avt-rtp-cn-00.txt

>A New Internet-Draft is available from the on-line Internet-Drafts
directories.
>This draft is a work item of the Audio/Video Transport Working Group of the
IETF.
>
> Title : RTP Payload for Comfort Noise
> Author(s) : R. Zopf
> Filename : draft-ietf-avt-rtp-cn-00.txt
> Pages : 6
> Date : 08-Mar-00
>
>This document describes an RTP [2] payload format for transporting
>comfort noise (CN).  The CN payload type is primarily for use with
>audio codecs that do not support comfort noise as part of the codec
>itself such as ITU-T Recommendations G.711 [3], G.726 [4], G.727
>[5], G.728 [6], and G.722 [7].
>
>A URL for this Internet-Draft is:
>http://www.ietf.org/internet-drafts/draft-ietf-avt-rtp-cn-00.txt
>
>Internet-Drafts are also available by anonymous FTP. Login with the
username
>"anonymous" and a password of your e-mail address. After logging in,
>type "cd internet-drafts" and then
> "get draft-ietf-avt-rtp-cn-00.txt".
>
>A list of Internet-Drafts directories can be found in
>http://www.ietf.org/shadow.html
>or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
>
>Internet-Drafts can also be obtained by e-mail.
>
>Send a message to:
> [email-masked].
>In the body type:
> "FILE /internet-drafts/draft-ietf-avt-rtp-cn-00.txt".
>
>NOTE: The mail server at ietf.org can return the document in
> MIME-encoded form by using the "mpack" utility.  To use this
> feature, insert the command "ENCODING mime" before the "FILE"
> command.  To decode the response(s), you will need "munpack" or
> a MIME-compliant mail reader.  Different MIME-compliant mail readers
> exhibit different behavior, especially when dealing with
> "multipart" MIME messages (i.e. documents which have been split
> up into multiple messages), so check your local documentation on
> how to manipulate these messages.
>
>
>Below is the data which will enable a MIME compliant mail reader
>implementation to automatically retrieve the ASCII version of the
>Internet-Draft.
>

---

From: Robert Zopf <[email-masked]>
Date: Thu, 09 Mar 2000 14:35:31 -0500

Hari,

There is no mechanism defined for the codecs listed in the draft (ex. 
G.711, G.726, G.727, G.728, and G.722).  The new appendix to G.711 
describes a CNG algorithm which MAY be used with the defined CN 
payload.  This algorithm was tested with G.711 (again, see the appendix for 
a description of how it was tested) and found to give equivalent quality to 
G.711 without CNG.  The CNG algorithm is of course only a part of it, you 
also need a VAD algorithm and DTX algorithm, all of which contribute to the 
overall quality.  In the test, the VAD/DTX from G.729 was used, but others 
are possible.  The CNG algorithm described could also be used with the 
other codecs, but this was not tested within the ITU.  The idea of the 
payload and example algorithm was that they are generic, and may be used 
with any codec without a defined CNG mechanism.

The appendix should be published and available from the ITU soon.  It was 
just approved in February, and I am not sure of their turn-around time on 
such documents.

Rob.

> >implementation to automatically retrieve the ASCII version of the

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Rob Zopf
Principal Engineer
Speech Technology Group
Lucent Technologies, INS

Phone 	: (732) 578-3207
Fax		: (732) 578-3213
Email		: [email-masked]
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~