Subject: VoIP & packet loss

From: Massimo Fubini <[email-masked]>
Date: Sun, 2 Jul 2000 15:27:20 +0200

I'm working on the influence of network condition on the perceived
quality of a VoIP "telephone" call.

I would like to know if there are studies on how the distribution of
packet loss (not only the average packet loss, but the complete
distribution ) influence the perceived quality of a VoIP call.

Best regards,
 Massimo Fubini                         mailto:[email-masked]

University of Rome La Sapienza - Netlab CNR

---

From: Orion Hodson <[email-masked]>
Date: Mon, 03 Jul 2000 11:20:32 +0100

> distribution ) influence the perceived quality of a VoIP call.

Checkout Henning Schulzrinne's netbib http://www.cs.columbia.edu/~hgs/netbib/

Some references get started...

@InProceedings{bolot93,
  author =	 {Jean-Chrysostome Bolot},
  title =	 {End-to-End Packet Delay and Loss Behaviour in the Internet},
  booktitle =	 {Proceedings of {ACM SIGCOMM'93}},
  year =	 1993,
  month =	 {September},
  pages =	 {289-298}
}

@INPROCEEDINGS{Bolo9603:Control,
  AUTHOR="Bolot, Jean-Chrysostome and Garcia, Andres Vega",
  TITLE="Control Mechanisms for Packet Audio in the {Internet}",
  BOOKTITLE=infocom,
  ADDRESS="San Fransisco, California",
  DAY="24--28",
  MONTH=mar,
  YEAR=1996
}

@InProceedings{Bore98:Loss,
  author =  {M. S. Borella and D. Swider and S. Uludag and and G. B. Brewster},
  title =	 {Internet Packet Loss: Measurement and Implications for End-to-End {QoS}},
  booktitle =	 {Proceedings, International Conference on Parallel Processing},
  year =	 1998,
  month =	 {August}
}

@INPROCEEDINGS{Yajn9903:Measurement,
  AUTHOR="Yajnik, Maya and Moon, Sue and Kurose, Jim and Towsley, Don",
  TITLE="Measurement and Modelling of the Temporal Dependence in Packet Loss",
  BOOKTITLE=infocom,
  ADDRESS="New York",
  DAYS="23--25",
  MONTH=mar,
  YEAR=1999
}

M. S. Borella, "Measurement and Interpretation of Internet Packet
Loss," Journal of Communications and Networking,
Jun. 2000. (http://home.xnet.com/~cathmike/MSB/pubs/jcnloss.ps)

Related stuff

Vern Paxson's measurements:
	http://www.aciri.org/vern/papers.html

Chapter on Mbone Performance
@PhdThesis{Hand9708:Thesis,
  author =	 {Mark Handley},
  title =	 {On Scaleable Internet Multimedia Conferencing Systems},
  school =	 {Department of Computer Science},
  year =	 1997,
  address =	 {University College London},
  type =	 {Ph.D.}
}

Kind Regards
- Orion.

---

From: Henning Sanneck <[email-masked]>
Date: Mon, 03 Jul 2000 14:52:19 +0200

> > distribution ) influence the perceived quality of a VoIP call.
I'd like to add two useful references on loss metrics to Orion's list:

@TECHREPORT{JIA99,
        AUTHOR = {W. Jiang and H. Schulzrinne},
        TITLE = {QoS Measurement of Internet Real-Time Multimedia Services},
        INSTITUTION = {Columbia University},
        YEAR = 1999,
        TYPE = {{Technical} {Report}},
        NUMBER = {CUCS-015-99},
        MONTH = {December} }

@inproceedings{MIY98,
        AUTHOR = {T. Miyata and H. Fukuda and S. Ono},
        TITLE = {New Network {QoS} measures for {FEC}-based Audio
                  Applications on the {Internet}},
        BOOKTITLE = {Proceedings IEEE IPCCC 1998},
        YEAR = 1998,
        PAGES = {355-362},
        ADDRESS = {Tempe/Phoenix, AZ, USA},
        MONTH = {February} }

In a recent paper [Sann0001:Speech-FEC] we have characterized the behaviour 
of a particular speech codec (G.729) under packet loss in terms of the 
packet-level metrics of [bolot93] (Gilbert model) linked to objective speech
quality metrics (P.861A and EMBSD). While the decoder is relatively 
insensitive to bursty losses (as described by the conditional loss 
probability of the Gilbert model), the perceived quality breaks down for
losses within unvoiced/voiced transitions within the speech signal. We
have concluded that the effect of loss distribution on perceived quality is
significant, it is codec-dependent and it cannot necessarily be fully 
described building just on simple metrics like those of the Gilbert model.

@inproceedings{Sann0001:Speech-FEC,
        AUTHOR = {H. Sanneck and N. Le},
        TITLE = {Speech Property-Based {FEC} for {Internet} {Telephony} Applications},
        BOOKTITLE = {Proceedings of the SPIE/ACM SIGMM Multimedia Computing and Networking
Conference (MMCN)},
        YEAR = 2000,
        ADDRESS = {San Jose, CA},
        PAGES = {38-51},
        MONTH = {January},
        NOTE = {ftp://ftp.fokus.gmd.de/pub/glone/papers/Sann0001:Speech-FEC.ps.gz}
}
>   booktitle =    {Proceedings of {ACM SIGCOMM'93}},

Regards

-- Henning 

________________________________________________________________________
           Henning Sanneck

           Research Institute for Open Communication Systems
           GMD FOKUS, Kaiserin-Augusta-Allee 31, D-10589 Berlin, Germany
Phone    : ++49 / (0)30 / 34 63 - 71 75
Fax      : ++49 / (0)30 / 34 63 - 81 75
e-mail   : [email-masked]
WWW      : http://www.fokus.gmd.de/usr/sanneck
________________________________________________________________________