Subject: RE: Voice Playout for VoATM

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 20 Sep 2000 14:29:32 -0400

There is no simple answer for VoATM, as the underlying
ATM network has mechanisms to control transmission characteristics the
affect jitter.  With ATM, one can maintain Stratum 2 timing
end to end and not need much jitter buffer.  Of course, one
can also use UBR, and be under the same basic position that
VoIP is.

I usually tell folks "less, how much less depends on what
you are doing".

Brian

> -----Original Message-----
> From: Hari Krishna Vuppaladhadiam [mailto:[email-masked]]
> Sent: Wednesday, September 20, 2000 1:22 PM
> To: Rosen, Brian; [email-masked]
> Subject: Re: Voice Playout for VoATM 
> 
> 
> Thanks Brian for the information.
> 
> I am trying to capture the differences as per the jitter 
> buffer requirements
> for VoIP and VoATM case. How does it differ for these two?
> 
> Regards
> Hari V
> 
> -----Original Message-----
> From: Rosen, Brian <[email-masked]>
> To: 'Hari Krishna Vuppaladhadiam' <[email-masked]>; 
> [email-masked]
> <[email-masked]>
> Date: Wednesday, September 20, 2000 6:11 AM
> Subject: RE: Voice Playout for VoATM
> 
> 
> >You wouldn't use RTP for VoATM except for a case of VoIP over ATM.
> >So, I suspect this group can't help you much.
> >
> >The ATM Forum has some specs on carrying voice.  The most recent
> >is the BLES spec for VoDSL, which is ATM AAL2 based.
> >The Q.BICC work in ITU covers VoATM using an extension to ISUP
> >to carry an NSAP address.
> >
> >H.323 in ITU offers Annex C, which is an AAL5 VoATM bearer.
> >
> >Finally, there is work in MMUSIC to extend SDP to include
> >ATM bearers, which would allow SIP, MEGACO and MGCP to
> >support VoATM. MEGACO (H.248) has VoATM support in the
> >"native" tags media format using binary encoding.  The SDP
> >work extends similar support for text encoding.
> >
> >Brian
> >
> >> -----Original Message-----
> >> From: Hari Krishna Vuppaladhadiam [mailto:[email-masked]]
> >> Sent: Tuesday, September 19, 2000 9:07 PM
> >> To: [email-masked]
> >> Subject: Voice Playout for VoATM
> >>
> >>
> >> Hi,
> >>   I am looking for Voice playout schemes for VoATM. Are there any
> >> references?
> >> hari
> >>
> >>
> >>
> >
> 
>

---

From: Jon Crowcroft <[email-masked]>
Date: Thu, 21 Sep 2000 08:19:35 +0100

In message <[email-masked]

 >>can also use UBR, and be under the same basic position that

right - you can run VOIP with 40 byte rtp+udp+ip headers over a TDM
network, and get whatever bit level jitte the TDM net guarantees, or
at the other weirder extreme, you can run PCM voice in ATM cells in
cells-in-frames on an ethernet - then you get absolutely nada in the
way of jitter control.....
 
 >>I usually tell folks "less, how much less depends on what

usually less, but see above...

 >>> >>   I am looking for Voice playout schemes for VoATM. Are there any

 cheers

   jon

---

From: Jon Crowcroft <[email-masked]>
Date: Fri, 22 Sep 2000 08:35:25 +0100

after a chat with orion hodson and dimitris terzis here who've done
lots of voice of ip and atm:

2 more important consequences of playout for ATM versus IP

1/ native atm never re-orders packets - IP frequently does - this adds
to the playout for an IP receiver potentially in odd ways  - the
re-ordering statistcs are not necessarily distributed the way that jitter is
distributed when causesd by statistical multiplexing so algoruithms
based on assu,mptions about that distribution (e.g. rolling averasge
+ some number times the variance of inter-arrival times) might not
accomoadate this well, whereas ATM wont have this problem

2/ there's a strong incentive not to go for packetisation larger than
a single cell in native atm, whereas in ip there's nothing to stop ou
picking anything up to an mtu really - this leads to sender side
delays in sampling and packetising and serialising the packet for
transmission from an IP box - all of these may be subject to
operating system scheduling effects too (see papre by kouvelas on
cushioning these, or henning schulzrinnes work way back on various
band pass filter ways of remioving these glitches) - again, vice on
atm would be more like to be written device to device, and a cell
payload at a time, so much less susceptible 

so basically, voice on atm playout is easier than voip, once you can
swallow the idea of using ATM :-)

 cheers

   jon

---

From: "Dr. Carsten Bormann" <[email-masked]>
Date: Fri, 22 Sep 2000 13:31:17 +0200

> [...] vice on atm [...]

Is there an RFC for vice on ATM?

Gruesse, Carsten

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 22 Sep 2000 09:29:03 -0500

> Is there an RFC for vice on ATM?

it be rc01.xt at ftp.iet.og

-- 
Brian F. G. Bidulock
[email-masked]