Subject: RE: AHG comments on draft-ietf-avt-rtp-mpeg4-es-03 in response to the last call

From: "Narasimhan, Sam (SD-EX)" <[email-masked]>
Date: Tue, 12 Sep 2000 15:36:18 -0400

Colin,

 In this mode, if the sender wants to reach both the
'generic format receiver' and 'mpeg4-es-03.txt receiver', 
then he has to use the same payload type. If payload format 
for the generic format differs from mpeg4-es-03.txt draft, 
then the sender has to use 2 different payload types, which 
does not seem to be possible in multicast.

 If mpeg4-es-03.txt included the header with no processing
requirement, then the 'generic format' draft could use the
same payload type as this draft. The generic format would
define the content of adaptation fields that future receivers
that support this will understand. The sender can author
content that will play on both the receivers (slightly
different from each other) using the same payload type.
This is what Jan has been suggesting. This is similar to
many 'scalable' modes where same content can play on
low end and high end players. Low end players play the base
layer and parse over or ignore the enhancement layers while
high end players enhance the decoded presentation with the
enhancement layers. The adaptation field gives the capability
to include such enhancements later without breaking the
base layer (at little extra complexity).

Best Regards
Sam Narasimhan
Motorola 

-----Original Message-----
From: Colin Perkins [mailto:[email-masked]]
Sent: Tuesday, September 12, 2000 12:11 PM
To: Kris Huber
Cc: Luthra, Ajay (SD-EX); 'Zvi Lifshitz'; [email-masked]';
[email-masked]; [email-masked]
Subject: Re: AHG comments on draft-ietf-avt-rtp-mpeg4-es-03 in response
to the last call

--> Kris Huber writes:
>Hello Colin,
>
>I'm a bit confused.  It seems to me that one or more of these assumptions
>must be wrong:
>- that multicast involves one-way communication from one sender to many
>  receivers
>- 'dynamic negotiation' (of payload type in this case) requires two-way
>  communication.
>
>Perhaps the precise technical definition of 'negotiate' in this case is
what
>I lack.  The definition of the word as generally used seems to require
>two-way communication (A talks to B, B replies to A, A replies back, etc.,
>until they converge to agreement).
>
>Thanks for any clarification,

In the typical "mbone conference" style of multicast, the sender advertises
that a named payload format is using a particular payload type. There's no
negotiation (and none needed, since payload type numbers are local to a 
session).

Colin

---

From: Colin Perkins <[email-masked]>
Date: Tue, 12 Sep 2000 15:43:18 -0400

Sam,

>does not seem to be possible in multicast.

Why not? 

>base layer (at little extra complexity).

How are the enhancements signalled? 

Colin