Subject: Re: LATM specified in a public MPEG document?

From: John Lazzaro <[email-masked]>
Date: Wed, 20 Sep 2000 11:26:17 -0700

[ Bodo Teichmann <[email-masked]> writes] 

> LATM was actually developed for only "natural"  audio coders, 
> i.e. not fo Structured Audio. it is not possible to transmitt
> multiple objects, no scene desctipion  and no time stamps
> can be transmitted . in your case you  better should  either use
> SyncLayer packets (thats an Acess unit with a Sync Layer header)
> with rtp or use flexmux with rtp. but both options are just
> drafts at the moment.

Thanks for the info, it sounds like the earlier suggestions I
made on the draft-ietf-avt-rtp-mpeg4-es-04.txt document about
Structured Audio issues, which made it into the current draft,
are inappropriate, since they assume the header described in
"4.1 RTP Packet Format" is meant for all audio, not only 
"natural" audio. Perhaps the I-D should simply state that 
Structured Audio isn't currently transportable over any of 
the packet formats described in the document.  

I'm currently prototyping using SA_access_units for MIDI 
messages for low-latency "jam session" sorts of applications,
and its becoming apparent that a SA-specific profile for RTP
(particularly RTCP) may have enough value to simply pursue
it as an another valid packetization scheme, described as an
I-D -- the draft-singer-mpeg4-ip-00.txt states that these
application-specific packetization schemes are appropriate
complements to the major ones like draft-ietf-avt-rtp-mpeg4-es-04.txt.

-------------------------------------------------------------------------
John Lazzaro -- Research Specialist -- CS Division -- EECS -- UC Berkeley
lazzaro [at] cs [dot] berkeley [dot] edu     www.cs.berkeley.edu/~lazzaro
-------------------------------------------------------------------------

---

From: "Toshiyuki Nomura" <[email-masked]>
Date: Thu, 21 Sep 2000 11:52:12 +0900

Dear John and Bodo,

> the packet formats described in the document.  

Simple SA session without scene description can be realized
by the LATM-based RTP specification.

Therefore, I'll modify the current draft to claim
"Since LATM has no funciton to handle scene description,
Structured Audio with scene description MUST NOT be 
transported using RTP packetization specified in 
this document".

Best Regards,

Toshiyuki Nomura, NEC
--------------------------

---

From: Ralph Sperschneider <[email-masked]>
Date: Thu, 21 Sep 2000 21:56:01 +0200

Dear Toshiyuki,

> by the LATM-based RTP specification.

Are these facts already stated within the current LATM description? We otherwise would now have the chance to clear these matters by means of the Corrigendum (deadline is the end of September).

Best regards,

Ralph

-- 
Dipl.-Ing. Ralph Sperschneider  | Phone: +49 9131 776 344
FhG IIS-A                       | Fax:   +49 9131 776 398
Am Weichselgarten 3             | mailto:[email-masked] 
D 91058 Erlangen                | http://www.iis.fhg.de/amm/

Facts do not cease to exist because they are ignored. (Aldous Huxley)