Subject: Types of MPEG-4 streams over IP

From: [email-masked]
Date: Thu, 21 Sep 2000 14:25:05 +0200

Dear all,

I would like to verify my understanding on the types of MPEG-4 streams that
need tools for transport over IP. I summarized my understanding by the
following list :

- ObjectDescriptorStream
- ClockReferenceStream (is this needed over IP ?)
- SceneDescriptionStream
- VisualStream (with and without use of MPEG-4 Systems)
- AudioStream (with and without use of MPEG-4 Systems)
- MPEG-7Stream
- IPMPStream
- ObjectContentInfoStream
- FlexMux stream
- MP4 file

For MP4 files only a standard MIME type is required. For all other streams
also use of RTP and SDP need to be defined. Please correct me if I am wrong.

The framework document (Singer et al) indicates that also a MIME type is
needed for an MPEG-4 MuxCodeTable. Is this required indeed, or can we assume
(/require) that the MuxCodeTable is transported inside the same FlexMux
stream (in a packet with simple mode). This could provide an easy solution
for the timing of applicability of the table that would need to be resolved
otherwise when using e.g. HTTP; however it would require MuxCodeTable to
become a new entry in the table for streamType values, right ?

Regards,

Jan

************************
Jan van der Meer
Philips - Digital Networks
Building OAN-4
P.O. Box 80002
5600 JB Eindhoven
The Netherlands
Phone +31 402 735 774
Fax +31 402 735 545
Email [email-masked]
************************

---

From: "Kuntal D. Sampat" <[email-masked]>
Date: Fri, 22 Sep 2000 08:17:51 +0530 (IST)

Jan,
isn't the "ERROR_PROTECTION_STREAM" (from 14496-3/Amd.1:1999 Part 3, 
Section 9, pp. 124), which is the error protected audio stream also a
unique streamType?

-Kuntal.

DSP Group,
Motorola, India.

---

From: Dave Singer <[email-masked]>
Date: Fri, 22 Sep 2000 11:34:30 -0700

>become a new entry in the table for streamType values, right ?

The MuxCodeTable needs to be delivered out-of-band.  If you see my 
proposal, it was to deliver this via a URL in SDP, which then 
requires a MIME type if HTTP or DATA are to be used.
-- 
David Singer
Apple Computer/QuickTime