Subject: RE: AHG comments on draft-ietf-avt-rtp-mpeg4-es-03 in response to the last call

From: "Narasimhan, Sam (SD-EX)" <[email-masked]>
Date: Tue, 12 Sep 2000 12:20:37 -0400

Zvi,

 I am assuming that the payload type from the future draft
could be set to the same value as this draft, if this
draft can accommodate the change.

Regards
Sam Narasimhan
Motorola

-----Original Message-----
From: Zvi Lifshitz [mailto:[email-masked]]
Sent: Tuesday, September 12, 2000 10:18 AM
To: Narasimhan, Sam (SD-EX); [email-masked]'
Cc: [email-masked]; [email-masked]
Subject: RE: AHG comments on draft-ietf-avt-rtp-mpeg4-es-03 in response
to the last call

[Narasimhan, Sam (SD-EX):]

If this draft were to say that receivers should parse over the
adaptation bytes and not process them (as this draft does not
define these), then such receivers will be able to process payload
from future draft (from MPEG)

[Reply:]

They will not, because they don't know the payload type of the future draft
therefore they will not know they can process payloads from the future draft
even though they can.

If they know, they also know that the future draft has extra header info. So
work on the future draft, not on the current draft.

Regards,

z
soon the whole world will STREAM
==================================================================
Zvi Lifshitz				Phone +972(2)679-4788
[email-masked]			Fax +972(2)679-4789
Optibase Ltd.				Mobile: +972(53)461-787
http://www.optibase.com		US voice mail/fax  +1(206) 888-4149
Send SMS from: 			http://isend.cellcom.co.il/English/Login.htm
==================================================================
> Come see us at:
Streaming Media Europe Earls Court Centre, Booth # 628, London, October
10th-12th, 2000

---

From: Colin Perkins <[email-masked]>
Date: Tue, 12 Sep 2000 13:19:53 -0400

>draft can accommodate the change.

The payload type will have to be negotiated out of band anyway, there will
be no more static payload type assignments. Since there must be negotiation
having this extra byte in the payload format makes no sense.

Colin

---

From: "Young-Kwon LIM" <[email-masked]>
Date: Fri, 15 Sep 2000 01:51:21 +0900

Dear Colin and all,

> having this extra byte in the payload format makes no sense.

I'd like to be more clear on this point. The payload type of MPEG-4 ES over RTP bitstream and MPEG-4 SL over RTP bitstream can have the same tayload type semantically. Right?

Sincerely,
Young.

---

From: Colin Perkins <[email-masked]>
Date: Thu, 14 Sep 2000 14:07:39 -0400

--> Young-Kwon LIM writes:
>I'd like to be more clear on this point. The payload type of MPEG-4 ES
>over RTP bitstream and MPEG-4 SL over RTP bitstream can have the same
>payload type semantically. Right?

I don't understand your question. If the formats are different, they will
have different MIME types. What payload type those MIME types are mapped
to is not relevent.

Colin