Subject: Re: Types of MPEG-4 streams over IP

From: Viswanathan Swaminathan <[email-masked]>
Date: Thu, 21 Sep 2000 12:18:08 -0700 (PDT)

Jan,

In your list you missed MPEG-J Streams.

Regards,
Vishy

> X-Authentication-Warning: advent.ctr.columbia.edu: mjrdomo set sender to 
[email-masked] using -f
> From: [email-masked]
> To: <[email-masked]>, <[email-masked]>
> Subject: Types of MPEG-4 streams over IP
> Date: Thu, 21 Sep 2000 14:25:05 +0200
> MIME-Version: 1.0
> Content-Disposition: inline
> Content-Transfer-Encoding: 8bit
> X-MIME-Autoconverted: from quoted-printable to 8bit by advent.ctr.columbia.edu 
id IAA24511
> 
> Dear all,
> 
> I would like to verify my understanding on the types of MPEG-4 streams that
> need tools for transport over IP. I summarized my understanding by the
> following list :
> 
> - ObjectDescriptorStream
> - ClockReferenceStream (is this needed over IP ?)
> - SceneDescriptionStream
> - VisualStream (with and without use of MPEG-4 Systems)
> - AudioStream (with and without use of MPEG-4 Systems)
> - MPEG-7Stream
> - IPMPStream
> - ObjectContentInfoStream
> - FlexMux stream
> - MP4 file
> 
> For MP4 files only a standard MIME type is required. For all other streams
> also use of RTP and SDP need to be defined. Please correct me if I am wrong.
> 
> The framework document (Singer et al) indicates that also a MIME type is
> needed for an MPEG-4 MuxCodeTable. Is this required indeed, or can we assume
> (/require) that the MuxCodeTable is transported inside the same FlexMux
> stream (in a packet with simple mode). This could provide an easy solution
> for the timing of applicability of the table that would need to be resolved
> otherwise when using e.g. HTTP; however it would require MuxCodeTable to
> become a new entry in the table for streamType values, right ?
> 
> Regards,
> 
> Jan
> 
> ************************
> Jan van der Meer
> Philips - Digital Networks
> Building OAN-4
> P.O. Box 80002
> 5600 JB Eindhoven
> The Netherlands
> Phone +31 402 735 774
> Fax +31 402 735 545
> Email [email-masked]
> ************************
> 
> 

------------------------------------------------------
Viswanathan Swaminathan
Sun Microsystems Inc. 
901 San Antonio Road, M/S UMPK15-214  
Palo Alto, California  94303

Tel:(650) 786 4258     Fax:(650) 786 6445
email: [email-masked],  [email-masked]

---

From: [email-masked]
Date: Fri, 29 Sep 2000 10:47:57 +0200

Dear Kuntal, all,

Kuntal wrote :
isn't the "ERROR_PROTECTION_STREAM" (from 14496-3/Amd.1:1999 Part 3,
Section 9, pp. 124), which is the error protected audio stream also a
unique streamType?

I contacted our audio expert Ralf Funken and he gave the reply below. My
conclusion : an error protection stream is a special audio stream as
signaled in the AudioSpecificInfo. It is not another type of stream that
contains audio and consequently there is no need for another unique
streamType.

Kind regards,

Jan

---------------------------

The Error Protection (EP) tool in MPEG-4 Audio Version 2 acts as an
intermediate operation between the audio core coder and the MPEG-4 Systems
multiplexer. Each audio elementary stream coming from the audio encoder is
packed by the EP-tool (like adding CRC checks, applying interleaving,
applying FEC coding etc.) and transferred to the multiplexer. All
information required to decode the EP protected audio stream is contained in
the packed EP elementary stream itself; there is no specific channel for EP
side-information or whatsoever.

The usage of the EP-tool is signaled by the AudioSpecificInfo data (this is
the audio-related header information which is transmitted at the start of
each elementary stream). In the AudioSpecificInfo, the epConfig field
signals if and how the EP-tool must be used.

The use of the EP-tool does not affect the audio object type indication in a
stream. The audio object type determines the audio encoding/decoding
algorithm. Whether you use EP or not is signaled separately, see above.

The indication of profile@level defines limits on whether a MPEG-4 receiver
must implement the EP-decoder or not. Some levels allow the EP-tool to be
used, others do not.

---------------------------

************************
Jan van der Meer

-----Original Message-----
From:	[email-masked] [mailto:[email-masked]]
Sent:	vrijdag, 22 september, 2000 04:51
To:	Jan vanderMeer
Cc:	[email-masked]; [email-masked]
Subject:	Re: Types of MPEG-4 streams over IP

Jan,
isn't the "ERROR_PROTECTION_STREAM" (from 14496-3/Amd.1:1999 Part 3,
Section 9, pp. 124), which is the error protected audio stream also a
unique streamType?

-Kuntal.

DSP Group,
Motorola, India.