Subject: Re: Types of MPEG-4 streams over IP

From: [email-masked]
Date: Thu, 5 Oct 2000 10:08:11 +0200

[email-masked] wrote:

> Dear Jan and all,
>
> >Can we assume that the following streams are probably most efficiently
> >contained in a FlexMux stream, and consequently that is no need to specify
> >use of RTP and SDP for those streams:
> >
> >- ObjectDescriptorStream
> >- ClockReferenceStream
> >- SceneDescriptionStream
> >- MPEG-7Stream
> >- IPMPStream
> >- ObjectContentInfoStream
> >- MPEGJStream
>
> In my opinion, those streams should be carried on a reliable channel
> rather than RTP.

I wish that was possible too, however ...

In a truly scalable distribution architecture
you must use connectionless protocols.

RTP on UDP multicast is the key candidate.

NB: Retransmission of lost data requires a return channel
that is not always present and if it were present
would probably be not very scalable so forget
about absolute reliability too, repetition (and FEC)
are what we have to make sure can work

Therefore scalable broadcast requires RTP transport
of ALL these streams as well as SDP in repeated SAP packets.

>
>
> What I am not sure is the scene description stream.
> There are two kind of the scene description stream, one is BIFS-update
> and another is BIFS-Anim.  In my understanding, BIFS-Anim should
> be streamed like audio/visual streams.
>

Same thing for both, must be possible to broadcast them too.

Regards,

--
Philippe Gentric
Software Architect
PHILIPS DIGITAL NETWORKS
Broadcast & Internet Delivery Solutions
Laboratoires d'Electronique Philips
B.P. 15 - 22, Av. Descartes
94453 Limeil-Brevannes Cedex France
Phone  :   33 (0)1 45 10 68 12
Fax    :   33 (0)1 45 10 69 60
[email-masked]

---

From: Colin Perkins <[email-masked]>
Date: Thu, 05 Oct 2000 08:38:26 -0400

>of ALL these streams as well as SDP in repeated SAP packets.

...or some form of reliable multicast. You will never get 100% reliability
from RTP, whereas there are reliable multicast protocols which achieve this
with no backchannel. See the work ongoing in the IETF RMT working group.

I'm very nervous about the use of RTP here - it's NOT appropriate for
reliable transport.

Colin