Subject: RE: Types of MPEG-4 streams over IP

From: [email-masked]
Date: Wed, 4 Oct 2000 11:38:00 +0200

Dominique, all,

Dominique wrote:
*******so, to my understanding, at least:
 3 streams are missing: Flexmux steeams, SL steams & MP4 file streams

A few comments :
1) I don't think that SL stream is an additional stream type; in my view SL
streams are included in the stream types that use MPEG-4 systems.
2) The wording MP4 file stream is confusing; I don't think there is a need
to "stream" an MP4 file; instead only a mime type is needed for file
transfer.

A question : for which streams we need to specify use of RTP and SDP ? In my
understanding for :

- VisualStream (with and without use of MPEG-4 Systems)
- AudioStream (with and without use of MPEG-4 Systems)
- FlexMux stream

Can we assume that the following streams are probably most efficiently
contained in a FlexMux stream, and consequently that is no need to specify
use of RTP and SDP for those streams:

- ObjectDescriptorStream
- ClockReferenceStream
- SceneDescriptionStream
- MPEG-7Stream
- IPMPStream
- ObjectContentInfoStream
- MPEGJStream

Regards,

Jan

-----Original Message-----
From:	[email-masked]
[mailto:[email-masked]]
Sent:	woensdag, 04 oktober, 2000 10:39
To:	[email-masked]; [email-masked]
Cc:	[email-masked]; Jan vanderMeer;
[email-masked]
Subject:	RE: Types of MPEG-4 streams over IP

dear all,

*********Jan proposed:
- ObjectDescriptorStream
- ClockReferenceStream (is this needed over IP ?)
- SceneDescriptionStream
- VisualStream (with and without use of MPEG-4 Systems)
- AudioStream (with and without use of MPEG-4 Systems)
- MPEG-7Stream
- IPMPStream
- ObjectContentInfoStream
- FlexMux stream
- MP4 file

*****Olivier found in V2 :
0x00 Forbidden
0x01 ObjectDescriptorStream (see 8.5)
0x02 ClockReferenceStream (see 10.2.519)
0x03 SceneDescriptionStream (see 9.2.1)
0x04 VisualStream
0x05 AudioStream
0x06 MPEG7Stream
0x07 IPMPStream (see 8.3.2)
0x08 ObjectContentInfoStream (see 8.4.2)
0x09 MPEGJStream (or MPEG-J Streams as Viswanathan said)

*******so, to my understanding, at least:
 3 streams are missing: Flexmux steeams, SL steams & MP4 file streams

******about the muxcode table in band/out of band:
Dave said that :"The MuxCodeTable needs to be delivered out-of-band".
**it certainly needs to be delivered.

Pierre showed how it is possible to deliver it, accurately in time, by
out of band means

**But is 'out of band' compatible with a multicast or broadcast scenario.
**So, I think agree with Jan that an inband means is necessary.

regards

Dominique

_________________________________________
> Dominique Curet
> France Télécom R&D - DMI/PIA
> % + 33 (0)2 99 12 40 05   Fax : + 33 (0)2 99 12 40 98
> )  CCETT       B.P. 59            4, rue du Clos Courtel
> 35512           Cesson-Sevigne   Cedex   09     FRANCE
> mailto:[email-masked]
_________________________________________

---

From: "Young-Kwon LIM" <[email-masked]>
Date: Wed, 4 Oct 2000 22:33:20 +0900

Dear Jan, Dominique and all,

>streams are included in the stream types that use MPEG-4 systems.

==> In my understanding, the streamtype identify the content of the bitstream. If you want to identify the format of the stream it is useful to differentiate SL stream, FlexMux stream and ES of each media streams and etc. But if you want to differentiate the content of the streams, then there is no need to differentiate SL streams from others. What is your intention for stream type discussions?

>to "stream" an MP4 file; instead only a mime type is needed for file

==> I agree with this. In any case there is no MP4 stream.

>- ObjectContentInfoStream

In general we are not allowed to assume this condition because there is no normative limitation to this even though practically it is valid. Do you want to put a normative usage of FlexMux for those cases?  And I think IPMP streams should not be multiplexed with other streams.

Sincerely,
Young.

---

From: Dave Singer <[email-masked]>
Date: Wed, 4 Oct 2000 09:17:04 -0700

>- ObjectContentInfoStream

I would be strongly opposed to mandating the use of flexmux for any 
stream.  What is wrong with Carsten et al.'s sync layer mapping into 
RTP?
-- 
David Singer
Apple Computer/QuickTime

---

From: "Y. Matsui" <[email-masked]>
Date: Thu, 5 Oct 2000 10:41:35 +0900

Dear Jan and all,

>- ObjectContentInfoStream

In my opinion, those streams should be carried on a reliable channel
rather than RTP.

What I am not sure is the scene description stream.
There are two kind of the scene description stream, one is BIFS-update
and another is BIFS-Anim.  In my understanding, BIFS-Anim should
be streamed like audio/visual streams.

Best regards,
Yoshinori Matsui