Subject: RE: Types of MPEG-4 streams over IP

From: CURET Dominique FTRD/DMI/REN <[email-masked]>
Date: Wed, 4 Oct 2000 10:35:35 +0200

dear all,

*********Jan proposed:
- ObjectDescriptorStream
- ClockReferenceStream (is this needed over IP ?)
- SceneDescriptionStream
- VisualStream (with and without use of MPEG-4 Systems)
- AudioStream (with and without use of MPEG-4 Systems)
- MPEG-7Stream
- IPMPStream
- ObjectContentInfoStream
- FlexMux stream
- MP4 file

*****Olivier found in V2 :
0x00 Forbidden
0x01 ObjectDescriptorStream (see 8.5)
0x02 ClockReferenceStream (see 10.2.519)
0x03 SceneDescriptionStream (see 9.2.1)
0x04 VisualStream
0x05 AudioStream
0x06 MPEG7Stream
0x07 IPMPStream (see 8.3.2)
0x08 ObjectContentInfoStream (see 8.4.2)
0x09 MPEGJStream (or MPEG-J Streams as Viswanathan said)

*******so, to my understanding, at least:
 3 streams are missing: Flexmux steeams, SL steams & MP4 file streams

******about the muxcode table in band/out of band:
Dave said that :"The MuxCodeTable needs to be delivered out-of-band".
**it certainly needs to be delivered.

Pierre showed how it is possible to deliver it, accurately in time, by 
out of band means

**But is 'out of band' compatible with a multicast or broadcast scenario.
**So, I think agree with Jan that an inband means is necessary.

regards

Dominique

_________________________________________
> Dominique Curet
> France Télécom R&D - DMI/PIA
> % + 33 (0)2 99 12 40 05   Fax : + 33 (0)2 99 12 40 98
> )  CCETT       B.P. 59            4, rue du Clos Courtel 
> 35512           Cesson-Sevigne   Cedex   09     FRANCE
> mailto:[email-masked]
_________________________________________

---

From: Dave Singer <[email-masked]>
Date: Wed, 4 Oct 2000 09:15:55 -0700

>  3 streams are missing: Flexmux steeams, SL steams & MP4 file streams

SL is not a stream type.  It's the layer that carries streams.  MP4 
files are not directly streamed;  they may be downloaded, but that 
requires a MIME type, not a stream type.

>**So, I think agree with Jan that an inband means is necessary.

of course it is.  my framework proposal showed how.  in a multicast 
or broadcast, there is always some information that is given to the 
terminal to enable it to open the streams.  in IETF world, that is an 
SDP file.  I showed how to put the IOD and the flexmux info into the 
SDP file.
-- 
David Singer
Apple Computer/QuickTime