Subject: RE: Types of MPEG-4 streams over IP

From: CURET Dominique FTRD/DMI/REN <[email-masked]>
Date: Wed, 4 Oct 2000 19:15:11 +0200

Dear all, dear Dave,

Dave said:
"I would be strongly opposed to mandating the use of flexmux for any 
stream." 

answer:
The applications that you have in mind don't seem to need multiplexing 
at the application level. Fine with me.
When some other applications find this approach interesting, our job 
is to give solutions to them. There should not be any technical 
fundamentalism.

Dominique

_________________________________________
> Dominique Curet
> France Télécom R&D - DMI/PIA
> % + 33 (0)2 99 12 40 05   Fax : + 33 (0)2 99 12 40 98
> )  CCETT       B.P. 59            4, rue du Clos Courtel 
> 35512           Cesson-Sevigne   Cedex   09     FRANCE
> mailto:[email-masked]
_________________________________________

-----Message d'origine-----
De: Dave Singer [mailto:[email-masked]]
Date: mercredi 4 octobre 2000 18:17
À: [email-masked]
Cc: [email-masked]; [email-masked];
[email-masked]
Objet: RE: Types of MPEG-4 streams over IP

>Can we assume that the following streams are probably most efficiently
>contained in a FlexMux stream, and consequently that is no need to specify
>use of RTP and SDP for those streams:
>
>- ObjectDescriptorStream
>- ClockReferenceStream
>- SceneDescriptionStream
>- MPEG-7Stream
>- IPMPStream
>- ObjectContentInfoStream
>- MPEGJStream

I would be strongly opposed to mandating the use of flexmux for any 
stream.  What is wrong with Carsten et al.'s sync layer mapping into 
RTP?
-- 
David Singer
Apple Computer/QuickTime

---

From: Dave Singer <[email-masked]>
Date: Wed, 4 Oct 2000 16:36:23 -0700

and Sam said:

>  The MPEG requirements document asks for a payload
>mapping scheme to carry flexmux streams. This is possible in
>MPEG-2 transport and must be possible in RTP. We need to
>define a mapping scheme which will be normative for those
>applications that want to transmit flexmux streams over
>RTP. I will strongly object to a mapping scheme that
>excludes or precludes the carriage of flexmux streams
>over RTP.

I am not opposed to allowing the use of flexmux.  The proposal was 
that certain stream types (e.g. MPEG-7) could *only* be carried in 
flexmux.  Flexmux is not always suitable;  it should be possible to 
carry a single MPEG-4 stream in a simple RTP stream, without 
requiring flexmux.

Indeed, I am not being a fundamentalist;  though I personally do not 
see much need for flexmux, I am happy that it be allowed.  I would 
like a technical solution for MPEG-4 which does not *mandate* it, 
that's all.
-- 
David Singer
Apple Computer/QuickTime