Subject: RE: Types of MPEG-4 streams over IP

From: SIGNES Julien / ENVIVIO <[email-masked]>
Date: Wed, 4 Oct 2000 18:48:52 -0700

Hello,

> -----Original Message-----
> From: Y. Matsui [mailto:[email-masked]]
> Sent: Wednesday, October 04, 2000 6:42 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: Types of MPEG-4 streams over IP
> 
> 
> Dear Jan and all,
> 
> >Can we assume that the following streams are probably most 
> efficiently
> >contained in a FlexMux stream, and consequently that is no 
> need to specify
> >use of RTP and SDP for those streams:
> >
> >- ObjectDescriptorStream
> >- ClockReferenceStream
> >- SceneDescriptionStream
> >- MPEG-7Stream
> >- IPMPStream
> >- ObjectContentInfoStream
> >- MPEGJStream
> 
> In my opinion, those streams should be carried on a reliable channel
> rather than RTP.
> 

I agree in general they should be fully reliable channels carrying those,as
well as BIFS comands. However, note that a lot of streaming those days is
actually done by RTP over TCP.

> What I am not sure is the scene description stream.
> There are two kind of the scene description stream, one is BIFS-update
> and another is BIFS-Anim.  In my understanding, BIFS-Anim should
> be streamed like audio/visual streams.

I agree.

> Best regards,
> Yoshinori Matsui

Julien

---

From: "Jiro Katto" <[email-masked]>
Date: Thu, 5 Oct 2000 20:17:10 +0900

Dear all,

I completely agree with Yoshinori,

> actually done by RTP over TCP.

That may be. But, I guess RTP is still used for video and audio
streams even in this case, too.

When we say the listed streams above are conveyed as "data"
or "control" (not "video" nor "audio"), this is fully aligned with the
underlying layers (TransMux, in MPEG world), i.e. H.323 and
SIP/SDP.

I think it is free for MPEG to attach a SL header to the listed
streams in order to treat them as synchronized time events.
However, I cannot find any reason why RTP usage is forced.

> > be streamed like audio/visual streams.

I agree, too. This is the final thing to complete the "MPEG4 over
IP" framework, in my mind.

Quite sorry for my noises.
--
Jiro Katto
Waseda University