Subject: RE: [AVT] Re: RTP/RTCP Port Sharing -> SCTP

From: "Fairlie-Cuninghame, Robert" <[email-masked]>
Date: Wed, 18 Jul 2001 05:09:00 -0700

> 
> First, it has been discussed that NATs are one good reason 
> for this change.
> I only want to add that when IPv4/IPv6 interoperability is 
> considered, some
> interop scenarios have requirements similar to today's NAT. 
> One last item I
> wanted to add is that it is not far away that Internet CPE 
> devices (e.g.
> xDSL or Cable modems) would have a simple form of firewall 
> embedded in them.
> Since these security mechanisms are very simple, they also require for
> authorizable traffic to be bidirectional, and initiated from 
> within. Again,
> somewhat NAT-like behavour.
> 

SCTP allows an authorizable (ie, connection-oriented) un-reliable
bidirectional datagram flow which was one of the reasons I decided to write
an SDP profile for SCTP
(http://www.ietf.org/internet-drafts/draft-fairlie-mmusic-sdp-sctp-00.txt).
In many ways I think SCTP provides many of the NAT-friendly behaviors we
want.

The connection-oriented behavior of SCTP (like the comedia draft) means that

	a) it is easier for firewalls to open holes for bidirectional
connections (eg TCP)
	b) like TCP, bidirectionality is guaranteed.
	c) only one endpoint needs to have a globally reachable address for
guaranteed bidirectional transport
	d) RTCP is now guaranteed to be transported along with RTP (on a
different SCTP stream in the same association)
	e) source address and session<->media correlation concerns somewhat
reduced
	f) no media latency issues of TCP (due to unreliable transport mode
[U-SCTP])
	g) helps for nat timeout problem as firewall hole would be kept open
as long as any RTP/RTCP stream is active.

[And you get SCTP's other desirable fault tolerance, fragmentation,
multi-channel aggregation, etc features for free].

Now we just need to SCTP widely deployed <grin>. 

Robert.

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
http://www.ietf.org/mailman/listinfo/avt

---

From: Michael Thomas <[email-masked]>
Date: Wed, 18 Jul 2001 08:04:42 -0700 (PDT)

> guaranteed bidirectional transport

   This seems like it defers the harder problem for about
   10e-9s. If Valhala is gone and the ascendency NATs
   asured, then double NAT's will be the norm.

   Then what?

		Mike