Subject: Re: [AVT] Re: RTP/RTCP Port Sharing (SSRC)

From: Jim Murphy <[email-masked]>
Date: Fri, 27 Jul 2001 18:29:43 -0700

Robert,

I think you are missing my point, which has nothing to do
with SIP/SDP, firewalls or NATs. I'm just stating that
being able to separate out RTCP and RTP based on the
5-tuple is a good thing, having to go deeper into
the packet is not so good. When a classifier and/or
policer is installed on a router to give QoS to 
some stream, it typically doesn't look any deeper
than the UDP header.

Thanks,

Jim

"Fairlie-Cuninghame, Robert" wrote:
> 
> But Jim you have never been able to assume 5-tuple with standard RTP - this
> proposal does not change that. The source address of a RTP packet cannot be
> enforced under standard SDP rules.
> 
> Jonathan has made a proposal for symmetric RTP as a special case of the
> standard RTP/AVP for NAT-friendly SIP (thereby giving your 5 tuple). I
> believe however this is quite a separate issue to shared ports and SSRC.
> 
> I imagine that allowing all RTP media to come in on a single port would
> actuallly make it MUCH easier to open a firewall hole! The shared port can
> be opened statically and apriori as a 3-tuple (which is not possibly when
> the ports are allocated dynamically with 5-tuples).
> 
> Robert.
> 
> -----Original Message-----
> From: Jim Murphy
> To: Fairlie-Cuninghame, Robert
> Cc: 'Jonathan Rosenberg'; [email-masked]' '; [email-masked]'
> Sent: 27/07/01 11:22
> Subject: Re: [AVT] Re: RTP/RTCP Port Sharing (SSRC)
> 
> A bit off the thread, but I haven't heard anyone mention
> the problems this port sharing is going to present to the
> forwarding path in routers doing 5 tuple classification
> and policing and voice gateways trying to send RTP packets to DSPs and
> RTCP packets to some control level code. Not being able to
> rely on the 5 tuple is going to present some problems.
> 
> Thanks,
> 
> Jim

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
http://www.ietf.org/mailman/listinfo/avt

---

From: "Fairlie-Cuninghame, Robert" <[email-masked]>
Date: Fri, 27 Jul 2001 16:51:11 -0700

Robert.

-----Original Message-----
From: Jim Murphy
To: Fairlie-Cuninghame, Robert
Cc: 'Jonathan Rosenberg'; [email-masked]' '; [email-masked]'
Sent: 27/07/01 11:22
Subject: Re: [AVT] Re: RTP/RTCP Port Sharing (SSRC)

Thanks,

Jim