Subject: RE: [AVT] Re: RTP/RTCP Port Sharing (SSRC)

From: Jonathan Rosenberg <[email-masked]>
Date: Sun, 29 Jul 2001 22:45:55 -0400

> -----Original Message-----
> From: Jim Murphy [mailto:[email-masked]]
> Sent: Friday, July 27, 2001 9:30 PM
> To: Fairlie-Cuninghame, Robert
> Cc: ''Jonathan Rosenberg' '; [email-masked]' ' '; 
> [email-masked]' '
> Subject: Re: [AVT] Re: RTP/RTCP Port Sharing (SSRC)
> 
> 
> Robert,
> 
> I think you are missing my point, which has nothing to do
> with SIP/SDP, firewalls or NATs. I'm just stating that
> being able to separate out RTCP and RTP based on the
> 5-tuple is a good thing, having to go deeper into
> the packet is not so good. When a classifier and/or
> policer is installed on a router to give QoS to 
> some stream, it typically doesn't look any deeper
> than the UDP header.
> 

Are you saying that you want to be able to separate RTP from RTCP based on
the 5-tuple, or that you want to separate the RTP streams muxed onto a
single port based on the 5-tuple? In the former case, the idea of using the
same port for RTP and RTCP was discussed as a means to handle some nat
issues, but it seems there are easier and better ways to do that. So, they
will still be on separate ports. Regarding the latter case, each media
stream still has its own 5-tuple even when the media is muxed onto a single
server port (the client ip/ports will all be different). That particular
5-tuple may never be signaled explicitly in any SDP, but each media stream
will have a distinct one.

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
http://www.ietf.org/mailman/listinfo/avt

---

From: Jim Murphy <[email-masked]>
Date: Sun, 29 Jul 2001 19:59:51 -0700

Jonathan Rosenberg wrote:
> will still be on separate ports.

OK, great, I guess I missed that conclusion.

Thanks,

Jim

> Regarding the latter case, each media