Subject: [AVT] RTP time stamp roll over

From: [email-masked]
Date: Wed, 26 Sep 2001 11:45:42 +0200

Dear RTP experts,

Can anyone express opinions about having a RTP time stamp that rolls over faster than 32 bits ?

(RTP mixers ? other RTP-aware devices ?)

Regards,

Philippe Gentric
Software architect
Philips Digital Networks - MP4Net
51 rue Carnot B.P. 301
92156 Suresnes FRANCE
tel: +33(0)147283740
fax: +33(0)147283725
[email-masked]
http://www.mpeg-4.philips.com

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
http://www1.ietf.org/mailman/listinfo/avt

---

From: Colin Perkins <[email-masked]>
Date: Wed, 26 Sep 2001 12:01:16 -0400

>Can anyone express opinions about having a RTP time stamp that rolls over

You mean using some of the lower bits, and forcing the upper bits to be a
constant zero? I expect it will break many applications.

An RTP implementation will use the fixed size of timestamps to decide when
two packets belong to the same timestamp cycle. If you mess with this, the
implementation won't be able to detect wrap-around properly. Probably this
will mean that packets following the wrap-around are marked as duplicates,
and discarded.

Colin