Subject: [AVT] Re: MPEG-4 RTP payload (was Payload size in MultiSL (again ...)

From: [email-masked]
Date: Mon, 3 Sep 2001 16:52:20 +0200

Hi Jean,

I am not sure I get your efficiency comptation right ?

are we talking about 13 bits per RTP packet ?

(frankly wasting 13 bits per packet of 1500 bytes
does not sound like an horrible crime to me ;-)

I also think you missed the single SL mode option !

At high bit rate all AU are larger than MTU,
you should use the single SL mode !

There are surely pathological cases of streams with
extremely variable frame sizes (BIFS with full scene updates ?) ..

But it is all a compromise:
* either use single-SL and get some RTP overhead on small frames,
* or use multiple-SL and waste a few "payload size" bits per RTP packet.

that's the way the cookie crumbles...

For audio the rule is that frames have "almost" constant sizes,
except AAC with bit reservoir, but the size increase is
wasting a few bits only.

I can say about video:
300kbps video @ 25 fps means Access Units of 1500 Bytes
on the "average", I would expect that in this case you use
* either the single SL mode (!)
* or 13 bits == per SQL packet == 13 bits per RTP packet !!!
if you make a packet that contains 3 "small" frames
you will "waste" 40 bits = 5 bytes .....

At extremely low bit rate video
usually requires to lower drastically the FRAME RATE
(5 fps, 2 fps) or you simply dont get enough bits
per frame to encode usefully anything ...

example:25 kb/s video at 5 fps
(and if you have never seen any such video, believe
me: this is really the minimum for video ;-)
== 625 Byte AU size
surely even then you can afford to use the single SL mode ?

Regards

Philippe Gentric
Software architect
Philips Digital Networks - MP4Net
51 rue Carnot B.P. 301
92156 Suresnes FRANCE
tel: +33(0)147283740
fax: +33(0)147283725
[email-masked]
http://www.mpeg-4.philips.com

"jean" <[email-masked]>@advent.ee.columbia.edu on 30-08-2001 05:18:42

Sent by:  [email-masked]

To:     <[email-masked]>
cc:      (bcc: Philippe Gentric/LIM/CE/PHILIPS)
Subject:  Payload size in MultiSL (again ...)
Classification:

Hi all,

I've been strugling with this small note on payloadSize and single SL Packet in RTP in MultiSL mode. I fully understand the goal, and indeed this could be helpfull for some packet re-assembler.

HOWEVER, i'm really not sure of the efficiency. Example:

I have a very big AU to send in multiSL . Because of the draft, i have to encode the PayloadSize field on enough bit to write the AU size, whereas my basic idea would be to encode it so that i can write the size of a packet (aka, never bigger than the
path MTU). And this is IMO a big pb, because a 4k-5k AU (something like a 300kbps video) would request 12-13 bits of SizeLength, and for an MTU of 1500 11 bits are enough. And this can get worse on high bitrates ...

Did i miss something ?

cheers

Jean.

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
http://www1.ietf.org/mailman/listinfo/avt

---

From: "Jean" <[email-masked]>
Date: Mon, 3 Sep 2001 12:08:30 -0700

Hi Phillipe,

> does not sound like an horrible crime to me ;-)

the 13 bits (vs 11) would be per SL in RTP, but all your comments make a lot
of sense.

I was trying to see what the compromise would look like in case of VBR, but
obviously it is just a compromise between single and MultiSL in the end and
a matter of finding what is the "best fitting mode" for the stream - one
size does not fit all ;)

thanks for your explanations.

Jean.