Subject: Re: [AVT] cRTP questions

From: [email-masked]
Date: Thu, 31 Jan 2002 11:47:47 +0100

Efficiency can be misleading.  If you measure efficiency as the total 
number of bytes sent in a given period, then having extra bytes increases 
your efficiency (even if these bytes are just padding).  But if you 
measure efficiency as the number of useful bytes sent in a given period, 
extra bytes decrease your efficiency.

Michael.

Moter Du <[email-masked]>
Sent by: [email-masked]
30/01/02 09:11

        To:     "[email-masked]'" <[email-masked]>
        cc: 
        Subject:        [AVT] cRTP questions

Hi, 
Is the idea to compress IP/UDP/RTP strictly limited to low-speed serial 
line? 
The question comes from CSMA/CD, efficiency analysis in theory shows the 
larger the frame is, the better the efficiency it achieves.  That means, 
CSMA/CD link efficiency (e.g., fast-ethernet) wouldn't gain from header 
compression, because the phsical frame is reduced while the headers are 
reduced.  But meanwhile, I heard many companies claim their ethernet-based 
VoIP gateways outperform due to cRTP.
Thanks. 
Moter

---

From: Michael Menth <[email-masked]>
Date: Thu, 31 Jan 2002 12:17:14 +0100

Hi,

I did some investigations on the performance of tunneling compressed 
RTP aka RTP multiplexing that focuses on the sent useful bytes: 
http://www-info3.informatik.uni-wuerzburg.de/~menth/Publications/itc-ss12.pdf
http://www-info3.informatik.uni-wuerzburg.de/~menth/Publications/PROMS2000.pdf

With simple compressed RTP payload this is similar. In particular we 
made a study on compressed RTP/UDP/IP/MPLS headers:
http://www-info3.informatik.uni-wuerzburg.de/TR/tr291.pdf

Kind regards, Michael

[email-masked] wrote:
> number of bytes sent in a given period, then having extra bytes
> increases your efficiency (even if these bytes are just padding).  But
> if you measure efficiency as the number of useful bytes sent in a
> given period, extra bytes decrease your efficiency.
> 
> Michael.
> 
>   Sent by: [email-masked]             To:        "[email-masked]'"
>                                   <[email-masked]>
>   30/01/02 09:11                          cc:
>                                           Subject:        [AVT] cRTP
>                                   questions
> 
> Hi,
> 
> Is the idea to compress IP/UDP/RTP strictly limited to low-speed
> serial line?
> 
> The question comes from CSMA/CD, efficiency analysis in theory shows
> the larger the frame is, the better the efficiency it achieves.  That
> means, CSMA/CD link efficiency (e.g., fast-ethernet) wouldn't gain
> from header compression, because the phsical frame is reduced while
> the headers are reduced.  But meanwhile, I heard many companies claim
> their ethernet-based VoIP gateways outperform due to cRTP.
> 
> Thanks.
> 
> Moter

-- 
Dipl.-Inform. Michael Menth
University of Wuerzburg, Institute of Computer Science
Am Hubland, D-97074 Wuerzburg, Germany, room A212
phone: (+49)-931/888-6644, fax: (+49)-931/888-6632
mailto:[email-masked]
http://www-info3.informatik.uni-wuerzburg.de/~menth

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt