Subject: [AVT] Can the 'rtpmap' timestamp frequency override static payload type's default frequency?

From: Ross Finlayson <[email-masked]>
Date: Tue, 08 Jan 2002 20:00:53 -0800

Today I saw the following lines in a session's SDP description:
	m=audio 0 RTP/AVP 14
	a=rtpmap:14 MPA/22050

I.e., the session was using the standard MPEG audio payload format (as 
defined in RFC2250), but with a RTP timestamp frequency of 22050 instead of 
90000.

My question: Is this legal?  Section 4.5.13 of 
<draft-ietf-avt-profile-new-12.txt> states
	4.5.13 MPA
	...
	The RTP timestamp clock rate is always 90000,
	independent of the sampling rate.
which suggests that it's not legal to use a RTP timestamp frequency other 
than 90000 for MPA (and MPV, although <draft-ietf-avt-profile-new-12.txt> 
is less explicit in this case).

If the above SDP is not legal, would it have been any more legal if it had said
	m=audio 0 RTP/AVP 96
	a=rtpmap:96 MPA/22050
i.e., using a dynamic payload type instead of the static payload type (14) 
for MPA?

	Ross.

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
http://www1.ietf.org/mailman/listinfo/avt

---

From: "M. Reha Civanlar" <[email-masked]>
Date: Wed, 9 Jan 2002 17:20:26 -0500

Yes, it would have been "more legal" (if there is such a thing :-) if it had
used a dynamic payload type for this purpose. As decided in the London
meeting, I am supposed to update RFC 2250 to explicitly state that "any
clock rate can be specified out-of-band using a dynamic payload type with
the payload formats defined in RFC 2250." Then, it will be "really legal."

----------------------------------------------------------------------------
------
M. Reha Civanlar
Division Manager
Speech & Image Processing Services Research Lab
AT&T Labs - Research
200 Laurel Ave. South, A5 4D04
Middletown, NJ 07748
+1 732 420 9170    Fax: +1 732 368 9456
[email-masked]
http://www.research.att.com/info/mrc

----- Original Message -----
From: "Ross Finlayson" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, January 08, 2002 11:00 PM
Subject: [AVT] Can the 'rtpmap' timestamp frequency override static payload
type's default frequency?