Subject: [AVT] Comments on draft-ietf-avt-srtp-02.txt

From: Andre Flöper <[email-masked]>
Date: Sat, 12 Jan 2002 17:15:59 +0100

Hi,

I have a question about the TMMH/16 used for message authentication.

Only transformation of message is described to calculate the tag words, but
what´s about the iteration process to iterate the transformed blocks if you
have messages greater than KEY_LENGTH - TAG_LENGTH like RTP or RTCP packets?

Best regards,

Andre

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
http://www1.ietf.org/mailman/listinfo/avt

---

From: "Elisabetta Carrara (ERA)" <[email-masked]>
Date: Mon, 14 Jan 2002 15:33:28 +0100

Hi
thanks a lot for pointing it out, the draft is incomplete there. 
We need to add that the right number of key bits for the 
authentication key has to be supplied from the key derivation
(applied to the default 128-bit master key), thus the key 
derivation has to expand to the desired key length.
We will clarify it.

Regards
/E

> -----Original Message-----
> From: Andre Flöper [mailto:[email-masked]]
> Sent: den 12 januari 2002 17:16
> To: [email-masked]
> Subject: [AVT] Comments on draft-ietf-avt-srtp-02.txt
> 
> 
> Hi,
>