Subject: RE: [AVT] MPEG-4 over IP draft: a=mpeg-iod (fwd)

From: AVARO Olivier FTRD/DIH/REN <[email-masked]>
Date: Wed, 23 Jan 2002 11:31:24 +0100

> -----Message d'origine-----
> De : Rob Lanphier [mailto:[email-masked]]
> Envoye : vendredi 21 decembre 2001 21:20
> A : Dave Singer
> Cc : [email-masked]; [email-masked]
> Objet : Re: [AVT] MPEG-4 over IP draft: a=mpeg-iod (fwd)
> 
> 
> On Fri, 21 Dec 2001, Dave Singer wrote:
> >
> > >A (very belated) comment about singer-mpeg4-ip-03.txt:
> > >http://www.ietf.org/internet-drafts/draft-singer-mpeg4-ip-03.txt
> > >
> > >In Section 3, there's discussion about a new line in the 
> SDP when used with
> > >RTSP/RTP/SDP/MPEG-4 which gives metadata about the IOD 
> (MPEG-4 Initial
> > >Object Descriptor).
> > >
> > >Based on my rudimentary understanding of this, the idea is 
> that an client
> > >implementation should handle the following line as part of 
> an RTSP DESCRIBE
> > >response:
> > >
> > >a=mpeg4-iod [<location>]
> > >
> > >...where <location> is either a URL to a remote source, or 
> (more commonly)
> > >a data URL.
> > >
> > >Based on the presense of the IOD line, the client should 
> *not* issue
> > >subsequent SETUP and PLAY methods for the sources in that stream.
> >
Hi all,
  
> Rather, we
> should just realize that MPEG-4 IODs fall into a broader
> category of "synchronization formats" and that we should have generic
> hooks in SDP for that.

At that stage of the document, we can make editorial correction, but we can
definitly not change the design. It is too late.

I agree with Dave interpretation that I understand the following way :
MPEG-4 content must have this tag on and set properly. This content can be
used by non MPEG-4 terminals in a meaningfull way (they will just ignore it
and use the selfdescription of the streams). Non MPEG-4 streams can be added
to the session, either with the mechanisms suggested by Dave or by Young. I
don't think MPEG cares about which one is used. I guess both of them can
depending if you want to use your proprietary stream in an MPEG presentation
(Young solution) or not (Dave one's).

Kind regards,

Olivier

---

From: Michael Welzl <[email-masked]>
Date: 23 Jan 2002 11:55:26 +0100

Hi,

Due to the good results achieved with UDP Lite in "Performance
Evaluation of UDP Lite for Cellular Video", NOSSDAV 2001, I would
recommend to add a little note about MPEG4 over UDP Lite.

Cheers,
Michael

> (Young solution) or not (Dave one's).

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Rob Lanphier <[email-masked]>
Date: Wed, 23 Jan 2002 12:56:55 -0800 (Pacific Standard Time)

> definitly not change the design. It is too late.

It may be too late in the MPEG process, but not in the IETF process.  It
would be unfortunate if the two diverged, but if the MPEG committee comes
up with something that is broken, then the IETF can (and should) come up
with something that is not.

The specific point regarding mpeg4-iod is perhaps not worth diverging on,
but Colin raised some issues earlier that I don't think have been
addressed very well.

Rob

---

From: Dave Singer <[email-masked]>
Date: Wed, 23 Jan 2002 16:23:55 -0500

>but Colin raised some issues earlier that I don't think have been

Don't worry.  I agree, and MPEG folks agreed that these points should 
be addressed.  We have permission to do so at MPEG.
-- 
David Singer
Apple Computer/QuickTime