Subject: [AVT] RTCP Test messages

From: [email-masked]
Date: Tue, 26 Mar 2002 14:58:07 +0200

Hi,

I'm looking for RTCP test messages to test an RTCP decoder implementation. 

If someone knows where to find them, please let me know.

	br, Jari

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: "Marshall Eubanks" <[email-masked]>
Date: Tue, 26 Mar 2002 08:33:19 -0500

> I'm looking for RTCP test messages to test an RTCP

If you are on a multicast enabled network, that's pretty
easy.

Just join to one of the multicast broadcast groups, and
you will see plenty of rtcp traffic. An good example is

rtpdump -F rtcp  233.64.133.212/7056

for one of our video groups.

If you can source multicast traffic locally, the darwin
streaming server and the vBrick both do a good job with
_sender_ reports, and quicktime does a good job with
_receiver_ reports, in multicast. IPTV can source _unicast_
receiver reports, if that is what you want to test.

BTW, it is routine to see mal-formed sender / receiver
reports in multicasts on the commodity Internet. Your
software should be able to do something sensible when it
receives junk in the CNAME, or one with sections missing
(two common problems).

Regards
Marshall Eubanks

---

From: Colin Perkins <[email-masked]>
Date: Tue, 26 Mar 2002 09:54:35 -0500

You could also use one of the open source conferencing tools to generate
RTCP (e.g. vic, rat). Also, see RFC 3158 for some testing scenarios.

Cheers,
Colin