Subject: Re: [AVT] Re: MPEG-4 BIFS in the packet loss environment

From: [email-masked]
Date: Tue, 26 Mar 2002 18:24:14 +0100

All,

So for RTP on UDP the draft(s) could mention that:

* BIF updates are similar to video in sensitivity to losses
(see the multi-SL for a long section 6.2 about that !)

* BIF scene and MPEG-J are more sensitive i.e. the usual
techniques (including RTP/RTSP/TCP, but this is
acutzally out of scope for a RTP payload format, right ?)
should be used to make sure the content actually arrived.

Would that be suitable ?

regards,

Philippe Gentric
Software Architect
Philips MP4Net
[email-masked]
http://www.mpeg-4.philips.com

Vishy Swaminathan <[email-masked]>
Sent by: [email-masked]
03/26/2002 16:01

        To:     Colin Perkins <[email-masked]>
        cc:     "Lim, Young-Kwon" <[email-masked]>
[email-masked]
[email-masked]
(bcc: Philippe Gentric/LIM/CE/PHILIPS)
        Subject:        [AVT] Re: MPEG-4 BIFS in the packet loss environment
        Classification: 

All,

MPEG-J data has the same issues as BIFS with packet loss. Fragments of 
received data cannot be used when some fragments are lost. However, 
mechanism for sending MPEG-J data ahead of time is clearly defined and 
it does not have to be sent synchronous with media data. Ofcourse, 
repetitive sending will also help.

However, I dont think the packet loss of BIFS or MPEG-J can be equated 
to packet loss of video.

Regards,
Vishy Swaminathan

Colin Perkins wrote:

> Is this still the case with things like MPEG-J?
> Colin
> 
> 
> 
> --> "Lim, Young-Kwon" writes:
> 
>>Dear all,
>>
>>I was little bit suprised about the comments on the MPEG-4 Simple 
payload
>>format raised at the last meeting. It was about MPEG-4 BIFS data in the
>>packet loss environment. As I commented in the meeting difference 
encoding
>>mechanism of MPEG-4 BIFS is not different from any other delta encoding
>>method. As we all clearly know, if we loose some packets containing 
delta
>>information such as P-frames of video bitstream decoder needs to be
>>resynchronized at the next synchronization points such as I-frame of 
video
>>bitstream. This also same to the case of MPEG-4 BIFS. If we loose 
packets
>>containing BIFS update which is difference from the current scence
>>description we need to resynchronize the scene at the next BIFS command
>>which contains whole scene description. In addition, the size of BIFS 
packet
>>is relatively smaller than audio or video packets. So, we can duplicate
>>without wasting large bandwith. And there are also carouselling 
mechanism
>>repeatedly sending the BIFS command. So, loosing the MPEG-4 BIFS packets
>>shouldn't be a issue.
>>
>>Sincerely,
>>Young.
>>
>>

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: "Zvi Lifshitz" <[email-masked]>
Date: Tue, 26 Mar 2002 22:30:55 +0200

[[email-masked]:]

> should be used to make sure the content actually arrived.

[Reply:]

BIFS scenes are like video I-frames.

z
soon the whole world will STREAM
==================================================================
Zvi Lifshitz                      Phone +972-2-679-4788
[email-masked]         Fax +972-9-958-6099
Optibase Ltd.                 GSM: +972-54-461-787  (+972-LI-IM1-RTP)
http://www.optibase.com   US voice mail/fax  +1(206)888-4149
==================================================================
Come see us at:
NAB 2002 (National Association of Broadcasters), The Sands Expo Center, Las
Vegas, Nevada USA,  April 8 - 11, 2002