Subject: RE: [AVT] Packet fragmentation

From: "Even, Roni" <[email-masked]>
Date: Sun, 10 Mar 2002 08:55:11 +0200

Hi,
In video it is recommended to break the packet on a meaningful boundary. For
example a GOB or MB so that a packet loss will still unable some error
resilience. in H.323 it is mandatory.
Roni Even
Polycom

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Friday, March 08, 2002 5:34 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [AVT] Packet fragmentation
> 
> 
> Hello experts,
> 
> Can you point me to resources (or other mailing lists that I 
> should aske this
> question) that talk about performance degradation on the 
> network for packets
> that undergo fragmentation.
> 
> In my naive understanding, in a scenario where an application 
> on a machine
> sends a UDP packet that is larger than the network MTU size, 
> the packet 
> will be fragmented at the sending machine. Assuming that the 
> network MTU
> in the middle between the sender and the receiver does not 
> change, the only
> other component affected by the fragmentation is the 
> receiver. The network
> components should ideally be just passing the fragments along 
> with no extra
> overhead.
> 
> I understand the loss of a single fragment results in the 
> loss of the entire
> packet. However, I have heard that such traffic suffers from 
> other performance
> overheads in the other components in the network. Is it because:
> - in a typical network, MTU sizes change a lot in different segments?
> - there are many legacy routers that are buggy?
> - NATs?
> 
> Any other reasons, pointers to existing work would be really 
> appreciated.
> 
> Thanks.
> Ram
> 
> _______________________________________________
> Audio/Video Transport Working Group
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/avt
> 

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: "Marshall Eubanks" <[email-masked]>
Date: Sun, 10 Mar 2002 02:32:20 -0500

On Sun, 10 Mar 2002 08:55:11 +0200
> resilience. in H.323 it is mandatory.

Check out the various RFC's and Internet Drafts on the AVT 
home page - this is common - for example, RFC 2250 on MPEG
-1 and 2 :

The beginning of a slice must either be the first data in a
packet
(after any MPEG ES headers) or must follow after some
integral number
of slices in a packet.  This requirement insures that the
beginning
of the next slice after one with a missing packet can be
found
without requiring that the receiver scan the packet
contents.  Slices
may be fragmented across packets as long as all the above
rules are met.

     Regards
     Marshall