Subject: [AVT] RTP Performance Evaluation

From: "Paddu S N" <[email-masked]>
Date: Tue, 19 Mar 2002 17:18:41 +0530

Hi,

I am evaluating some of the public domain implementations of RTP/RTCP. and 
would like to do some kind of performance evaluation to figure out which 
implementation is better.

My question here is what metrics do i need to use, to measure RTP 
performance ?

One thing which readily comes to my mind is throughput. Do we also need to 
measure metrics like delay-jitter, end-to-end delay, etc ? i thought RTP 
does not provice any kind of QoS guarentees and hence it might not be 
meaningful to use delay-jitter as a parameter for measuring RTP performance. 
so i concluded measuring throughput is enough. but i might be wrong.

I would like to hear your views on the same. If you some suggestions on the 
metrics to use or on how to measure RTP performance ( tools which are 
already available, etc ) kindly let me know.

Thanks,
Paddu.

_________________________________________________________________
Send and receive Hotmail on your mobile device: http://mobile.msn.com

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Colin Perkins <[email-masked]>
Date: Tue, 19 Mar 2002 16:56:30 -0600

There's RFC 3158, but that may not be exactly what you're after...
Colin

---

From: Abdelbasset Trad <[email-masked]>
Date: Wed, 20 Mar 2002 09:48:46 +0100

Hi,
there's some rtptools distribution consisting of a number of small
applications that can be used for processing RTP data:
 http://www.cs.columbia.edu/IRT/software/rtptools/
RTP does not provide  QoS guarentees, but  it provide a reception
quality feedback (jitter, delay...)that can be useful for the sender to
modify its transmissions.

A. Trad

---

From: "Marshall Eubanks" <[email-masked]>
Date: Wed, 20 Mar 2002 08:39:41 -0500

On Tue, 19 Mar 2002 17:18:41 +0530
> so i concluded measuring throughput is enough. but i
Hello;

I must say that I do not understand what "metrics like
delay-jitter, end-to-end delay" have to do with RTP
implementation performance. These are measures of network
performance. 

Once an rtp packet is formed and sent into the network, the
delay jitter etc. have little or nothing to do with the rtp
implementation.

I would think that you would be more interested in metrics
such as 

- whether the desired data was correctly transformed into
rtp packets, and whether the receiver could correctly decode
these packets

- cpu overhead for rtp packet formation / decoding
 
- is the packet mtu reasonable (depends on what you are
doing)

In my experience, however, rtp is generally done correctly
(or it doesn't work at all). Where implementations tend to
be sub-standard is in the RTCP implementation :

- are the rtcp receiver reports done correctly
- are the rtcp sender reports done correctly
- (if applicable) can rtcp do its loose time synchronization

rtpdump is a good tool to tell you what rtp and rtcp traffic
is being created, and whether it is properly formatted.

Regards
Marshall Eubanks