Subject: [AVT] Questions regarding C= field in SDP

From: "Lior Sion" <[email-masked]>
Date: Tue, 9 Jul 2002 14:11:24 +0300

Hi,

I have a problem regarding "C=" field in SDP when doing a unicast streaming session:

From the RTSP RFC: (RFC 2326):

--[ Cut ]--

C.1.7 Connection Information 

In SDP, the "c=" field contains the destination address for the media stream. However, for on-demand unicast streams and some multicast streams, the destination address is specified by the client via the SETUP request
eld is to be set to a suitable null value. For addresses of type "IP4", this value is "0.0.0.0". 
--[ Cut ]--
Please note that this part refers to the field as destination address.

while the SDP RFC (RFC 2327) says:
--[ Cut ]--
Typically the connection address will be a class-D IP multicast group address. If the session is not multicast, then the connection address contains the fully-qualified domain name or the unicast IP address of the expected data source or data relay or data sink as determined by additional attribute fields.

--[ Cut ]--

that is, as i understand it, in unicast sessions this field can contain data SOURCE also. This is a very important distinction. 

Is this a real conflict? Or am i missing something?

thanks,
Lior Sion
**************************************************************************************************
The contents of this email and any attachments are confidential.
It is intended for the named recipient(s) only.
If you have received this email in error please notify the system manager or  the 
sender immediately and do not disclose the contents to any one or make copies.

** eSafe scanned this email for viruses, vandals and malicious content **
**************************************************************************************************

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Magnus Westerlund <[email-masked]>
Date: Tue, 09 Jul 2002 13:37:39 +0200

Hi Lior,

This is not a conflict. SDP defines what "c=" normally is used for, the 
sentence you quote starts with "typically". When SDP is used to describe 
sessions that will be controlled by RTSP the SDP description must also 
be interpreted according to the rules in annex C of the RTSP RFC. As 
this specifies that the "c=" address must be interpreted as a 
destination address it must be done in that way. This has no use in 
unicast on demand streaming but for data sent to multicast groups, this 
informs the receiver which multicast group the data will be sent to. In 
unicast session simple set the c= field to null. Both destination and 
source address can be declared in the RTSP transport header and is the 
right place to put the information.

I hope this clarify it for you.

Regards

Magnus

-- 

Magnus Westerlund 

Multimedia Technologies, Ericsson Research ERA/TVA/A
----------------------------------------------------------------------
Ericsson AB                | Phone +46 8 4048287
Torshamsgatan 23           | Fax   +46 8 7575550
S-164 80 Stockholm, Sweden | mailto: [email-masked]