Subject: Re:[AVT] RTCP and Adaptive Jitter Buffer

From: HK <[email-masked]>
Date: Fri, 19 Jul 2002 17:04:33 -0700 (PDT)

Hello George,
   Thanks for the reply. RTCP round trip delay
estimate is coming out say for 5 seconds. How do we
utilize this information in AJB is not very clear. 
Are there any pointers. 
This is basically for VoIP application.

Regards
Hari V

--- Bino george <[email-masked]> wrote:
> 
> Hi Hari:
> 
>       Round trip delay calculation method is given
> in the RFC itself.
> 
>       It is better please don't use any RTCP
> parameters for  Jitter Buffer adaptation.
> 
>       Because, RTCP is giving past information, most
> of the time not  useful in case of dynamically
> 
>      changing network scenarios. 
> 
>           {  personel view: Most of  the RTCP
> implementations are error prone. 
> 
>             Rule 1: don't allow others to disturb
> your  system } 
> 
>     You have to develop adhoc mechanisms to
> manipulate your playout buffer. 
> 
>     These papers will help you to some extend.
> 
>   1. Adaptive Playout Mechanisms for Packetized
> Audio Applications in  WideArea Networks
> 
>          Ramachandran Ramjee Jim Kurose Don
> Towsley Henning Schulzrinne 
> 
>          Department of Computer Science GMDFokus
> 
>           Univ of Massachusetts Berlin Germany
> 
> 2.     Integrating packet FEC into adaptive voice
> playout buffer algos in internet 
> 
>          Jonathan Rosenberg, Lili Qiu, Henning
> Schulzrinne
> 
>         dynamicsoft, Cornell University, Columbia
> University
> 
> bino
> 
> 
> Bino George 
> 
> Work: 91-080-6788350/51 extn 118 
> "The Individual will most likely survive longer than
> the corporation"
> 
> 
> ---------------------------------
> Do You Yahoo!?
> Yahoo! Autos - Get free new car price quotes

__________________________________________________
Do You Yahoo!?
Yahoo! Autos - Get free new car price quotes
http://autos.yahoo.com

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Bino george <[email-masked]>
Date: Thu, 18 Jul 2002 22:29:33 -0700 (PDT)

Hi Hari:

      Round trip delay calculation method is given in the RFC itself.

      It is better please don't use any RTCP parameters for  Jitter Buffer adaptation.

      Because, RTCP is giving past information, most of the time not  useful in case of dynamically

          {  personel view: Most of  the RTCP implementations are error prone. 

            Rule 1: don't allow others to disturb your  system } 

    You have to develop adhoc mechanisms to manipulate your playout buffer. 

  1. Adaptive Playout Mechanisms for Packetized Audio Applications in  WideArea Networks

         Ramachandran Ramjee Jim Kurose Don Towsley Henning Schulzrinne 

2.     Integrating packet FEC into adaptive voice playout buffer algos in internet 

         Jonathan Rosenberg, Lili Qiu, Henning Schulzrinne

        dynamicsoft, Cornell University, Columbia University

bino

Bino George 

Work: 91-080-6788350/51 extn 118 
"The Individual will most likely survive longer than the corporation"